Installing to EAP1300 fails

The wiki page to this device seems lean. Does it work?

I get this error:

tmp # sysupgrade -v openwrt-19.07.5-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin
sh: d00dfeed: bad number
XXXXXXXXX Error: mandatory section(s) missing from "openwrt-19.07.5-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin". Abort...
Image check 'platform_check_image' failed.

It's failing because it was looking for one of these mandatory sections which
is not present: ubi, hlos fs, hlos.

/lib/upgrade # dumpimage -l openwrt-19.07.5-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin
FIT description: ARM OpenWrt FIT (Flattened Image Tree)
Created: Sun Dec 6 01:31:03 2020
Image 0 (kernel@1)
Description: ARM OpenWrt Linux-4.14.209
Type: Kernel Image
Compression: gzip compressed
Data Size: 2891774 Bytes = 2824.00 kB = 2.76 MB
Architecture: ARM
OS: Linux
Load Address: 0x80208000
Entry Point: 0x80208000
Hash algo: crc32
Hash value: 07247169
Hash algo: sha1
Hash value: f991b99bac3eb1e380bdaa8674ab885e3bbf01c7
Image 1 (fdt@1)
Description: ARM OpenWrt engenius_eap1300 device tree blob
Type: Flat Device Tree
Compression: uncompressed
Data Size: 16010 Bytes = 15.63 kB = 0.02 MB
Architecture: ARM
Hash algo: crc32
Hash value: 5aa60df8
Hash algo: sha1
Hash value: 4ce2b5e84d97f85e3bbd4836a21665ec4107f1e2
Default Configuration: 'config@4'
Configuration 0 (config@4)
Description: OpenWrt
Kernel: kernel@1
FDT: fdt@1

Is that an incomplete image the way sysupgrade things it is, or would it be
OK to try forcing this to install?

The symptoms are the same as this earlier post but the stock firmware I have running is 3.7.4.

1 Like

ping. Can anyone advise if it's safe for me to force the upgrade given what I found in the image?

I tried asking for help in another section on this website and no one offered any help so trying here.

openwrt is building an image for eap1300, but there is next to zero helpful info in the device page. I'm willing to help fix this if I can get openwrt installed but everything I have tried so far has failed.

-- identified tx/rx on the pins and tried connecting a serial port, no serial output was observed.

-- tried sysupgrade but complains the image is missing sections. is it possible we are not building the image right? stock is running very old openwrt image 12.09.1. is it possible that sysupgrade just doesn't jump +5 years ahead to image 17.0, which is when this image for this device first appeared?

-- I'm willing to did and put in effort to make this work, then fix up the device web page, but I need guidance. Can someone with good debug experience PLEASE help me?

-- someone on reddit mentioned they had to first jump to stock 3.5.5, then sysupgrade worked
for them. Sadly that image is not available on engenious website.

-- is it possible/worth effort to copy over binaries and upgrade files from newer image?

Do the installation instructions in the git commit help?

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=2b4ac79a791d9451f601d494dde2e71864174358

  1. I couldn't get the serial to work. I wonder if it's really disabled. I'm ordering a scope to get more info on this.

  2. v3.5.3.2 is not available on their website any more. but I did upgrade to
    v3.7.8_c1.9.51 where I run into this problem:

/tmp # sysupgrade -v /tmp/openwrt-19.07.2-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin
sh: d00dfeed: bad number
Error: mandatory section(s) missing from "/tmp/openwrt-19.07.2-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin". Abort...
Image check 'platform_check_image' failed.

then with -F:

/tmp # sysupgrade -F -v /tmp/openwrt-19.07.2-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin
sh: d00dfeed: bad number
Error: mandatory section(s) missing from "/tmp/openwrt-19.07.2-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin". Abort...
Image check 'platform_check_image' failed but --force given - will update anyway!
etc/avahi/avahi-daemon.conf
etc/config/acd
....

nothing else happens. still does not do any upgrade.

Tried 21.02.0-rc3 too:

/tmp # sysupgrade -v /tmp/openwrt-21.02.0-rc3-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin
sh: d00dfeed: bad number
Error: mandatory section(s) missing from "/tmp/openwrt-21.02.0-rc3-ipq40xx-generic-engenius_eap1300-squashfs-sysupgrade.bin". Abort...
Image check 'platform_check_image' failed.

Hey goldenhour. I'm just starting the fight to get one of my EAP1300 s to take a OpenWRT image... I'll try to update this thread as I find more information, or at least with my experience.