Installing OpenWRT in a X86 System in a partition, having both WIN11 and OpenWRT

That does it. I'm going back to bed.

In (amended) response to @Exio0, Ctrl-F is your friend.

Hint: you're looking for a kernel module (kmod). That might help you find the right subfolder where the package might reside...

found it but when im trying to install it...

root@OpenWrt:/tmp# opkg install kmod-rtw88_5.10.176+5.15.92-1-1_x86_64.ipk
Unknown package 'kmod-rtw88'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kmod-mac80211 for kmod-rtw88
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-rtw88 found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package kmod-rtw88.

will install this too and lets see kmod-mac80211

Yeah, that's the joy of trying to install stuff offline. If you have Internet access, the package dependencies get resolved automatically. Without Internet access, you get to do it the hard way. Good luck!

Right. Another caffeine-deprivation thought: that URL I posted earlier, for the packages, is for the 22.03.05 branch. If you've rolled your own image, then I don't know if those packages will or won't work, or if you might need to look in a different tree for the packages. Apologies in advance...

... OR (drumroll) ...
just create a new image with the packages included, using the online image builder.

1 Like

yup, will do this, this packages has so many dependencies to install them manually..

Its enough if i add kmod-mac80211 to the image builder or do i need to add kmod-mac80211-hwsim_5.10.176+5.15.92-1-1_x86_64 ?

whatever the package needs, it should pull automagically, just like luci installed uhttpd, etc.

1 Like

nice, then i have only to add kmod-rtw88 package

once installed the RTW88 pkg...

No wireless appeared...

and it is installed...

rebooted too, or was it done using sysupgrade ?

sysupgrade with his reboot and then rebooted manually

Should i try a new installation? it have sense?

no, there's no point.

you can study the system log, see what it says about the wifi card.

As in my town says... Four eyes see more than two...

System Log

Kernel Log

Sincerely i cant see anything respecting the wifi card, can see the Eth bringing up, but not much more...

10ec:c821 mentioned once ...

at least we seem to have the right module, but this is from a 6.1 kernel.

[root@atlantis ~]#   modprobe -c | grep -i '10ec.*c821'
alias pci:v000010ECd0000C821sv*sd*bc*sc*i* rtw88_8821ce

what more can we check?

I'm out of ideas, perhaps @iplaywithtoys got something, once he receives his box.

Still think you should set up wired tethering, it's no rocket science.

i have tried before, but still no giving me internet access... then i will do it little by little for if i left something to do in that post

Forget to comment something, last night i went to buy a Wifi Repeater (Typical TP-Link).

What i tried to do was repeating the wifi hotspot of my phone and then, connecting the repeater via ethernet to the x86, but, again and dont know why, still without working... iPhone hotspots give 172.20.10.X IPs, could be that...

Did you use the correct ethernet port in the T8 ?
Can you get it to work on your computer?