Installing OpenWRT in a X86 System in a partition, having both WIN11 and OpenWRT

i can download it from here

and send and install it by SCP, right?

That you can do too, but the NICs have to work, so I hope the kmod is the right one ,)

okey, will try and comment the result, thanks

Let me rephrase.

Why do you want both OpenWRT and Windows to be installed on the same device? They serve completely different purposes and have completely different use cases. And in a dual-boot scenario, you will be using either one or the other, not both.

OpenWRT is intended to be left alone and run unattended. You configure it to do its thing and then leave it alone; it's not intended as an interactive system.

Windows 11, on the other hand, is very much intended to be an interactive system. Yes, you can set it up to run unattended, but that's not its main use case.

If you want to run both OpenWRT and Windows at the same time on the same device, then dual-boot is not the solution; rather, some approach to virtualisation would be the solution.

I suspect that you're encountering the XY Problem:

yep, you are right, but im having problems installing OpenWRT in the entire SSD my x86 i have. I had set up an USB with OpenWRT image but it is booting from the USB all the time, im not seeing the option to install it in the SSD...

Respecting this, i selected the package to build a custom img but it doesnt work, cant see LuCI, cant connect via SCP... idk whats happening....

can't see it where ?
if you're refering to the console, it won't show there, only via the network.

sorry, accesing GUI from

does your client get an 192.168.1.x IP ?
if not, tried the other ethernet port ?

since you've got a console, what does ifconfig say ?

ifconfig says that the ip to connect to it is Tried to set my nic to dhcp, static ip with gateway... but nothing happens

i tried to flash the USB again with the "normal" .img and adding kmod-usb-net-rndis via scp and didnt work either...

if the IP is there on one of the ports, try doing logread -f, then unplug and reconnect the cable in both ports.

1 Like

do you mean with the firmware selector .img, right?

no, I mean the console, via SSH or HDMI.

yeah, but with that .img generated with the firmware selector, i mean.

Silly question:

Is this correct?

Or should i

And then, i just have to

am i right?


the 1st one, like all the other entries in the list, then grab the combined EFI.

If I were you, I'd add all the other packages listed on the tether wiki page.
carpet bombing, to cover all angles/scenarios.

dd -if /dev/usb0 -of /dev/nvme0 (adjust device names to suit the real device names in your system).

By the way, don't use dd until you've read and fully understood the man page for it; the above command will completely erase /dev/nvme0 and replace its contents with what's on /dev/usb0. It's destructive, but it will get the contents of the USB stick onto the SSD (subject to the earlier caveat about the correct device names).

But none of that answers the question about why you want two entirely different operating systems, with entirely different purposes, on the same device. If you want OpenWRT because you want a powerful router, then go ahead; x86 is an excellent choice. But then you don't need Windows on it.

I have not mentioned it but I will install only OpenWRT on the x86 finally, sorry for not mentioning that

ok, will do and try it

Good idea, will do it too.

I will be comenting the results

And for this, you are talking about to do this under OpenWRT console, right?

cant find the devices on my x86..... lsblk doesnt work...

Tried this with the same result, cant access to via GUI-LuCI
Chrome says ERR_CONNECTION_REFUSED, even when i turned my firewall off

In that case, your options are a lot easier. If your hardware is standard and supported out-of-the-box, then it's unlikely you need to mess around with building a custom image. And even if your hardware is non-standard and you need to build a custom image after all, then it's still good to learn how to install the system successfully. See

If you want to duplicate a disk image onto a real disk, you have many options at your disposal. dd is one option, but it is not the only one. The OpenWRT console might or might not be suitable, depending on your chosen method of duplicating the image onto the disk. See

"doesn't work"... or "not found" ? If the latter, have you installed the "lsblk" package? See

For that matter, have you looked at the contents of /dev to identify what devices are known to your system?

hehe, not found, i have generated a new .img installing lsblk and its dependencies and this is what i got

But still without accesing via web...