Installing OpenWrt 19.07.0 on Netgear R6220

Hi, this morning I tryed to upgrade my Netgear R6220 with stable release from GUI but the installation failed with the following message:
printscreen 2020-01-25 12-15-51
Image is "openwrt-19.07.0-ramips-mt7621-r6220-squashfs-sysupgrade.bin"

My device is actually running on this snapshot:

Thank you in advance for any support or suggestion you may provide me.

You should untick 'Keep settings and configuration' since you're actually downgrading, and tick force upgrade (which is in red, and meant for this type of situations). Especially when downgrading you should not be keeping settings, since any migration mechanisms in place are meant for upgrades; not downgrades. You might just be bricking your device, even though the image is perfectly valid, because you're running older firmware with incompatible, newer, configuration settings.

There's probably a backward sysupgrade compatibility between master and 19.07, related to device naming, which makes sysupgrade bark.

1 Like

Thank you Borromini. Followed your instructions, and everything run flowless.
System is up and running:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

I try to install OpenWrt first time and I'm confiused because Instruction on website isn't fix to real.
Method 1 (via GUI): I choosed *.img file and while upgrading I was logout. I tried tree times with same results.
Method 2 (via telnet): In instruction is wrote about files "kernel.bin" and "rootfs.bin". Where are they?

If you are flashing OpenWrt over the OEM stock firmware you shall follow Method 2 (the same I followed myself with success). You can first flash with 18.06.6 files, available here:, and here
than upgrade to 19.07.0 via GUI with

Not 100% sure but you will probably need to install LUCI from console after OpenWrt install:
Putty (if Windows) or Linux console:

Tell us if everything's okay.

No. LuCI is included in stable releases, but not in snapshot releases.

These instructions are from 2017.

The instructions on seem to be far more up to date.

Can you please provide more details?
What exactly did you do, what exactly happened?
Did you get any error messages?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.