Installing nMap with script support

I have installed nMap on my OpenWRT v18.06 doing:

opkg update
opkg install nmap

But the installation finishes with:

Nmap version 7.70 ( https://nmap.org )
Platform: mips-openwrt-linux-gnu
Compiled with: libz-1.2.11 libpcre-8.41 libpcap-1.9.1 nmap-libdnet-1.12 ipv6
Compiled without: liblua openssl libssh2
Available nsock engines: epoll poll select

And scripts on nMap seems not be working:

root@OpenWrt:/tmp# nmap --script
nmap: unrecognized option: script
See the output of nmap -h for a summary of options.

I have added the "liblua" package attemping to solve this:

opkg install liblua

But the problem is not solved.
I have uninstalled and installed again nMap:

opkg remove nmap
opkg install nmap

Still same problem.

How can I install nMap with scripting engine?

opkg remove nmap; opkg install nmap-full

It yields:
Unknown package 'nmap-full'.

Solved:

The nmap-full package is only available on OpenWrt v19 repository.

Thanks you all for helping.

Er... sorry for replying again but... should I mark the thread as solved or so? And how (I am rather new to this forum)?

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.