Installing Lede on pi 3


i installed the image 'lede-brcm2708-bcm2710-rpi-3-ext4-sdcard.img on my pi3. I also installed Luci.

I read the quick start guide. It suggests to connect through ethernet to wan and to connect a client to a lan port. The pi3 only has 1 ethernet port; not 2.
So i want to use the ethernetport for wan and the builtin wifi for client connections. The wan is working over ethernet. But how can i get the built in wifi to work?



Edit: etc/config/wireless
In there you should find option disabled set it to 0

I note from the wiki:
disabled | When set to 1, wireless network is disabled.

Actually the OpenWRT wiki has even more useful stuff at the top of the page so you dont have to work with vi to edit the wireless file (

Note1: By default the wireless is OFF. You can turn it on in the /etc/config/wireless by changing disabled 1 to disabled 0
In UCI CLI you do this with:
uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi
Note2: If your device contains multiple radios (e.g. some dual-band devices), then you'll need to enabled each device in-turn - list disabled devices with
uci show wireless | grep disabled
Note3: In case your image does not contain the driver for your wireless chipset, simply install them with opkg and proceed with Regenerate Configuration.

This worked. When i scan for wifi signals with my ipad i see LEDE as a wifi network.

Now i want this LEDE wifi signal gone and use the internal wifi adapter for the pi to connect to my local wifi at home.
Furthermore, i would like to connect an usb wifi adapter and use this device for the LEDE wifi as an accesspoint.

I know the pi can do sta and ap at the sametime. But this option could potentially cause lag as one wifidevice can only handle this much data at the same time.

I have been meddling with the network and wireless files but cant seem to get this to work. Could someone please send me on my way?

Ive read the pages on openwrt but i, as i described here, wasnt succesful in getting it all to work.
Current status:

  • i can not do iwlist radio0 scan. It says: /bin/ash: iwlist: not found
  • i have internet from a temperary lan cable connection
  • my network and wireless files are attached.

Solved this by reading first and asking questions later...

In the instructions page on openwrt i followed the parts where sta was added to the network and wireless files. Easy as it sounds. Gotta say that this is quite a step for a total noob... Still, ive learned.


How did u solve the first issue? I installed LEDE on PI i3 and I cannot find the wifi signal. Could you show me the configuration of wireless and network?