Proper Pi setup


The answer to this post suggests to turn wireless on from the commandline through /etc/config/wireless.
I wanted to run this on my pi 1 so I downloaded the correct image. It boots fine, however I navigate to the above location and the wireless config file isn't there.
I mean I have it connected to a lan port on the existing router and I thought maybe plugging in a wireless adapter would add something. It did not.
Is there anyone out there familiar with the raspberry pi and has tested LEDE? How did you manage? What did you have to do for the pi to get internet? For me, ping indicates network is unreachable.

Are you sure that brcmfmac and its firmware are installed?

https://downloads.lede-project.org/releases/17.01-SNAPSHOT/targets/brcm2708/bcm2708/lede-17.01-snapshot-r3006-ef08595-brcm2708-bcm2708-rpi-ext4-sdcard.img.gz
I had my pi hooked up to my tv and I saw it start up. Is that what you mean?

Installing Lede on pi 3
The answer to this post suggests to turn wireless on from the commandline through /etc/config/wireless.
I wanted to run this on my pi 1 so I downloaded the correct image. It boots fine, however I navigate to the above location and the wireless config file isn't there.
I mean I have it connected to a lan port on the existing router and I thought maybe plugging in a wireless adapter would add something. It did not.
Is there anyone out there familiar with the raspberry pi and has tested LEDE? How did you manage? What did you have to do for the pi to get internet? For me, ping indicates network is unreachable.

if you run the command "wifi" it will detect the radios on your system and
create a minimal /etc/config/wireless file for you.

I would have expected this to happen during the first boot, but try running it
yourself.

David Lang

1 Like

Thanks David. I will do that.
Ok, is there a specific directory i should be in?
I typed in wifi and checked out /etc/config and I still don't see wireless.
Edit - I looked at dhcp and the option to ignore wan is set to 1. Using vi how to I change that to zero??

I'm able to ssh into my lede pi though

Ok, is there a specific directory i should be in?

no

I typed in wifi and checked out /etc/config and I still don't see wireless.

then the system isn't seeing the wifi chipset, which probably means that the
drivers aren't loaded.

Edit - I looked at dhcp and the option to ignore wan is set to 1. Using vi how to I change that to zero??

do a google search for 'vi cheat sheet' and find one that works for you.

here is one
http://www.lagmonster.org/docs/vi.html

David Lang

1 Like