Installing LEDE on EVG2000?


I have the Netgear EVG2000 wireless router with Broadcom chipset. It was supplied with the ISP. I was looking for a way to flash some custom Linux firmware on it and LEDE/OpenWRT project seems to be the only one that has something for this router. But being a Broadcom based router it has a number of issues, or so I read.

What is the current support status on this one? Is it fully supported yet? I read that there is an issue of recognizing the switch?

For example here:

It suffers from the same problems these devices have of not recognising the BCM53115 switch but the lan ports work as a hub.
Adding Actiontec R1000H (V1000H, Q1000) (brcm63xx)

Supported since LEDE Reboot. Switch not configurable, work in progress!
SMP. b43 wifi drivers installed. The switch cannot be configured, no WAN support

Adding support for this router should be easy, the hardest part is the external switch.

No WAN support? Switch not configurable? What do these things mean exactly? I would like to know what I'm in for before I embark on this quest.

If that is still the case that means that the 5 Ethernet ports on the back will all be in the same network (the LAN), and you can't change that to connect one of them to a modem for example. The switch powers up in its default configuration where all the ports are switched together like an unmanaged switch.

So it will basically work the same way as it was originally with original firmware? In other words you can't upgrade it from un-managed to a managed switch?

Another question I have! I came across conflicting information on this. Is the Luci web UI installed by default or not?

Here is the router page for example:

Does this firmware link include the web UI or do I have to install it separately? This router has 16 MB ROM so it should technically be able to hold a GUI.

Also, if I understood this correctly I should use the BIN file when using the upgrade page of the router to flash LEDE on it? What is the CHK file for?

The original firmware works by setting a VLAN in the switch to put one of the ports in a different network for connection to the WAN modem. LEDE may not be able to do that. All the ports would be in the LAN. You could not use the box to route out to a modem.

If you use the 17.04 release build, GUI is included.

The .chk file would be used to flash from factory firmware's upgrade page.

How do I access the firmware upgrade page of my router? I don't seem to have that option. Or it may be hidden and not listed as a clickable option?

The EVG2000 Settings pages allow you to configure, upgrade and check the status of your NETGEAR Router.

Click an item in the leftmost column. The current settings or information for that area appear in the center column.


I don't know if this image is genuine of EVG2000 but I found it over at and it appears as if on this one there is clearly an option called Router Upgrade under Maintenance section.

I see on the Netgear website instructions for using a dedicated website to do the upgrade.

But if I go to this site I am asked for my credentials for the router, but I still get the same UI with the same options. No option for upgrading the firmware. What am I missing?

I found the upgrade page, it is as I suspected, they don't list it. Here it is:


Click Browse and select the file from your PC, then click Upload.

I would suggest flash a stock Netgear upgrade from the Netgear website first to remove the "Tele2" firmware.

Where do you download such a firmware? I looked, I could not find one anywhere. Since this is an ISP provided router, there may not be any unbranded versions of it. The rumor on the web is that this router is based on another Netgear router, but this one is it's own model in it's own right and does not share the firmware with its ancestor.

It was EVG834N in 2008/9 and has just been rebadged as EVG2000(D) as it's been picked up by Australia's Telstra.

This is one of several sources.

Besides, flashing it with a stock FW is irrelevant. Because the main guy behind the LEDE build for this router, namely Xotic 750, has used exactly the same kind of router with Tele2 branding to flash LEDE on it.

Once I got to that upgrade page I was able to flash the router using the CHK file.




It got stock (pun!) during the reboot, with a red power LED constantly lit so I had to force reboot it. I did not get the IP address so I had to reboot a second time and then it worked.

However, as I suspected, and this is important so pay attention if you are a new visitor here looking to flash this device... given that the switch port detection and configuration was problematic (you can read about it in Xotic 750's logs) the WAN port, as well as the WLAN will be disabled after you successfully flash this device. Then you are stuck with what is essentially a network hub. So don't do it unless someone has already fixed this issue by the time you read this, or if you need the WAN or the WLAN. There is a way to reverse it and restore its original firmware (not stock, the Tele2 branded firmware), by compiling and building it from source, which you will find on Xotic 750's GitHub account. I haven't done it yet myself, but I plan on doing it later on.


I update my router, the following image: --> lede project download page................. /releases/17.01.2/targets/brcm63xx/smp/lede-17.01.2-brcm63xx-smp-EVG2000-squashfs-factory.chk

But it say:

"DSL Router Software Upgrade

Image uploading failed. The selected file contains an illegal image.


What the problem?

Sorry my bad English.

WLAN is disabled yes, but not inoperable. I picked up this router again and I just realized that the WLAN can be enabled manually. So I have LAN and WLAN, but still no WAN which obviously important for Internet connection. I don't know if one of the five switch ports can be reconfigured to operate as WAN/uplink port.

I have upgraded the firmware from 17.01.4 (LEDE) to 18.06.4 (OpenWRT). That proved to be futile attempt to enable that WAN port.

Will this router ever get full OpenWRT support?

What router are you using? Is it EVG2000? Is it branded by Tele2?

You will find the latest binaries here:

Not unless you or someone with it ports it.

A 400 MHz MIPS processor and an old Broadcom wireless chip don't make it very attractive at all.

It would seem so, yes.

The BCM53115 onboard switch cannot be configured. The MDIO interface isnt's still implemented to configure this switch on this platform.

Do all routers based on Broadcom chips suffer the same problem? It seems to me like Realtek based hardware is best supported by OpenWRT.

It’s more that Broadcom hasn’t been very supportive of open-source development, in general.

The various SoC vendors come and go with level of open-source support. It’s even on a chip-by-chip basis. Most try to keep their data sheets out of public view. Unfortunately, there’s little economic incentive for them to support open-source development. It doesn’t increase their sales significantly.

That's rather unfortunate. I am interested in giving this one a try, just for the sake of challenge. But I have no experience in doing any embedded programming, so I would not know the first thing about it. So doing something like this is probably a difficult task for a beginner like myself, especially if the lack of open source support from the vendor means I will hit a major road block further down the road that requires expert knowledge to get around.

So... what's the best way to ease into this kind of stuff, OpenWRT development in particular? Do people just pick up a random router that's not supported yet and give it all they have until OpenWRT runs on it? Or do they help out in other ways?

Is there a way to restore the stock firmware on this device? Since it's ISP specific I don't have the image to flash back on it. I looked at the repository that Xotic750 posted on Github, here:

What is this exactly? Is it the source code for building the needed image to restore the stock firmware?

In the build instructions MD it says:

"The final firmware is located in targets/TELE2.
The filename is EVG2000-.chk, or kernel_rootfs_image.chk"

Does this mean if I navigate to...

I should see an image file with name extension CHK? I don't see one in this repository, so I assume it will only appear in my local repository if I build it successfully?

Is it maybe possible to clone the firmware from one router to another? I actually have two of these.

An easier (and more common) approach to get started with developing on OpenWrt would be to first familiarize yourself with building it from source for an already supported device, to adapt the resulting image to your needs, beginning with just tailoring the build config to your liking over starting to make some source level changes/ patches up to packaging new stuff. Once you're there, you might look into porting OpenWrt to devices that should be easily supportable (SOC support and drivers already present and working for similar devices), but which just haven't ended up on the desks of existing contributors yet - but which do provide some value to you (cheap, unique features, new on the market, ...).

This would be kind of a natural progression for new contributors. Obviously you can skip these steps and jump into the deep end, but unless you already have solid development experience (coming from other projects), you'd likely hit the walls soon and end up in frustration - even more so for targets that are simply lacking essential drivers, where you'd need an army of developers to get started. Even for the 'simple' cases (SOC already supported, all drivers available) you will have to learn by yourself, based on examples for other/ similar devices and simply by doing/ trying, embedded devices differ -a lot- and there is no checklist to follow, no steps to replicate.

1 Like

I actually have one of these that I've put OpenWRT on recently (I used the serial port short-circuit method since I couldn't find the firmware upgrade URL).

I found the archive where Xotic750 talks about getting the bridge working.

It looks like he was close... I want to continue the work but I don't know how I'd flash the firmware after a kernel panic (I did the short-circiuting the serial port connection method to get it on in the first place but I'm pretty sure that only works with the original firmware )