Installing certificates for opkg

Can someone provide the exact steps for installing a cert on OpenWrt? I am asking on this list because a user on this list "cksum" seemed to have the exact same problem I am having and solved by installing a cert but did not give details on the installation process. I am running the latest brcm2708 and bcm2710 on RPI. The release is May 28 (yesterday).

When trying to run opkg update, I get a signature check failed which I can "solve" by commenting out the
option check_signature 1 in the /etc/opkg.conf However I cannot get rid of the additional wget returned 8 error message.

I suspect this is a problem with certs since our school is behind a firewall and I have had this problem before. I know how to install a cert on a standard debian install, but do not know how to do the same on openwrt.



I think that you are actually talking about two different certificates/signatures here:

  • build-related signatures, which are used to sign Openwrt package lists for verifying list contents. Those certificates should be automatically installed with the firmware image itself, and you run into problems only if you edit feed definitions and try to download package list that are not related to the your current build. (e.g. change feed definitions in 17.01 to point into 18.06, which uses newer signatures that are not included in 17.01)
  • SSL certificates used for HTTPS traffic. Usually these can be solved by installing the certificate packages. "opkg install ca-certificates". Certificate wget errors would usually be 5, I think.

Wget error 8 is "Server issued an error response."
That sounds something not related to certificates, but might well be related to firewall traffic filtering by your school.

You might try running the wget (simulate opkg update) from the command line, and see if you get a more meaningful error message.

... forum timeouts seem to have hidden this thread ... ...

Test to see if the thread gets refreshed.

Thanks for the reply.

Well, it turns out that the error I was getting seemed to be related to using a development snapshot which I mistakenly downloaded instead of the stable releases that I had been using.

Though with the development snapshot I was unable to use opkg at all.


If your problem is solved, please consider marking this topic as [Solved].