Install to GL.inet GL-B1300

I recently bought a couple of these devices as they appeared to be a good choice for a router that would be supported under OpenWRT. However I've not been able to install to it. I initially did just some basic messing around on the stock firmware such as changing IP addresses to match my network and that firmware appeared to be working. I then downloaded openwrt-19.07.7-ipq40xx-generic-glinet_gl-b1300-squashfs-sysupgrade.bin and had it install that. Is that perhaps only meant as an upgrade once OpenWRT is already installed? If so where do I get the initial install image from? Has that potentially tried to preserve the existing settings from the stock firmware which may have been somewhat messed up.

This doesn't seem to work. It comes up trying DHCP to get an IP for the WAN port. nmap on that IP then shows no open ports and neither port 80 nor 22 work. On the second, LAN port, it comes up as On that, I'm seeing no web - firefox jumps straight to trying https after http. ssh does seem to sort-of work initially but then times out:

The authenticity of host ' (' can't be established.
ED25519 key fingerprint is SHA256:TlVcMHO8XLowHLpVaXEpiZD666Yfsc86hAp2AANO33s.
No matching host key fingerprint found in DNS.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '' (ED25519) to the list of known hosts.
Fssh_ssh_dispatch_run_fatal: Connection to port 22: Operation timed out

With -v options, ssh is hanging after debug3: send packet: type 50.

I tried dropbear's dbclient to see if that might work instead and get:

dbclient: Connection to root@ exited: No matching algo enc c->s

I also then tried the snapshot rather than release firmware with much the same outcome. I did check the checksums on the downloaded files.

On the initial factory firmware, I think I may have created a mess by giving it the same IP address for more than one interface. I had it so the Advanced part which I think brings up LuCI was not working. Perhaps that's irrelevant. Any ideas how I get it installed properly with OpenWRT?

Use the uboot web-ui
Instructions here (b1300 specific bits included)

The u-boot webui is exactly what I used to flash the openwrt images. That's not getting it to a working state. Are the sysupgrade files the right ones or are those for upgrading to newer versions only?

Stock firmware of these devices is an older OpenWrt version so sysupgrade should work. You need to open the Luci interface by going in the "More Settings" and click on "Advanced" menu. THis will open a Luci (default OpenWrt) web interface and you can do sysupgrade from there.
See this for example

Please remember to NOT SAVE configuration as you are upgrading to a much newer OpenWrt firmware.

The sysupgrade file is the correct one.
The uboot web-ui is the one you get to by holding the reset button and powering up as in the link I provided. It is not Luci.
I just flashed one here with uboot and it works fine.
The only conclusion I can come to is that you are not following the instructions in the link.

Using the procedure from the link I was able to flash the firmware from
Both clean and release firmware from there was fine. From the normal LuCI web interface, I then again tried the sysupgrade image. Again that gets the thing back where it was with it doing DHCP on the WAN interface, on LAN and ssh to that timing out while all other ports are fully closed.

You are missing the point I thought was obvious - ie use uboot to flash this:

By default the lan interface will be and it will be running dhcp ready for you to connect by ethernet cable.
Wifi will be disabled by default. So log in to luci at and enable it. Also change the lan ip address subnet to something different to that used on your isp router's lan while you are at it.

Thanks for your help, it finally seems to be working though I'm not entirely sure what I did differently in the final working case. Seems I had to use uboot while the existing firmware was the stock one. I may have made things worse when trying the snapshot as opposed to release firmware. I had hoped to run that in order to try out the new dawn roaming thing but that can wait. For now I have the first one running 19.07 which is great and I'll see how things go with the second device.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.