Install OpenWrt on TP-LINK Archer c6 v3.0 BR

I will try to create a 21.02.2 build for the Archer C6 v3.x.

For this I will manually merge (into 21.02.2 branch) the changes that added C6 v3 support (here) plus I will also add the new IDs per @hmh post here to support the Archer C6 v3.0 BR.

If the build completes successfully, I will share the images in this thread.

1 Like

OK.Here you go. Below is the link for downloading 21.02.2 stable for Archer C6 v3.x.

IMPORTANT: I have not tested this build. I'm away from home and unable to test it. So before using it, we should wait for a more experienced user to test it (who has an UART adapter to unbrick the device just in case things go wrong) and reports it works.

I did this build on top of the 21.02.2 stable branch with the following modifications:

  • Added/replaced the files that added C6 v3 support per this commit.
  • Updated tplink-safeloader.c to add the new C6 v3 IDs per @hmh post here.
  • All default packaged plus LuCI collection

Again, I have not tested this build. Use it at your own risk, knowing that it can brick your device and may require an UART to recover it. I will take no responsibility if you brick your device!

If you are not certain, do not use it. Wait for other users' reports confirming it works before trying it.

Download 21.02.2 stable release for Archer C6 v3.x:
[Removed download link - this build is causing a boot loop when enabling 5GHz radio - see below]

1 Like

Thanks! Hopefully someone can test this build soon

I was about to test it, and I just found out that the factory image was missing. So the build was not OK. For now I removed the download link until I am able to troubleshoot and redo it.

OK, the good news is that now I have successfully built 21.02.2 for the Archer C6 v3 (backported some C6 v3 files and successfully built it).

However the bad news is that the stable build 21.02.2 for the Archer A6/C6 v3.x is broken. When enabling the 5Ghz radio the router enter in a boot loop (I tested in in my C6 v3.2 and confirmed this issue).

For this reason I will not make this build (21.02.2 stable for the C6 v3.x) available for downloading.

This issue was already reported in the 21.02.2 thread below:

1 Like

@dsouza I saw your post in OpenWrt 21.02.2 Second service release - #90 by dsouza
Could you share your stable build? Or is it still too risky?

Thanks in advance

I just created a pull request to both add official support to Archer C6 v3 to future 21.02 stable builds as well as to fix the boot loop that 21.02.2 was causing with Archer A6 v3.

However I need 6 developers to review and approve my pull request so it make into future 21.02.3 stable build:

Since this is my first pull request I'm not sure I've done it correctly.

Anyway I will to a 21.02 stable build from my branch, test and share here.

That's awesome! I've never done a pull request either, pretty daunting.

Congrats on fixing the boot loop issue.

OK, here you go.

Below it the link to download 21.02 for the Archer C6 v3 (not BR, see below). This build includes the most recent changes from 21.02 head plus the two commits I cherry picked above (fix for the bootloop plus changes to support Archer C6 v3).

You may think as a pre-21.02.3 release if my pull request gets accepted. I did a quick test in an Archer C6 v3.2 and it worked OK:!AorfKe3ImcTd5aVFt9yjMmD0UhZwcw (password "owrtc6v3")

Notice however the factory image of his build will NOT WORK on the C6 3.0 BR. This is because this build does not include @hmh fix since it would require upgrading the entire firmware-utils for the 21.02 branch, something that cannot be done via a cherry-pick.

If you want to use my build on the Archer C6 3.0 BR and you are still using stock firmware, you may need to first install a snapshot build then installing the sysupgrade image from my build. If you are already running OpenWRT on the C6 3.0 BR, the sysupgrade image from this build should work (but I have not tested).

I installed your image. I was already running a snapshot image.
I ran into the following error trying to install luci-app-sqm.

The installed version of package kernel is not compatible, require 5.4.182-1-613e7cb3… while 5.4.182-1-eddafb3b… is installed.

Not sure if this is the correct place to post this or if I should open up another topic.

Hum, this was sort of expected, since my build is coming from 21.02 master and has a newer kernel. Let me do a custom build from 21.02.2 tag with the specific changes. I will update here when it's available.

OK, here you go. This is 21.02.2 version with the following changes:

  1. Added support to Archer C6 v3 (including now v3 BR)
  2. Fixed the issue which caused boot loop on 21.02.2

Please test and report back:!AorfKe3ImcTd5aVHU-ymI0U1iZfujA (password owrtc6v3)

Now I get this.

 Require version = 5.4.179-1-613e7cb33f069740a878d322bb79ae77,
installed 5.4.179-1-eddafb3bc53308a6fee3cb3cfc6c498a

TBH I really don't know why this is happening, since I did the build using 21.02.2 tag, all versions should be the same as the official 21.02.2 build. So it seems this build will not work with the 21.02.2 packages.

Anyway, if SQM is the only additional package you need, I just did a new build which is including SQM by default:!AorfKe3ImcTd5aVJSxMSM_FD4ydY2A (password owrtc6v3)

You absolute legend! Thank you so much!

It works! Sorry about all the trouble

Hello, can I install this build on the Archer C6 v3.2 (US) router?

Yes. I recommend using official snapshot builds 22.03 available here.

What is the diff b/w snapshot and 22.03-snapshot on there?
Both seem to have diff build numbers.

  • snapshot = snapshot of master, the development branch
  • 22.03-snapshot = snapshot of the 22.03 branch, which will soon become the next stable release

The link @AashishAS posted (from asu.aparcar website) is also a 22.03-snapshot image (below).

I understand that the asu.aparcar website is a sort of cloud based build infrastructure which provides a web UI for users to do their own custom builds (anyone please correct me here since I'm not 100% sure if my understanding is accurate). [EDITED: asu.aparcar is used by luci-app-attendedsysupgrade. More details at]

So the 22.03-SNAPSHOT from builds might be different from the official/daily 22.03 snapshot builds sine they might include different packages and also they might pick (or not) the latest commit from the 22.03 branch depending on the build date/time.