Install OpenWrt on TP-LINK Archer c6 v3.0 BR

Hi, how to install openwrt snapshot in tplink archer c6 v3.0 BR ? , via web - Firmware Upgrade but message error file.!

How to install tftp boot ?

I assume BR is froM Brazil, right? I'm from Brazil, and the models sold here (at least the 4 ones I bought) are all "Archer C6 v3.2 (US)".

Can you please double check the label below your router?

Archer C6(BR) Ver:3.0. Yes, I am from Brasil too.

@dsouza, can you contact from phone or email ?

you could try the web recovery;a=commit;h=d22fb7f4fd833c420bc2ab34384862da0a6688b5

@dsouza Archer C6 v3.2 (US) its works ?

Yes. But notice that the C6 v3 has only snapshot builds (without LuCi). Are you comfortable in performing the initial setup with SSH only (command line) and without a graphical user interface? You can install LuCI from SSH later, but you will need to use ssh and command line.

If yes you can download the firmware version to flash from factory to OpenWRT at

Alternatively you can flash the stable 21.02.1 (which includes LuCI) using the Archer A6 v3 firmware (the C6 and A6 v3 series are the same hardware):

BTW, I’m assuming that you are currently running the latest version of stock firmware from TP-Link. If not, I would recommend first to upgrade the TP-Link firmware to the latest version (at least this did work for me). Also, if possible, please share the error you are getting when trying to install OpenWRT.

Here image error:

Strange. I did this sometime ago without issues. Perhaps something changed in the master that broke the factory images for this device in the snapshots build.

Could you please try flashing the Archer A6 v3 stable image?

@dsouza, can you contact from phone or email ?

same mistake with flashing the Archer A6 v3 stable image :grimacing:

Hi guys.
Same situation here!

On device's page there are some instructions for TFTP installation. I want to try this method but I got some doubts about it:

  • The IP address is set on my computer?
  • Where do I get the …initramfs-kernel.bin file?
  • and items 3 and 4 is also a big ? for me.

Any light on this?

If you guys want the meet in conference just let me know.

That method involves connecting serial hardware to the port inside the case to control the bootloader.

Once you have done that it is a good way to bypass firmware checks and country codes since the factory firmware will not be booted up at all.

The "factory" image files on openwrt master are for the C6 v3.2, they don't seem to have the required tp-link IDs for the TP-Link Archer C6 v3 (BR).

Since the "factory" tp-link Archer A6 v3 images from OpenwRT 21.02 won't work either with the same error message (just tested this here as well), it is likely for the same reason.

That error seems to be the tp-link vendor firmware rejecting the openwrt "factory" image file since it does not have the correct models in its headers.

The UPSTREAM (vendor) firmware for the Archer C6 v3 (BR) and Archer C6 v3.2 (US) as distributed in the home-country's site have identical sha256sum, and mention A6. So, it should be a matter of ensuring the correct firmware ids for the C6v3 are present, and that the openwrt image has kernel support for any hardware discrepancies (if any at all) between the A6v3, C6v3 and C6v3.2.

1 Like
{product_name:Archer C6,product_ver:3.20,special_id:55530000}
{product_name:Archer C6,product_ver:3.20,special_id:45550000}
{product_name:Archer C6,product_ver:3.20,special_id:52550000}
{product_name:Archer C6,product_ver:3.20,special_id:4A500000}
{product_name:Archer C6,product_ver:3.20,special_id:4B520000}
{product_name:Archer A6,product_ver:3.20,special_id:45550000}
{product_name:Archer A6,product_ver:3.20,special_id:52550000}
{product_name:Archer C6,product_ver:3.0.0,special_id:42520000}
{product_name:Archer A6,product_ver:3.0.0,special_id:55530000}
{product_name:Archer A6,product_ver:3.0.0,special_id:54570000}
{product_name:Archer A6,product_ver:3.0.0,special_id:43410000}
{product_name:Archer A6,product_ver:3.0.0,special_id:4A500000}

Interesting new IDs for C6v3 support are for the (BR) variant, only. I have no knowledge of other C6v3 variants that should be added along with the (BR) one.

There are new A6 IDs in there, too, which aren't in firmware-utils master yet. But these are outside of the scope I am interested in, and I am not sure if they match the FLASH sizes, so I am not going to look into them.

Adding the missing ID for 3.0.0, special 4252 will allow the router to accept the "factory" image from the web interface, I have just tested it on an Archer C6v3(BR), latest vendor firmware version 1.0.10. I make absolutely NO CLAIMS that you will ever be able to return to the vendor firmware, though.

I will send the trivial patch to firmware-utils through the openwrt-dev ML. Backporting the TP-Link Archer C6v3 support to openwrt-21.02 and earlier is a separate matter.



Any progress on that patch?

Patch sent today to openwrt-devel. We took some time testing the unit, it seems to be working properly.

That said, my workplace has very strict DMARC, which causes patchwork to mangle things, and the ML to attach the real message. Let's see if it gets applied.

It doesn't help that firmware-utils is now on its own git repo and that it is a very new change, so I tried to CC the openwrt core developer that has been gatekeeping patches for firmware-utils.