Install OpenWrt on an Ubiquiti Nanostation ac loco

Hi all

I am new to Open-WRT but I was using DD-WR on a D-Link DIR-600 for some years.

I looked up instructions for installing here:

I also installed the recommended ubnt firmware to start from (v8.5.0.36727).

However I cannot understand the process for applying the downloaded Open-wrt firmware (openwrt-ath79-generic-ubnt_nanostation-ac-loco-initramfs-kernel.bin).

Has anybody done this sucessfully - please help?

Thanks Pete

The first set of instructions, for installing through the manufacturer firmware, use a factory bin not initramfs. Use the ath79 19.07.0 build.

I recommend those instructions I have used them on several units.

Thanks MK
I'm not sure what you mean by original instructions? Excuse me being cautious, don't want to brick my device :slight_smile:

Do you mean these instructions:-

Installing OpenWrt

The firmware for this Ubiquiti device is signed. But since there are no mtd utilities available on the device the original fwupdate.real binary must be used. Please make sure you have got firmware version v8.5.0.36727 installed The instructions probably won't work for other versions. To install unsigned firmware the fwupdate.real binary (which is in fact just a symlink to ubntbox) must be patched:

hexdump -Cv /bin/ubntbox | sed 's/14 40 fe fe/00 00 00 00/g' | hexdump -R > /tmp/fwupdate.real chmod +x /tmp/fwupdate.real

After that the factory image can be installed using the patched binary:

/tmp/fwupdate.real -m /tmp/openwrt-ath79-generic-ubnt_nanostation-ac-loco-squashfs-factory.bin

I'm not really a linux expert :roll_eyes: :roll_eyes: but assume I'd need to scp the image to the device first as in

Cheers Pete

Yes scp the firmware to /tmp on the router first.

On both AirOS and OpenWrt, /tmp is a RAM disk so there is considerable space, but the files won't persist through a power cut or reboot.

All flashed and working now :slightly_smiling_face:

Thanks for your help mk24 much appreciated

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.