IMG with USB Ethernet

Hey guys, first time poster here.

First off Happy New Year to all!

I'm trying to turn an old laptop into a "router" with one PCI GB ethernet and one USB GB ethernet (FTTH).

I was wondering, is there any IMG/ISO with USB Ethernet drivers? I know we can compile it, but frankly, I don't really have about 52 million years to do it, especially since my USB card is a very common model (an USB3 Realtek 1GB, IIRC the drivers are 8353 or something).

I've tried creating another network to just DHCP into my existing network and download everything, but even that doesn't work, it doesn't even get an IP. Even when I tried to change the default static IP from .1 to .X, it was horrible, it never worked, unless I do everything from host using a french keyboard with an US layout, I can't do much and it's starting to really test my patience.

Also, the wiki doesn't help that much. I don't want to spend decades installing everything piece by piece with an unchangeable keyboard layout, especially since this thing does not seem as functional as I've been led to believe. (Needing to vi just to change the IP because the webinterface works if it feels like it is a BIG no-no, why even have a webinterface at all, then?)

I have the ext4 version, because the squash one was basically unusable and I wouldn't recommend it to my worst enemies.

I wonder tho, I know for a fact that I'm not the only one using USB cards to make "routers", is making one IMG with the required USB drivers forbidden by some deities I've never heard of?

Must be, because nowadays, not many people lack space for a few drivers, especially when talking about x86 ones that basically every single distro (even my Android phones work with this card) in the Universe has. I'm not even asking for all of them obviously, just the most common ones. Or an easier way to actually install and use them, like in automatically.

I could rant on for hours on this subject, but I think you got the jist of it.

Thanks in advance for any help. Also, I'm sorry for the rant, I'm about to have a nervous breakdown :(.

takes around 2 mins... if it is online and working ( otherwise imagebuilder would take 10-20mins if you have a linux host to learn ... 5 mins to run max on subsequent use )

1 Like

Your statement is quite rambling and I don't quite understand this issue. Mainly because you note the Wiki, but describe things not suggested by it.

Regarding USB cards, simply copy over the package files to install the drivers. Simple. Since you're using an EXT4 image, this shouldn't be difficult.

:confused: Ummmm...I thought you needed the network drivers?

(BTW if you do get one of the NICs up, you can use the Internet to install the drivers for the second.)


Hey, sorry for being so late, I wasn't home.
Thanks for taking the time to answer.

I went on their site ( but it don't seem to be able to find a x86/64 image.

no problemo...

sadly that site and related support channels are in a really poor state...

try asking @aparcar whats going on...

Hey sorry for being late, thanks for answering.

Phew, that was a headache. A few missing dependencies, including an older kernel grrrr.

Your suggestion would have been perfect if it weren't for the kernel problem haha. Thanks a lot man.

1 Like

Ouch I thought it was the go-to place for on-demand images :blush: .

About the "unable to find PC image" problem?

I used @lleachii solution, even if it was mind-bogglingly easy, the need for an older kernel confused me, I thought I could just get an older kernel pkg and just have it laying around just for this driver to work, but it would try to downgrade the whole thing every time I tried, so that was awkward, but I just used the --force-depend option to skip the dependency checks for that one kernel pkg.

This kind of thing should really be much simpler, preferably automatic, I'm far from a complete Linux/Unix newb, been using it on and off since I was around 10 but even I find it much, much more complicated than it should be nowadays, it was just a simple ethernet driver, after all. I know it's not a desktop distro but a barebones system but still, there is a huge number of people that use USB ethernet solutions from what I can tell. Like Raspberry Pi users and such.

I actually had a similar problem on the Rpi0, which is even more complicated IIRC, but since I now have FTTH, I never finished configuring it lol. I have around 40MBps so the Zero wouldn't cut it with its USB2 controller and 2x USB3 GB cards :(. I bet the CPU could handle it tho, too bad, it's an amazing little piece of tech.

Although, if I stick a USB 3 hub on it with both ethernet cards on the same hub, would the data still need to go all the way through the USB2 controller (especially if I'm using it for QoS) or would the bulk of the data just go back and forth between the 2 cards through the USB3 hub?

data will pass through the host... glad you sorted it out...

Like in the USB2 controller? Damn, that's too bad.

Thanks, got pretty messy for a moment lol.

BTW, do you know a fix for the crazy CPU usage in VIrtualbox? Barebones, I manage to get 50MBps when I can barely get 40 on my router but on Virtualbox, the CPU goes up to 100% and I barely manage to get around 14MBps :/. Seems to be a problem with the virtual NICs (I use the default ones, the Intel Desktop 1000) but I've tried the rest and it's pretty much the same.

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.