Image not updating after editing code in mypackages

Hi all,

I have a very frustrating problem, I cannot find the correct sequence for the final compiled .bin image for my hardware to reflect changes I make to a C application in /mypackages/extensions/myproject/main.c

This is a custom application and it has all the correct makefiles etc

Sometimes it will work and the image will have my changes but I cannot find a repeatable process, this is what I currently do:

edit the .c file for my package
run ./scripts/feeds update -a
run ./scripts/feeds install -a
make -j4

I really only see my changes in the compiled .bin image If I nuke the full build, with make clean, make dirclean,make distclean, but this build is incredibly slow.

Can you please help me to find a sequence that allows this to compile reliably?


Use make package/mypackage/{clean,compile} V=sc followed by make target/linux/install to repack images.


After a make clean and recompile of your package you could also find the .ipk file from the bin/packages tree and (re)install it on the running system.

Thanks for your replies, it turns out the .bin image was being updated correctly, it was just a weird copying error from my virtual Ubuntu machine

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.