IGMPv3 (igmpproxy) / Telekom MagentaTV / TP-Link Archer C2600

Hello together,

first thank you for that great OpenWRT project! After some years I can finally switch back to OpenWRT. :slight_smile:

I'm using a TP-Link C2600 V1.1 with the latest stable release (18.06.2). I installed igmpproxy and tried to get my Telekom Mediareceiver to work. The IPTV stream stops working after 10 seconds and begin to stutter. Some seconds after the complete stream stops. A non working IGMPv3 is the problem as far as I know. The stream stops when the Media Receiver is switching from unicast to multicast.

At the moment I don't know a good way to debug my configs. Maybe someone of you can help me?

Here are some of my current configs:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd69:8650:d5ca::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.7'
        option proto 'pppoe'
        option password 'mypw'
        option ipv6 'auto'
        option username 'xxx@t-online.de'

config interface 'wan6'
        option ifname 'eth0.7'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '7'
        option ports '0t 5t'
        option vid '7'
root@OpenWrt:~# cat /etc/config/firewall
[...]
config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'
        option dest '*'

[...]
config include
        option path '/etc/firewall.user'

config rule
        option enabled '1'
        option target 'ACCEPT'
        option src 'wan'
        option name 'Allow-UPD-IPTV'
        option family 'ipv4'
        option proto 'udp'
        option dest '*'
root@OpenWrt:~# cat /etc/config/igmpproxy
config igmpproxy
        option quickleave 1
#       option verbose [0-3](none, minimal[default], more, maximum)

config phyint
        option network wan
        option zone wan
        option direction upstream
        list altnet 192.168.1.0/24

config phyint
        option network lan
        option zone lan
        option direction downstream
root@OpenWrt:~# cat /etc/igmpproxy.conf
quickleave

phyint pppoe-wan upstream ratelimit 0 threshold 1
###     altnet 192.168.1.0/24
        altnet 87.128.0.0/11
        altnet 224.0.0.0/4
        altnet 193.158.0.0/15
        altnet 239.35.0.0/16

phyint br-lan downstream ratelimit 0 threshold 1
        altnet 192.168.1.0/24

I'm using just one port (WAN) on the router which is connected to a managed switch and than to the VDSL2-modem. That's why I have VLAN7 tagged and untagged traffic on the WAN port configured.

Thanks in advance!

Why does your /etc/config/igmpproxy differ from /etc/igmpproxy.conf

Hmm, good question. I only modified the /etc/igmpproxy.conf and left the /etc/config/igmpproxy as default. So both configs should look similar?

You modified the wrong file.

You edit /etc/config/igmpproxy

1 Like

Thank you so much! Now my igmpproxy configs are looking like that:

root@OpenWrt:~# cat /etc/igmpproxy.conf
quickleave

phyint pppoe-wan upstream ratelimit 0 threshold 1
        altnet 192.168.1.0/24
###     altnet 87.128.0.0/11
###     altnet 224.0.0.0/4
###     altnet 193.158.0.0/15
###     altnet 239.35.0.0/16

phyint br-lan downstream ratelimit 0 threshold 1
###     altnet 192.168.1.0/24
root@OpenWrt:~# cat /etc/config/igmpproxy
config igmpproxy
        option quickleave 1
#       option verbose [0-3](none, minimal[default], more, maximum)

config phyint
        option network wan
        option zone wan
        option direction upstream
###     list altnet 192.168.1.0/24
        list altnet 87.128.0.0/11
        list altnet 224.0.0.0/4
        list altnet 193.158.0.0/15
        list altnet 239.35.0.0/16

config phyint
        option network lan
        option zone lan
        option direction downstream
        list altnet 192.168.1.0/24

Now the IPTV streams are not hanging anymore! Thanks!

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.