OpenWrt 19.07.x ath79 tiny LuCI

One of my devices seems to get its wifi in a tangle in a similar way. Rather then reboot I can press the hardware wifi disable / enable button, or if I'm on a device with a wired connection to it I can ssh and run the command wifi (which on its own also does a stop / start). Despite this suggesting it was some kind of software issue I wasn't able to find a cause in the logs, by looking at memory use, etc. Maybe some other resouce type is being exhausted?

Successful install to TP-Link TL-WR841N v8.3

1 Like

Great compilation! I looked at the packages and saw ipt-offload but again I must ask, do those images have SFE software nat offloading feature? Asking for my WR740N v4.

Sorry, but I don't really know. Also even if it is shown in LuCI, some hardware may not support offloading, try it on and off and if there's a difference, choose the faster/more stable alternative.

1 Like

I tried your image and its working, not the hardware offload though its for another chipset. but yes software offload is working.

1 Like

Nowadays those 4/32MB routers are best for just extending signal range.

Yes, this is what I am using this for :slight_smile:

For IPTV, though, I seem to require igmpproxy (see IGMPv3 (igmpproxy) / Telekom MagentaTV / TP-Link Archer C2600), which has 16 kB and no dependencies apart from libc (which the image should have for luci). Any chance to fit this into the next build? I am using a TP-Link TL-WR841N/ND v9.

Edit: I was able to compile myself on WSL, which works great. Here's short instructions for anyone wanting to try this themselves:

git clone
cd openwrt
git checkout v19.07.7
./scripts/feeds update -a && ./scripts/feeds install -a
wget -O .config
make menuconfig  # select TP-Link TL-WR841N/ND v9, add igmpproxy, save, exit
make -j4  # build with 4 cores

Hi, Apologies for any ignorance on the chipsets used as this might be why the TL-WA901ND V3 isn't listed but I have two V3 device that I would like to bring back into service as dumb AP's but am not able to compile the sources. Any chance these can be added to the target list?

I am happy to test firmware for these and understand the risks involved in bricking them etc.



Not sure of the implications of this, but the title of this thread is "... ath79...". In "make menuconfig", the "Atheros ATH79" target system does not include the TL-WA901ND V3 (only V1, V2, V4, V5), so it's kind of expected you don't see it here.

By contrast, V3 can be found in the "Atheros AR7xxx/9xxx" target system (in line with V3 using Atheros AR9341 according to In fact, "Atheros AR7xxx/9xxx" includes V1 through V5. But I understand (e.g., from that that target system is rather non-modern.

Edit: On the other hand, I see V3 being listed here:

thanks @bers, I wonder if @Ashus can comment. I am not particularly familiar with these ranges of SoC's etc and so a bit lost in what gest ath79 support and what doesnt.

Thanks - Newbs

Okay, I did some digging about the TL-WA901ND v3. Do not try to flash v2 or v4 as their hardware is different and it wouldn't work. It's support has been ported from ar71xx to ath79 on master branch after 19.07 branch was separated. That means new OpenWRT 21.02 will support it when it's finally out.

In the meantime, this git commit adds support, but it can't be cherry-picked without modifications to 19.07.7 stable tag as structure has changed a bit.
I can't guarantee anything and you could brick your devices, but you could try to flash this: . Changes in custom-changes.patch correspond to the commit mentioned above.

thanks @Ashus I have just tested the sysupgrade (without keeping settings) on my TL-WA901ND v3 and it booted straight up. as a refresher i followed this guide to get the dumb AP up and running and my phone and 2 Chromecast are connected fine and I have streamed to one of them. I'll keep running it and report back any issues.

are you going to keep supporting small memory devices in 21.02 as well - when that is officially released in a few months?

Thanks again - newbs

@newbs thanks for letting me know.
I plan on building new OpenWRT 21.02 with LuCI if possible; hopefully it will fit and there won't be dependencies on SSL as even the smallest SSL implementation doesn't fit 4 MB flash size.


I would love to see updated uPnP builds from 19.07.02 to version 19.07.7 - as i understand from reading this topic it has fixes for the bug that Samson mentioned a few posts above.
I have 841N v8 and 3420 v2 (and that one doesnt even have 19.07.02 uPnP build).

If there's a need to cut something else I'm OK with wpad-mini and even with lack of relayd.

Hi. Thank you very much for putting your effort and time on this. It makes our "tiny" (but awesome) devices comes alive again.

I'm a little lost. Were you able to add SQM in your 19.07.7 compilation??

My device is a WR940Nv6 and I'm looking for an updated firmware with SQM and IP Bandwidth Restrictions.

Thanks in advance! You're doing such a great job!

Ok, if there are some bugs fixed, here is 19.07.7 with uPnP:

Sorry, I tried, but even without relayd, SQM needs tc, ipmark, ifb and other stuff and it just doesn't fit 19.07 builds. You need a hardware upgrade - preferably to Archer C7.

That is so sad.

So, it means that this one won't work properly?

It could work fine. I think those mentioned features are a list of the ones excluded from the builds. It only makes sense to remove opkg on tiny devices where you can't install anything anyway.

1 Like

Is it possible you may take a look on that please? I love your excellent work, you're always up to date, and I think it will be the best if you could implement those features that let us have an optimal broadband management (even if you delete or exclude anything else).

Sorry for my bad English. My apologies

...and it doesn't matter if you could add it not in latest version. If you do it on 19.07.1 or .4 it's gonna be wonderful