I would like to use Openwrt on VMware like a LAB before make any changes in my routers


I'm new here. But have been using Openwrt since 2017 in one router the I bought from one friend.

I would like to create one Openwrt Lab in one Virtual machine (VMware). I already istalled it, but I see that's there's no Wan interface and don't have Switch option in Network menu.

I'm using https://downloads.openwrt.org/releases/18.06.5/targets/x86/64/openwrt-18.06.5-x86-64-combined-ext4.img.gz image.

There is any way to I solve this?


@Fperuso, welcome to the community!

Setup the VM with 2 virtual NICs. NIC 0 will become LAN - NIC 1 will become WAN.

Thanks lleachii!

But unfortali not worked... I added 2 network adapters, all like Bridged network conection... but the same problem, only one interface shows like "LAN"

OK, now setup the other Interface as WAN.

Sorry, I'm a basic user of Openwrt, but until where I could see when I go to the Interface in the Physical Settings(on Luci environment) it's only shows me the "Eth0", does not have ant other interface.

OK...let's try again

  • If you initially setup the VM with two or more NICs, it should automatically create LAN and WAN on first boot
  • If you added the second NIC after, you'll have to click "Add Interface" to setup eth1 as WAN

I tried to put the image(screen shot) of my VM machine, but I didn't find a way in this post. I'm using VMware Workstation 15.5.1 and I choosed ghest operation system Linux version Ubuntu... and 2 Networks adapters like a Bridged(Automatic) with the status checked like "Connected" and "Connect at power on" and the Eth1 no show in Luci or in ifconfig adapters(comand line)


I then booted:

eth0 and eth1 appear.

I got you. I don't know what is happining here with me... Which release are you using? I'm running https://downloads.openwrt.org/releases/18.06.5/targets/x86/64/ ( combined-ext4.img.gz )

So am I. I tested/screenshotted for this thread.

After setting two adapters try to reset to factory: https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset#soft_factory_reset

Trying the Soft Factoty Reset ( firstboot -y && reboot now) I receive this message: "jffsreset: MTD partition 'rootfs_data' not found"

Trying the Hard Factoty Reset ( umount /overlay && jffs2reset && reboot now) I receive this message: "umount: can't unmount /overlay: Invalid argument"

I saw that you was using Virtual Box. Could be a problem with VMware... Do you have a VMware to simulate this situation?

  • I've tested on VSphere before, it works
  • I've tested in the past with many VM Hosts

How are you setting up your VM, I have a feeling you never did what I suggested, as you never noted that you had?

This doesn't work on EXT4!
Please do not confuse the OP.

If you're unable/unwilling to configure WAN yourself:

  • What if you setup a fresh guest HDD as I noted??

Simply booting a fresh image/VM with 2 NICs works for me.

1 Like

I donI don't know. Maybe I'm doing something wrong... I accessed the URL https://downloads.openwrt.org/releases/18.06.5/targets/x86/64/ ( combined-ext4.img.gz )
1 -I Unziped the file
2 - I Converted the file with qemu
3 - I Created a new VM and associate the new file

The same problem... I will try Oracle Virtual box...

And you setup 2 NICs before booting the first time?

Yes. I setup 4 Nics...

Odd. Then upon booting, you should have:

  • eth0 - LAN
  • eth1 - WAN
  • eth2 -
  • eth3 -

All done. But not worked... I'm setup VirtualBox to try

1 Like

I should note, I'm using VirtualBox for Linux, so QEMU/KVM works (as it uses some libraries). Further, I've used pure QEMU/KVM also.