Huawei e3372 does not work with OpenWrt

huawei e3372 is not detected by my openwrt-modem, what can i do?

Install usb-modeswitch

Give more details about it, like running firmware version.

sorry for not answering that fast.

i did not have a stable internet connection, and first wantet to make

opkg update

and install the packages

opkg install comgt-ncm kmod-usb-net-huawei-cdc-ncm usb-modeswitch

the stick now is recognized

lsusb


Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 12d1:14dc Huawei Technologies Co., Ltd. E33372 LTE/UMTS/GSM HiLink Modem/Networkcard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and i already had some internetconnection, but i comes and it get lost again (blinking led)

edit: its a Huawei E3372 firmware 22.315.01.00.1080, hardwareversion CL2E3372HM

Switch to 21.x

i know how to make the switch in WINDOWS, you think i could do the switch in UBUNTU?

That has nothing to do with OpenWrt, while that is generally possible.


read and translate

I have E3372 HiLink with 22.328.62.00.1185 and it works well. I wouldn't recommend flashing to old firmware as the first attempt of solving a problem.

This tells us close to nothing. When you can't access Internet, can you still access HiLink web interface? What does it say about connection state? Maybe it's problem with HiLink setup / ISP problem? Did you try that SIM card in another device (e.g. smatphone)?

SIM card and E3372 work perfectly with my UBUNTU-labtop!

i can enter HiLink webinterface, when the E3372 is connected to my labtop...

but how to enter it, connected to openWRT-router, via Luci?

it is not an "old firmware". firmware 22.x is HiLink mode, firmaware 21.x is Stick mode.

no possibility to flash it without open the modem?

put dongle in fallback/recovery/serial mode

usb_modeswitch -v 0x12d1 -p 0x1f01 -n -I -M 55534243123456780000000000000011063000000100010000000000000000

then

then balongflash, translate and read carefully!!!

or use method you already know with windows.

Perfect, so I don't see why you should mess with your USB modem firmware.

Well, you clearly need to setup your new WAN interface. No matter if you use HiLink firmware or not, you'll need a new interface. Once you have it setup using DHCP protocol, you'll see interface IP gateway. Access that gateway IP address to see HiLink web interface.

Connecting HiLink USB device results in new physical interface appearing in your system. It may be eth3 or eth2 or eth1 - depending on your device. Then you should go to LuCI → Network → Interfaces → Add new interface.
Choose some name (e.g. WWAN), select DHCP protocol, set Interface to that ethN. Then assign your new interface to the wan firewall-zone.

I'm sure there are many howtos on how to setup WWAN using USB HiLink dongle.

2 Likes

stick mode = no double nat = best performance. just a matter of personal preference anyways :slight_smile:

There are two ways in which e3372 can operate: stick mode (3g/4g modem, no double NAT) and Hilink mode (ethernet interface, double NAT). Your device is currently in Hilink mode. You can (assuming it's e3372-153) flash a 21.* firmware and enable stick mode. But you don't have to. In this case you need to only configure and activate a new ethernet interface, as @rmilecki explained above.

1 Like

Right. It's however always a bit risky (and time taking) to flash a firmware. So my suggestion is to first try to setup that E3372 as it is (HiLink mode). Then consider more hacking (switching to native / stick mode) if needed.

ok think i got it with hilink-webui

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.