HiLink Huawei e3372 added, but no new ethernet device appears

I'm totally new to OpenWRT. I have been working with computers since the early 90's, mostly DOS and Windows. But I've done my fair share of pfSense and Raspbian, not to mention tons of different wireless routers, still this is something I have no experience with. I have set up a Raspberry Pi 3B, and I have no problems using it as a firewall with the built-in wifi, just as a test. But what I am really going to use it for, is with a Huawei e3372 LTE modem, and it's going to be in my car (using ESPresense and the Hass MercedesMe integration on another Pi connected to it, to mimic keyless entry). So I found this thread Huawei e3372 does not work with OpenWrt and followed what had be done there.

I did an opkg update and then added the packages I should need according to that thread, opkg install comgt-ncm kmod-usb-net-huawei-cdc-ncm usb-modeswitch

They are in, because I get this when I try to do it again:

Package comgt-ncm (0.32-33) installed in root is up to date.
Package kmod-usb-net-huawei-cdc-ncm (5.4.179-1) installed in root is up to date.
Package usb-modeswitch (2017-12-19-f40f84c2-2) installed in root is up to date.

I have also installed a package to check what's going on in USB: opkg install usbutils

Running lsusb I get:

Bus 001 Device 004: ID 0424:7800
Bus 001 Device 003: ID 0424:2514
Bus 001 Device 006: ID 12d1:14db HUAWEI_MOBILE HUAWEI_MOBILE
Bus 001 Device 002: ID 0424:2514
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.179 dwc_otg_hcd DWC OTG Controller

I thought that would work, bot it doesn't. I do not get another ethernet connection that I can add, there's nothing new under device. When I put it in the other Pi, I get the HiLink-interface, and according to that it's all working. The firmware version is

Can somebody please take pity on me and tell me what I need to do?

You'll probably need to insatll kmod-usb-net-cdc-ether for this modem and mode. I don't think it exposes any Huawei NCM function.

cat /sys/kernel/debug/usb/devices 

will confirm.

1 Like

see Huawei e3372h stuck in mode switch

1 Like

@bmork Jøss, er du her også, Bjørn? :rofl: Jeg kunne visst bare spurt på Hjemmeautomasjon... (Sorry, English speakers, that was internal...)

Thanks a lot! I added the package, and bang, it popped up! eth1 in da house! :slight_smile: I can ping VG and all (my goto ping, Norwegian newspaper). So if anybody finds this thread wile trying to get this thing to work, I used these packages:


I don't know if any of them are unnecessary, but at least that's what got me there. The usbutils package was just to check what was going on there.

Btw is it possible to do a dual headed WAN on OpenWRT? So that when my wifi is within reach it will use that instead of the 4G modem? It would have to be without physically pulling the 4G modem out, because the whole seupt is going to be hidden in a box under the dash of the car.

Check if the mwan3 package does what you want: https://openwrt.org/docs/guide-user/network/wan/multiwan/mwan3

Yes, and I'm everywhere :slight_smile:

1 Like

I was going to try adblock, as PeterSV on Hjemmeautomasjon said, but I have a weird problem. I have no Services menu in my setup! :face_with_monocle:

Edit: If that matters I'm using it on the built-in Chrome in Raspbian, but I don't think it should matter.

Great, load balancing could probably work for me, I'll try that out!

Same problem with mwan3 as with Adblock. I installed the packages mwan3 and luci-app-mwan3, and the menuitem "MultiWAN Manager" doesn't surface under the "Network" menu as it should according to the info page. I think I'll flash again tomorrrow and set it up from the ground again, in case I have done something wonky when I've been trying to get it working.

I did a new flash and rebuild, but it doesn't help. I don't get anything new in the Network menu, and I don't get a Service menu at all. I have rebooted, turned off completely and restarted, and I tried a fix from an old GitHub-thread, https://github.com/openwrt/luci/issues/4077

/etc/init.d/uhttpd stop
rm -rf /tmp/luci-*
/etc/init.d/uhttpd start

Nothing helps. :frowning:

Just weird... Tried another SD Card, no result. Tried another Pi...sudenly I managed to install the packages, but now the setting aren't saved when I change anything. I have checked, and only the boot is read only, and there's plenty of space on the other partitions.

Long story, getting longer... :wink: I only installed the other packages and I can now save and do changes. Seems like I'll have to install the Huawei stuff last, when everything else is set up, something in there seems to stop me from making changes that stick. So when I get this working I'll save it on several image backups on my severs!

Finally! I did all the changes I needed and finished off with the Huawei stuff, and I can still save changes, so I guess it was something weird about that first Pi and maybe a garbled download of a package, or something. Everything except for the jail list in Adblock works, so now I'm closing ending this and asking in the Adblock suport thread about the jail list. :grinning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.