Howto install OpenWrt on Asus RP-N53

I am a noob who loves to experiment with Openwrt. And now I am hoping to set up a Mesh using regular devices and then write a recipe for it. I realize its cheaper to buy this tech from Amazon once we consider the value of time but I love this....haha...

So, the first question is how to install Openwrt on RP-N53 (it "rPeeee" and not rTeeeee)!
I could not find a factory bin and so far I have been unsuccessful in using a tftp put on this device.

Any pointers will be appreciated.


Seems to be supported:[Model*~]=RP-N53
If there is no factory bin you can use the sysupgrade directly.

1 Like

I tried this trendy...Asus interface fails it as soon as I try. I tried even an earlier build and I get the same message. I renamed the file as openwrt.trx and it still failed...

Any further clues?

Write to @blogic. He added that device. He should know how to install. There is nothing in the commit message.

Is there SSH access?

Please describe exactly what you have been doing and what happened.

Nope. Just telnet. I was able to log in using telnet. No SSH.

I tried different techniques like pin down for 30 seconds immediately before powerup and held on.
or after normal book, kept the reset pin down for 30 seconds...
Also tried by setting my laptop to / and tried to see if I can catch the tftp early in the boot cyle...and try timeout of 90 and then put the image...
Any suggestions to try?

make sure ur NIC auto negotiation is disabled. You set to100Mbps full duplex same on your router

Hi gibi: I am using ubuntu 19.04 desktop and I could not figure out how to do that. I know exactly how to do that on a Windows machine and perhaps I should try this on a win7 or Win10 machine.

Thanks, I will let you know results.

sudo ethtool -s eth0 speed 100 duplex full

1 Like

Let me try this.

I gave up and tossed it in my box. Its possible that my unit had developed fault.

I emailed blogic and he replied:

you need to attach a serial console cable

Ouch, looks like there's no easy way to install OpenWRT on this device. :slightly_frowning_face:

1 Like

I manged to successfully install OpenWrt via serial cable and tftp ( i used uart to usb cable).
Uart pads is TP2(TX) and TP1(RX) .

Baud rate is 57600


Would you mind documenting the serial connection and the installation procedure on the RP-N53 devicepage?

This would be a great help for other users!


I wrote something like instruction.
English is not my main laguage, so sorry for my grammar.
Edit: Also i cannot upload images to wiki, so if you can, copy paste image from my previous post to the second step


I have added the image.

Since every logged in user can also upload images to the wiki: :slight_smile:


As you labeled TP2 as "TX", therefore we solder TP2 to the "RX" of the USB-to-UART device?
Similarly, TP1 is labeled as "RX", so we solder TP1 to the "TX" of the USB-to-UART device?

Which voltage level should the RX and TX pads accept from the USB-to-UART device? 3.3V or 5V?

Do you mind sharing a link to show the USB-to-UART device that you used?

Will a USB FTDI work? It has the following pins:

  • GND - Ground
  • CTS - Clear to Send
  • VCC - Positive Voltage Output (+5V)
  • TXD - Transmit Asynchronous Data output
  • RXD - Receive Asynchronous Data input
  • RTS - Request to Send

Can I ignore the CTS and RTS pins, and only solder to the GND, TXD and RXD pins, because your instructions don't state the need for CTS and RTS pins?