How to update IP to OpenDNS using DNS-O-Matic

I setup OpenDNS successfully on OpenWRT. However I have problem getting OpenWRT to update my IP address on OpenDNS.

Under the DDNS configuration section I selected OpenDNS as service provider and entered my username and password for OpenDNS, however there is a Lookup Hostname and Domain section that I am unsure what to fill in with.

You need to register with some DDNS-provider and you will get the required parameters:
https://openwrt.org/docs/guide-user/services/ddns/client
Sign in to the DDNS-provider site, navigate to your profile and search for your hostname/domain there.

2 Likes

If you are after a free DDNS service, then you could check Dynu. They have free membership that don't expire https://www.dynu.com/en-US/Membership.

I'm not affiliated to them.

1 Like

I have DNS-O-Matic and it's linked to OpenDNS, but there's no hostname provided. See attached.DNSOMatic

I recommend www.changeip.com as this free DDNS service works well with OpenWrt.

Is that image from an OpenWrt device?

No it's from DNS-O-Matic. No hostname or domain name that can be used in DDNS client.

  • Why are you showing us that?
  • How is it related to OpenWrt?

You are aware that you have to CREATE/REGISTER a domain before you can add one to the client, correct?

It's very unclear why you're showing pictures of DNS-O-Matic and OpenDNS, but nothing on OpenWrt.

What about this?

sionghua.dyndns.org

1 Like

It's in respond to

Anyway, going back to my original question. I attach the screenshoot below. What should I enter for Lookup Hostname and Domain.

I read that; and even after you clarified again, I still have no clue how DNS-O-Matic nor how OpenDNS are involved here. It seems you use them to update all DDNS, instead of just configuring them in OpenWrt.

Perhaps you need the manual from DNS-O-Matic???

https://www.dnsomatic.com/wiki/api#sample_updates

Use custom DDNS client.


Nonetheless, on your picture from DNS-O-Matic, we see:

sionghua.dyndns.org

1 Like

That is because DNS-O-Matic can update both dyndns and OpenDNS.

You are missing the point here again, I am trying to update OpenDNS, not DynDNS. ddns-scripts is already installed.

Read the sentence after:

Did you read the DNS-O-Matic instructions or not?
Do you need more assistance?

URL Authentication : For web browsers or utilities (fetch, curl, lwp-request) which parse authentification section in URL.

https://username:password@updates.dnsomatic.com/nic/update?hostname=yourhostname&myip=ipaddress&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG

Users need to enter a DNS-O-Matic username and password. DNS-O-Matic usernames are 3-25 characters. DNS-O-Matic passwords are 6-20 characters. All ASCII letters and numbers accepted. Dots, dashes, and underscores allowed, but not at the beginning or end of the string.

Users will also enter a list of hostnames (FQDNs) to be updated.

1 Like

Why are you asking then?

I have read it, it mentioned using all.dnsomatic.com but this page says not to use it.
https://openwrt.org/docs/guide-user/services/ddns/client

Only from someone who knows what they are saying, not from a troll.

That's useless, I know that.

Are you reading?
It doesn't say all it says updates:

When I configure custom URLs - they work for me, it doesn't pop out troll food.

I hope the best in your DDNS setup with DNS-O-Matic.

Screenshot%20from%202019-04-14%2010-50-24

Last updated: 2015-07-28

That's a joke, right?

I realized you really didn't read.

From

hostname
https://www.dnsomatic.com/wiki/api#update_parameters

Hostname you wish to update. To update all services registered with DNS-O-Matic to the new IP address, hostname may be omitted or set to all.dnsomatic.com (useful if required by client). This field is also used for services that use different names for the unique identifier of the target being updated (ex. freedns.afraid.org, TZO). DNS-O-Matic will format the update string appropriately for each supported service at distribution.

  • So to fix your issue (adhering to the 2015 Wiki), make an instance for BOTH domains - OR LEAVE THE DOMAIN AS UPDATES AND OMIT THE HOSTNAME PARAMETER
  • or, just setup BOTH OpenDNS and DynDNS in OpenWrt

You're welcome, don't call me a troll again.

1 Like

I did read that and tried it, but it's useless, still not working. Do not assume I didn't read.

Solved the problem using the instruction at the following link, much more helpful compared to the advice I received here.

https://www.leowkahman.com/2016/01/21/configuring-openwrt-and-opendns-to-log-all-dns-lookups/

From the page above:

Set Custom update-url to http://[USERNAME]:[PASSWORD]@updates.dnsomatic.com/nic/update?hostname=all.dnsomatic.com&myip=[IP]&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG

Perhaps just easier to read...but the all.dnsomatic.com domain...you must have forgot that you told me:

Glad you got it working.

1 Like

I did tried that even though it said not to used it. But it did not work.

1 Like

So, how did you edit the URL on the instructions at leowkahman.com ?

Please post so others can properly setup DNS-O-Matic for OpenWrt in the future.