How to restore stock firmware on WR841NV13

I have installed LEDE on WR841N, and now I want to restore to stock fw. Could you tell me how to do this?

Set up a TFTP server on your computer and upload the TP-Link stock firmware to the router.

Even though your router is not “bricked”, this tutorial works for reverts as well…

Rename the stock firmware file wr841Nv13_tp_recovery.bin

I have tried but here is my Log Viewer

Connection received from on port 1237 [24/11 15:52:41.044]
Read request for file <tp_recovery.bin>. Mode octet [24/11 15:52:41.045]
File <tp_recovery.bin> : error 2 in system call CreateFile The system cannot find the file specified. [24/11 15:52:41.045] 

I renamed the file downloaded from TPLink offical website but it always requests tp_recovery.bin file not wr841Nv13_tp_recovery.bin file.
I also changed the folder name to 841 as the guide in your link but nothing changed.
Can you tell me how to fix this problem?
Thank you!

Rename it to "tp_recovery.bin" as the Log suggests.

Yes, I tried. But my router gone brick after flash this file with "tp_recovery.bin" name.
I flashed LEDE fw after brick to save it. :((

try this

NOT for US routers (and possibly EU and IL as well).

Hi, I was not able to install Luci GUI on my TL-WR841N V13, so I had to restore to Stock firmware for solving the problem, just try this.

1 Like

does anybody know how to flash back on US version. the stripped version doesnt work and the factory one doesnt either


What is the soultion to install stock fw again?
I tried serveral original versions but V13 will blink all leds for ever...
Installing again OpenWRT works, but because wifi problems I need original version :frowning: