How to define VLAN's on DIR-842 C1

Hello i have a following config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb3:20eb:042b::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.87'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        list dns '8.8.8.8'

config interface 'VLAN_10'
        option type 'bridge'
        option ifname 'lan0.10'
        option proto 'static'
        option ipaddr '192.168.10.254'
        option netmask '255.255.255.0'

config interface 'VLAN_2_OM'
        option proto 'static'
        option type 'bridge'
        option ifname 'lan0.2'
        option ipaddr '192.168.2.88'
        option netmask '255.255.255.0'

config interface 'VLAN_3_BACKUP_OM'
        option proto 'static'
        option type 'bridge'
        option ifname 'lan0.3'
        option ipaddr '192.168.100.88'
        option netmask '255.255.255.0'


config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '40:9b:cd:a3:bd:9c'

config device 'om_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '40:9b:cd:a3:bd:9e'

config device 'om_backup_eth0_3_dev'
        option name 'eth0.3'
        option macaddr '40:9b:cd:a3:bd:9f'

config device 'iot_eth0_10_dev'
        option name 'eth0.10'
        option macaddr '40:9b:cd:a3:bd:a0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 4 3 2 1'
        option vid '1'
        option description 'LAN'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 3t'
        option description 'VLAN_2_OM'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '10'
        option description 'VLAN_10'
        option ports '0t 4t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '3'
        option description 'Backup_OM_VLAN'
        option ports '0t 5'

but newly added interfaces are not present:

i wonder what am i missed?

Thank you

Wrong ifname, should be eth0.X

1 Like

Ahhhhh
I am blind!

thank you

You're welcome!
If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Hello

after modifying the ifname eth0.10 and eth0.2 is came up but eth0.3 is nowhere so VLAN_3_BACKUP_OM is still down

root@OpenWrt:~# ifconfig | grep -i HWaddr
br-VLAN_10 Link encap:Ethernet  HWaddr 40:9B:CD:A3:BD:A0
br-VLAN_2_OM Link encap:Ethernet  HWaddr 40:9B:CD:A3:BD:9E
br-lan    Link encap:Ethernet  HWaddr 40:9B:CD:A3:BD:9C
eth0      Link encap:Ethernet  HWaddr DE:23:F9:A2:4E:C1
eth0.1    Link encap:Ethernet  HWaddr 40:9B:CD:A3:BD:9C
eth0.10   Link encap:Ethernet  HWaddr 40:9B:CD:A3:BD:A0
eth0.2    Link encap:Ethernet  HWaddr 40:9B:CD:A3:BD:9E
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb3:20eb:042b::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.87'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        list dns '8.8.8.8'

config interface 'VLAN_10'
        option type 'bridge'
        option ifname 'eth0.10'
        option proto 'static'
        option ipaddr '192.168.10.254'
        option netmask '255.255.255.0'

config interface 'VLAN_2_OM'
        option proto 'static'
        option type 'bridge'
        option ifname 'eth0.2'
        option ipaddr '192.168.2.88'
        option netmask '255.255.255.0'

config interface 'VLAN_3_BACKUP_OM'
        option proto 'static'
        option type 'bridge'
        option ifname 'eth0.3'
        option ipaddr '192.168.100.88'
        option netmask '255.255.255.0'


config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '40:9b:cd:a3:bd:9c'

config device 'om_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '40:9b:cd:a3:bd:9e'

config device 'ombu_eth0_3_dev'
        option name 'eth0.3'
        option macaddr '40:9b:cd:a3:bd:9f'

config device 'iot_eth0_10_dev'
        option name 'eth0.10'
        option macaddr '40:9b:cd:a3:bd:a0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 4 3 2 1'
        option vid '1'
        option description 'LAN'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 3t'
        option description 'VLAN_2_OM'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '10'
        option description 'VLAN_10'
        option ports '0t 4t'

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option vid '3'
        option description 'Backup_OM_VLAN'
        option ports '0t 5'

i try to modify option macaddr it is not helped

What's the output of swconfig dev eth0 show ?

root@OpenWrt:/overlay# swconfig dev eth0
swconfig list
swconfig dev <dev> [port <port>|vlan <vlan>] (help|set <key> <value>|get <key>|load <config>|show)

root@OpenWrt:/overlay# swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
        ar8xxx_mib_poll_interval: 500
        ar8xxx_mib_type: 0
        enable_mirror_rx: 0
        enable_mirror_tx: 0
        mirror_monitor_port: 0
        mirror_source_port: 0
        arl_age_time: 300
        arl_table: address resolution table
Port 0: MAC 40:9b:cd:a3:bd:b0
Port 3: MAC 80:e8:2c:93:9f:c4
Port 3: MAC c4:a3:66:f4:31:35
Port 3: MAC bc:cf:4f:fd:e8:77
Port 3: MAC 00:11:32:49:0e:ff
Port 3: MAC 02:07:5a:5c:fc:55
Port 5: MAC 02:07:e8:23:49:f2

        igmp_snooping: 0
        igmp_v3: 0
Port 0:
        mib: MIB counters
RxGoodByte  : 2394469 (2.2 MiB)
TxByte      : 6456279 (6.1 MiB)

        enable_eee: ???
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 0
        link: port:0 link:up speed:1000baseT full-duplex txflow rxflow
Port 1:
        mib: No MIB data
        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 1
        link: port:1 link:down
Port 2:
        mib: No MIB data
        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 1
        link: port:2 link:down
Port 3:
        mib: MIB counters
RxGoodByte  : 5187762 (4.9 MiB)
TxByte      : 2367415 (2.2 MiB)

        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 1
        link: port:3 link:up speed:1000baseT full-duplex txflow rxflow auto
Port 4:
        mib: No MIB data
        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 1
        link: port:4 link:down
Port 5:
        mib: MIB counters
RxGoodByte  : 1506086 (1.4 MiB)
TxByte      : 0

        enable_eee: 0
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 4
        link: port:5 link:up speed:1000baseT full-duplex txflow rxflow auto
Port 6:
        mib: No MIB data
        enable_eee: ???
        igmp_snooping: 0
        vlan_prio: 0
        pvid: 0
        link: port:6 link:up speed:10baseT half-duplex
VLAN 1:
        vid: 1
        ports: 0t 1 2 3 4
VLAN 2:
        vid: 2
        ports: 0t 3t
VLAN 3:
        vid: 10
        ports: 0t 4t
VLAN 4:
        vid: 3
        ports: 0t 5

Please edit the previous post with preformatted text for the console output.

This looks good.
I suspect the name you used is too long. Limit it to 15 characters.

1 Like

Thank you!

You was right it was too long

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.