How to configure SIM card on my router?

My router type is tp-link tl-mr6400 v5, I insert SIM card to it and I want to configure this sim in order to get internet from it, So how Can I do this ?

Any help please.

install the luci-proto-3g package, it'll get you the option to create a mobile carrier interface in Luci.
or perhaps luci-proto-qmi.

When I run this command opkg install comgt kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan usb-modeswitch

These errors are appeared :

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.90-1-82ef708180508031f09399f743b51f11) for kmod-nls-base
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.90-1-82ef708180508031f09399f743b51f11) for kmod-usb-core
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.90-1-82ef708180508031f09399f743b51f11) for kmod-usb-serial
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.90-1-82ef708180508031f09399f743b51f11) for kmod-usb-serial-wwan
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.90-1-82ef708180508031f09399f743b51f11) for kmod-usb-serial-option
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial-wwan:
 *      kernel (= 5.10.90-1-82ef708180508031f09399f743b51f11)
 * opkg_install_cmd: Cannot install package kmod-usb-serial-wwan.

How can I solve this problem ?

I am trying to download this package luci-proto-3g but it tell me Cannot install package luci-proto-3g.
Any suggestion .

Not without an error message...

This message appeared ...

Unknown package 'luci-proto-3g'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci-proto-3g.

The package is available...

Do an Update lists... in LuCI, then search the available packages.

or SSH in to the router and run...

opkg update
opkg install luci-proto-3g

1 Like

I found it brother Thank you.

Can you tell me the next step how can I activate it in order to get internet from sim card?

create a new interface, poiting toward your modem, as per the 1st reply in this thread ....

These are my options, which one should I choose ?

none, (probably) wrong protocol.

Hi
Have you installed:

kmod-usb-net-qmi-wwan
luci-proto-qmi
uqmi

What kind of device is associated with your modem?
ls /dev

I installed all of them, then I choose this protocol UMTS/GPRS/EV-DO and then I filled all necessary information but I didn't get an IP.

Any idea about this problem.

post the details for the interface you created ...

de

Knowing that I am living in turkey.

ttyS1 doesn't sound right, but I'm no expert in QMI devices.

I have these modem devices.

d

well, that's only half of the list .... :slight_smile:

what do you have that isn't ttySxxx ?

I have only ttySxxx and /dev/cdc-wdm0.