How to configure PPPoE without PD prefix, only a /64

Excuse me, how to configure those PPPoE that do not have a IPv6 PD prefix and only give a /64?
If I set the automatic mode, wan_6 can get the range of /64, not without the PD prefix. But if I set 1, that is, manual mode, there is almost no /64. Then I also tried to keep the automatic mode on the pppoe interface, set the wan_6-to-LAN relay under / etc/config/dhcp and / etc/config/network, and then turn on the default route on LAN, but it didn't seem to work. The LAN port still couldn't find / 64.

Ideally change to a provider who know ipv6 better than the current one.
Otherwise use relay.

1 Like

I'm sure I tried relay mode as described, but there was no /64 on the lan interface. And then I want to know how to solve this situation instead of choosing to escape.

There won't be any /64 on the lan, because:

What you will have is a relay between lan and wan.

So how do I know if the test is successful? I remember I tested sending ping packets to wan_6 's address.

First check if the lan hosts acquire ipv6 settings.

1 Like

OK I see the problem... Document said Ensure the lan interface has option ip6assign 64 (or a larger prefix size) set to redistribute the received prefix downstream. Now I am fine.

There seems to be some strange problem with the relay IPv6?
When I try to combine it with 6in4, it(IPv6 DNS of lan) doesn't work whether the IPv6 DNS of lan is set manually or not (and will be three uselessaddress), and the address of 6in4 will not be sent in this state. This time I am sure I have set the mixed mode properly.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; ifstatus wan; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*