How to configure OpenWRT to access printer on upstream subnet?

Hi there,

I just installed OpenWRT on my router, and I'd like to access a printer that is on the WiFi network of the router upstream from mine.

Can anyone let me know what configuration in OpenWRT needs to be applied in order to do so? Graph attached.

Depends on the printer, but it could work out of the box.

neh not so much

I have the printer's IP address on upstream subnet, so i'm just going to try to set up a static route from my router to go up to it. just not sure whether to use for "route type"?


Static routes are not necessary in this situation. You probably will simply need to access the printer via its IP address. Keep in mind that not all printers will work across subnets.

Can you ping its IP address?

Skip it, just try to print, using it's 192.168.68 IP.

ok will try to add it as a network printer with that IP address.

out of curiousity, any idea why it's IP address is invalid in OWRT's static route config page on Luci?

Add /32 for single address route

will do, thanks.

i added it without any config via windows add network printer, selecting 'ipp' protocol, but it is reporting an error when i try to print.

does the printer support ipp (and is it configured/enabled if it is supported)?

1 Like

grabbing all the drivers and bloatware from, will see if that helps. wish it wasn't all buried in garbage but that's how it is.

If in doubt, try connecting directly to the upstream network and then try the different protocol options for the printer. Airprint and other mdns/auto-discovery methods will not work, but you can test the others by directly specifying the IP address of the printer while on the same network. Once you find what works in that environment, it should work behind your router.

Test with telnet or nc, the goal is to not see any error message.

root@openwrt:~# nc 515
root@openwrt:~# telnet 515

515/TCP is a standard LPR port.


Downloading all that crap from Canon fixed it (despite Windows being able to detect it).

Software firewall config was another story but it's working (enough) for now. Thank you for the help

you're welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.