Hello, I've got TD-W8980 and Mi 4A Gigabit both running on latest OpenWrt snapshot. Currently I'm using TD-W8980 as DSL modem and router, and Mi4A Gigabit as dumb ap. As you can guess, Lantiq XRX200 is barely able to do anything besides the very basic tasks, thus I want to use TD-W8980 as DSL modem only (often called bridge mode on proprietary firmwares) and initiate PPPoE connection on Mi 4A Gigabit. I couldn't find any guides for DSA. @moeller0 Maybe you could help.
Check the BTHub5a guide referenced on its wiki page, different device, same SOC and behaving very similarly.
If your TD-W8980 is correctly functioning in bridge mode using stock TPlink firmware, then simply select PPPoE protocol in the WAN interface on your OpenWrt Xiaomi.
Unfortunately it is not working reliable on stock firmare.
See section 9.8 for DSL bridge modem in the HH5a installation guide pdf if running OpenWrt.
Use a non-DSA version of OpenWrt on the TD-W8890. OpenWrt 19 worked well for me in the past.
If you are using bridge mode on TD-W8980 using stock TPlink firmware, are you sure it is correctly configured and functioning? If you have a Windows computer, set it up for PPPoE to test the bridge mode function on W8890.
https://www.tp-link.com/uk/support/faq/921/
The problem with stock firmware is it's use of unstable DSL firmware.
Those instructions on guide are for swconfig, I'm not sure how to apply them on DSA.
I just found this post for DSA option (ADSL config)
https://forum.openwrt.org/t/using-a-vdsl-modem-router-as-bridged-modem/137987
or just try non-DSA Openwrt (eg. 19.07) on the TD-W8890 to see if it resolves the stability issues you witness with stock TPlink firmware.
Here is my /etc/config/network from a FritzBox 7520 running under OpenWrt configured as bridged modem using DSA. Note on my router I use VLAN7 to connect with br-dsl which uses dsl0.7 because my ISP requires VLAN7 for the WAN traffic I also use VLAN42 on the same port so I can access the modem's GUI from within my network (via a static interface on my primary router with address 192.168.100.2 that is part of the WAN zone). I can not guarantee that this will work on xrx200, but as far as I can tel it should give you at least some starting points..
Sidenote, changing br-lan from its default mode of no VLAN to any VLAN is tricky as it requires changes in two places before applying them...
root@OpenWrt_FB7520:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdcd:4cf3:765d::/48'
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'
config dsl 'dsl'
option tone 'b'
option annex 'b'
option ds_snr_offset '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option proto 'static'
option ip6assign '60'
option device 'br-lan.42'
list ipaddr '192.168.100.1/24'
config device
option name 'dsl0'
option macaddr '98:9B:CB:C0:F5:BB'
config interface 'wan'
option device 'dsl0'
option proto 'none'
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
config bridge-vlan
option device 'br-lan'
option vlan '42'
list ports 'lan1:t'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config bridge-vlan
option device 'br-lan'
option vlan '7'
list ports 'lan1:t*'
config device
option type '8021q'
option ifname 'dsl0'
option vid '7'
option name 'dsl0.7'
config device
option type 'bridge'
option name 'br-dsl'
list ports 'br-lan.7'
list ports 'dsl0.7'
config interface 'MODEM'
option proto 'none'
option device 'br-dsl'
`
my tested recommendation DSA ready.
Thank you so much! I just changed the VLAN7 to VLAN35 because of my ISP and your config works. I just couldn't configure how to access to modem from router but I'm still trying.
I simply had to add:
config interface 'WAN4FB7520'
option device 'eth2.42'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.100.3'
to the /etc/config/network on my primary router and make sure that this interface is in the wan zone in the firewall GUI. Note eth2 s my router's wan interface and I use eth2.7 to reach the dsl bridge on the modem and eth2.42 to reach the modem itself (where I installed luci-mod-dsl to get some nice dsl information)
Just to add another datapoint, because I've been doing it slightly differently: This is an extract from the network config of my FritzBox 3370, also a DSA-enabled XRX200 device.
config dsl 'dsl'
option annex 'b'
option tone 'av'
option firmware '/lib/firmware/fritzbox-7490-7.29--5.9.1.4.0.7-5.9.0.D.0.2--vr9-B-dsl.bin'
option ds_snr_offset '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
option bridge_empty '1'
config bridge-vlan
option device 'br-lan'
option vlan '1'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
list ports 'lan4:u*'
config bridge-vlan
option device 'br-lan'
option vlan '7'
list ports 'dsl0:t'
list ports 'lan4:t'
config interface 'lan'
option device 'br-lan.1'
option proto 'dhcp'
This way I had PPPoE passthrough on the lan4 port, ingress and egress VLAN tag 7 (change as needed). The whole switch, however, added itself to the regular untagged network it is connected to, meaning the "modem" was accessible in my router's LAN under whatever IP it received through DHCP, and all the ports worked as a regular switch, giving three more ports for other network devices. On the router side, I would tag one port with VLAN id 7 and use it as the WAN interface and untagged LAN on the same port. Best of all worlds.
Maybe that helps.
Adding it to firewall as wan and rebooting both devices fixed it. Thank you again.
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.