Using a VDSL modem/router as bridged modem

My HH5A is installed Openwrt 22.03.0 using DSA. Here is how I use it as a bridged modem to provide ISP connection to my main router. You can use same config for other OpenWrt installed routers, too.

This is my '/etc/config/network' file:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd53:32db:be0e::/48'
	option packet_steering '1'

config atm-bridge 'atm'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'
	option vci '33'
	option vpi '0'

config dsl 'dsl'
	option annex 'a'
	option ds_snr_offset '0'

config device
	option name 'br-lan'
	option type 'bridge'
	option stp '1'
	option igmp_snooping '1'
	option promisc '1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'lan1'
	option macaddr ''xx:xx:xx:xx:xx:xx"

config device
	option name 'lan2'
	option macaddr ''xx:xx:xx:xx:xx:xx"

config device
	option name 'lan3'
	option macaddr ''xx:xx:xx:xx:xx:xx"

config device
	option name 'lan4'
	option macaddr ''xx:xx:xx:xx:xx:xx"

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.6'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config device
	option name 'dsl0'
	option macaddr ''xx:xx:xx:xx:xx:xx"
	option promisc '1'

config device
	option name 'wan'

config device
	option type 'bridge'
	option name 'modem'
	list ports 'dsl0'
	list ports 'wan'
	option bridge_empty '1'
	option macaddr ''xx:xx:xx:xx:xx:xx"
	option mtu '1500'
	option vlan_filtering '1'

config interface 'modem'
	option proto 'none'
	option device 'modem'

Note: If you want to use HH5A as a dump AP you should connect one of HH5A's lan ports to the router. In this case please disable these services: dnsmasq, firewall, odhcpd.

Where should I write the vlan id 35 value?

dsl0.35