How do I get started with a snapshot device?

I have a TP-Link Archer C6 running with OpenWrt 19.07.6, the installation seemed straight forward, and the basic functionality is usable.

Now I wanted to convert a cheap repeater to OpenWrt, too. It is a Maginon WLR-755AC. There is an image fort this, but it is from the snapshot branch:

I got it installed, but of course there's no LuCI. I can connect my Laptop by cable to the WLR755ac and ssh to But since it's not connected to the internet, I can't install anything.
I managed to activate wireless 2.4GHz, and now I can also connect my laptop to the WLR755ac without cable. Fine.
Connected the WLR755ac to the OpenWrt-Archer-C6 by cable. But now I don't know how to ssh to it anymore. My laptop has a wireless connection to the WLR755ac, which is connected to the OpenWrt-Archer-C6, and the laptop can see the Internet. So the WLR755ac seems to route traffic between my laptop and the Archer-C6. The IP address now is the Archer-C6.
What is the IP address of the WLR755ac now?

Or what is the recommened path to get a newly installed device with a snapshot connected to the internet and install LuCI? (I have found the commands to install LuCI, but the device needs to be have the internet connection first.)

Sorry for this basic question. I am stuck and have wasted way too much time...

Ok, I powercycled the WLR755ac, then connected my Laptop by wireless to it (SSID: OpenWrt, without passphrase). Opened a ssh connection to, then connected the WLR755ac via cable to a Fritzbox internet router (, a ping to a website was successful, then issued:

root@OpenWrt:~# opkg update
root@OpenWrt:~# opkg install luci

I saw some errors:

Configuring rpcd-mod-file.
Configuring rpcd-mod-luci.
Command failed: Not found
Configuring luci-base.
Configuring luci-proto-ipv6.
Configuring uhttpd.
4+0 records in
4+0 records out
Configuring uhttpd-mod-ubus.
Configuring rpcd-mod-rrdns.
Command failed: Not found
Configuring luci.

Tried to connect to in a browser window, the address reads "", but I can't get a connection.

All this does not feel right...

For the transition from stock WLR-755ac to snapshot OpenWrt I have used the TFTP method, and the image was a ...sysupgrade.bin imgage. (I think there is no ..factory image?)

Can this be a problem?
How can I find out why LuCI does not start?
Or is it just this snapshot image, that is somehow broken?

Ok, for the records, for other beginners:

It was not necessary to connect my Laptop by wireless. It is possible to connect the laptop with a cable to the WLR755ac, wait (a long time) until it got an ip address. Then connect the WLR755ac with a cable on the second port to the internet router (Fritzbox 7490).

By this, I was able to open a ssh connection to the WLR755ac from my laptop, while the WLR755ac still had internet access.

Now it was possible to download the latest snapshot image into /tmp with wget.
Then installed it with sysupgrade.
Then installed LuCI again.

...and right now it is working!

So I guess, it was a problem with the snapshot on this day.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.