Help with OpenWrt network configuration

That's a good point.

This is why I figured it was working with tagged networks, but maybe this was all just arbitrary assignments by the OP.

This is a good point. Watch out for the cheap 2-pair cables that often came with DSL modems, they will not work properly if you try to use one to connect two gigabit Ethernet devices. When you look through the clear plastic of the plug there needs to be eight wires coming out to the gold pins, not four.

At the moment i am trying to make it work. Gb cable is in concrete wall. That is why I can't add more of them (me stupid.... not thinking about expanding upper floor network)
There was 2 routers laying around and why not use them as simple manageable switch instead of buying.
In here they are way too expensive for our incomes
Buying them is last solution.

hope you can help me tomorrow or any other day, no hurry... i'm giving up for tonight

Thank you in advance

Did you confirm the connections and run the ping tests? That will provide a lot of key information.

Hi there

On the side N16 when i connect to LAN4 i can ping and access main modem, N16 and 1043ND.
Also internet.
If I plug IPTV on 1043ND in LAN2, I got nothing. Only ping to main modem/router.

Main modem is 100mbps per port. All other are Gbps

DSL modem is ZTE ZXHN H168N V3.1

This sounds like everything is working as expected here.

This is probably also working as expected. The IPTV network probably doesn't need access to the internet (the IPTV network is served by the ISP and is not for general internet use), and because the 1043ND and N16 are not actually connected to the IPTV network (they simply pass it through via the switch/VLANs), the only device that should be accessible is the main ISP router.

Based on all of this, I don't expect that there would be any remaining issues. But if there are still problems, please explain what the symptoms are.

Yes,

Address on one of the STB I get is 10.232.31.129
default gateway 10.232.0.1
netmask 255.255.128.0
dns 93.87.84.26
dns1 93.87.24.28

This is not configurable, i am getting this thru dedicated LAN2 and LAN3 ports, they are only for IPTV on modem/router

One thing.... with IPTV plugged in LAN2 I can't access Internet

Can you elaborate here:

  • which router?
  • What is connected to LAN2 -- is this the IPTV connection from the ISP router? or the IPTV set-top-box for the TV itself?
  • If you unplug this connection, does the internet start working again?

If I unplug LAN2 on 1043ND, internet works
STB is connected to LAN2 on N16, then STB to TV

ZTE modem/router is 4 port router, 1 and 4 are for internet, 2 and 3 are for IPTV which goes to STB. ISP provides modems and STB

try using LAN3.

Both internet and IPTV goes down. Nothing works.

let's review things again.

Starting with the 1043ND, please post your /etc/config/network file.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1a:363d:cb02::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        option igmp_snooping '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.20'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5t 1 3 4 0'

config switch_vlan
        option device 'switch0'
        option ports '2t 0t'
        option vlan '200'
        option description 'IPTV'

This looks fine, except for possibly the tagged VLAN200, as @mk24 had brought up earlier.

Where did you get the VLAN ID (200) for the IPTV? Is this from the ISP (or searching the web about the IPTV VLANs from the ISP router)?

Also, what happens if you do the following:

  • unplug the cable from the 1043ND WAN port (breaking the connection to the N16).
  • connect the internet from your ISP router to 1043ND port 4
  • disconnect connect the IPTV (from your ISP) from 1043ND port 2
  • connect a computer to 1043ND port 1 or 3
  • Does the internet work?

  • Now connect the IPTV to the 1043ND port 2
  • does the internet still work?

Yes, it works

VLANID is on the main modem/router. Also others use this on managed switches.

EDIT: Disregard the following... it looks like port 5 is the CPU, and port 0 is the WAN port that is being used for the link to the other OpenWrt device.

It appears that VLAN 1 is not currently tagged on the CPU, but it should be. Try fixing that and then see if things work as expected.

Is this referring to the internet working both situations (i.e. the IPTV cable disconnected from the 1043ND and also when it was connected)?

If so, try keeping both the internet and IPTV connections from the ISP router connected to the 1043ND, and then plug in the cable that goes to the N16 (into the 1043ND WAN port). Does it still work or do things break?

It breaks connections, when i plug WAN port (it is used as connection between 2 OpenWRT routers)

Do I need to add one more VLAN 300 as Internet?

No, don’t add vlan300.

Let’s look at the network file from the n16.