Help with OpenWrt network configuration

Yes, i understand
I want to for example on WR1043ND to connect to LAN 2 IPTV, to LAN 4 Internet, and uplink both of them to WAN (want to configure WAN port as normal LAN) and thru 1 cable send to WAN (again as common LAN) and divide to LAN2 IPTV and LAN 4 Internet, aaaand bridge WIFI to LAN for as AP.
I know i confused you but this is first time that i am setting this up in OpenWrt.
And yes other ports needed to be for computers

Tell you what -- please revisit your diagram from earlier. Put the physical port numbers that you want to connect each device in that diagram.

We still need to know the physical to logical port mapping, but I think updating the drawing would be a good start and less confusing.

I want to my ISP router/modem be DHCP server
Hope diagram is more clear.
On 1043ND ports are mirrored, but there is option to mirror them to show real LAN port

Ok... on your RT-N16:
VLAN 1: off on all ports
VLAN 2: tagged on CPU (eth0), untagged on WAN. Untagged on LAN 1, 3, 4
VLAN 200: off on CPU, LAN 1, LAN 3, LAN 4. Tagged on LAN 2 and WAN.
VLAN 300 -- delete.

Done that
Next step? :smiley:

show the /etc/config/network file from the WR1043ND.

You might consider reading the Quick Start Guide, and then referencing the User Guide...

something goes wrong 
setted up as dumbAP as N16 but  i get

 OpenWrt 21.02.1, r16325-88151b8303
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# /etc/config/network
-ash: /etc/config/network: Permission denied
root@OpenWrt:~#

cat /etc/config/network

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1a:363d:cb02::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.20'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'

type or paste code here

ok. please confirm:

  • WAN port on WR1043ND connects to the WAN port on the RT-N16
  • LAN 2 to the IPTV connection from your ISP router?
  • Then what about the other ports?

Downlink all

LAN 4 need to be on Internet to modem LAN 2 on IPTV

What about 1043

Vlan 1: tagged on cpu, untagged on lan 1, 3, 4 and wan. Off on LAN2.

Vlan200 tagged on wan and lan 2. Off on all others.

Done that. I needed to transfer to 4G to reply
It is a bit slow. and no exit to internet

Here is the settings in switch

Asus

1043ND

Confirm connections:

  • DSL Modem Internet <-> WR1043ND port 4
  • DSL Modem IPTV <-> WR1043ND port 2
  • WR1043ND WAN <-> RT-N16 WAN
  • PC to RT-N16 port 4 (in this case, it looks like physical port 4 maps to logical LAN 1)

Confirm that PC is set to get address via DHCP
Then run some ping tests:

  • 192.168.1.30
  • 192.168.1.20
  • 192.168.1.1
  • 8.8.8.8
  • google.com

Report results of all of these things.

Tagged and untagged on the same cable is not a best practice and does not work on all hardware / drivers.

As I said before, the VLAN number of the LAN network needs to be the same on both ends. Right now you still have it as 1 on the TP-Link and 2 on the Asus. On the router that you change, it will also require going to the Network-Interfaces page and editing the LAN to change the physical device from eth0 dot the old vlan to eth0 dot the new vlan.

Then tag both VLANs on the interconnecting cable. The ports that are connected to the TV network of the modem on one router and the TV box on the other router should be untagged in most cases where they were intended to be simply connected together by a direct cable. (Though it is also possible the system uses a tag on TV packets anyway, then you would need to find out that tag number and install it in your switches.)

BTW, you have a 10Mbps Full Duplex connection on the 1043ND port 2 and a 100Mbps Full Duplex connection on port 4 -- those are the connections to your DSL Modem. You might have an issue with one of those cables -- especially the 10Mbps connection on LAN2 is very suspicious.

What DSL modem are you using?

In most cases, this is a matter of opinion/style, although it is a possible issue with some hardware.

The ping tests should reveal if this is functioning properly.

I'm not sure about this -- if it is VLAN 100, the IPTV boxes may be expecting tagged frames. This is easy to figure out once the general connectivity is validated.

Though I think the OP did say he connected a laptop to the TV port of the modem and received a 10.x IP address, so that would mean at least something is untagged.