HELP: Use RTL8814au in Client Mode on Raspberry PI

Hi all,
I have installed openwrt on my Raspberry Pi Model B and using a USB dongle with Mediatek MT7601u I can scan and connect to create a WISP router.

But now I want to use a RTL8814au USB adapter but I cannot manage to get it to work.
The Mediatek on is visible and working after installing the driver but the RTL8814au is detected after installing the 8812au driver.

Can someone guide me please?

I only require client mode, I don't need AP mode.

Thanks in advance

still relevant OpenWrt on Orange pi R1 - #14 by slh

1 Like

So, basically it is not possible?

No even in client mode only?

I just want to make a WISP router with the components that I have already :frowning:

client mode should work, whats the VID and PID, if you do a lsusb ?

lsusb shows

0bda:8113 Realtek 802.11ac NIC

Seems no one's worked with this radio before, there are zero hits for 0bda:8113, except for your post...

So this could be some different flavor of the 8814au chipset? Maybe manufacturer changed the VID and PID

This is the device specs: EP-AC1621

I have used this same USB adapter with KALI 2022 and it worked fine with the 8814au driver.

Try the snapshots, newer kernel, might suffice.

Kali might have an agreement with RTL, allowing them to distribute drivers.

1 Like

OK, I will try.
Thanks for your input!