Help setting up VLAN OpenWRT 23.05

I have a dumb access point where I want to broadcast two networks, the first is the main network, and the second is a separate VLAN interface for guests. There are lots of devices connected to the various ports on the router, all through unmanaged switches, all of which I want to plug and unplug and they don't even know they are on a VLAN. The AP is connected only to port 2. I have attached my config file below. I was able to successfully get the AP to communicate with VLAN 3 for the guest network, but it isn't communicating with the main network. I am completely new to this so please help me out. I heard from a tutorial on YouTube that I want my VLAN3 tagged and the rest untagged? I have read some of the other forums about setting up VLANs and they don't seem to meet my case.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd6c:19c8:70dd::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config device
	option name 'lan1'
	option macaddr {Redacted}


config device
	option name 'lan2'
	option macaddr {Redacted}


config device
	option name 'lan3'
	option macaddr {Redacted}

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '10.119.40.3'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr {Redacted}


config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	option dns '127.0.0.1'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option peerdns '0'
	option dns '0::1'

config device 'guest_dev'
	option type 'bridge'
	option name 'br-guest'
	list ports 'eth0'
	list ports 'lan2'
	option bridge_empty '1'

config interface 'guest'
	option proto 'static'
	option device 'br-guest.3'
	list ipaddr '192.168.3.1/24'

config bridge-vlan
	option device 'br-guest'
	option vlan '3'
	list ports 'eth0'
	list ports 'lan2:t'

config bridge-vlan
	option device 'br-guest'
	option vlan '1'
	list ports 'eth0:t'
	list ports 'lan2'

I'd recommend resetting the dumb AP to defaults, then posting the config file here. This will be the cleanest starting point and will ensure that we understand exactly the expected ports and details.

The other thing we need to know is how the upstream router is configured with respect to VLANs -- seeing that config could be useful, too. We need to know the subnet that is used to manage the dumb AP and the address that the dumb AP should take on the network.

The dumb AP should usually be connected LAN-LAN, so we'll also want to make sure the the dumb AP's DHCP server is disabled.

So, please post the default config from the dumb AP and the config from the upstream router, as well as the address for this dumb AP.

The dumb AP is a Netgear WAX214, and runs a modified version of OpenWRT. I just factory reset it as I had locked myself out. There is one router in my setup (ISP IN>MODEM>ROUTER (WAX202)>AP/CLIENTS) which is running vanilla OpenWRT 23.05.2 with mostly default setup, minus a created "Guest" interface and firewall profile. The dumb AP has its DHCP disabled by default and gets an IP of 10.119.40.228 from the router (the subnet for the main network is 255.255.255.0). If i do not touch any VLANs on the main router, the AP works fine and clients that connect to it get an IP address from the main router network as expected. What I want is to keep this functioning as is but make a guest SSID on the AP that connects to, say VLAN3 on the router which links to Interface "Guest"

1 Like

This device doesn't appear to be supported by the official OpenWrt project. Where did you get the modified OpenWrt from?

It runs the stock firmware that came with the device.

In that case, please reach out to Netgear. Their stock firmware is not supportable here because we don't know anything about it.

I believe there is a misunderstanding. My Router, the device I need help configuring, is a Netgear WAX202, running OpenWRT 23.05.2. I want to setup VLANs on this device to work with my AP, which just simply asks for a VLAN ID when setting up the SSIDs.

Oh... sorry. Sure.

Let's see your config from the WAX202 (presumably in the default state, or not far from that state).

I thought you were going to reset the main router to defaults and then post that config?

1 Like

I did forget to mention that the Router uses DSA, I know how to work with sw-config, but not so much DSA.

No problem... I can help you with the DSA config. It's not so hard once you get used to it.

But post your default config and we'll get you running.

I just Factory Reset the router....


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdee:f37c:c9bc::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config device
	option name 'lan1'
	option macaddr 

config device
	option name 'lan2'
	option macaddr 

config device
	option name 'lan3'
	option macaddr

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr '80:cc:9c:e7:bc:84'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

Thanks.

First, we'll create bridge-VLANs. It appeared that you were trying to make port lan2 the trunk that connects to your AP. So we'll do that again here.

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan3:u*'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan2:t'

Next, we'll edit the lan network interface to use br-lan.1:

config interface 'lan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

And now we can add the guest network:

config interface 'guest'
	option proto 'static'
	option device 'br-lan.3'
	list ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

Over to the firewall... we'll assign this new network to a new guest zone. That zone will allow internet access, but will not be allowed to connect to the router itself except for DNS and DHCP, nor will it be allowed to connect to the trusted lan.

config zone
	option name 'guest'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	list network 'guest'

config rule
	option name 'DNS-guest'
	option src 'guest'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'DHCP-guest'
	list proto 'udp'
	option src 'guest'
	option dest_port '67-68'
	option target 'ACCEPT'

config forwarding
	option src 'guest'
	option dest 'wan'

Finally, you'll want to add a DHCP server to the guest network. In the /etc/config/dhcp file add this:

config dhcp 'guest'
	option interface 'guest'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'

Restart the router and you should have a working guest network -- tagged VLAN 3 on port lan2.

1 Like

You're the best mate! Thank you so much for helping me! So, basically, what I was doing wrong was I was creating a separate bridge for the guest when I didn't have to. It makes so much sense now! Thank you!

Glad I could help. Yeah, you just needed to use bridge-VLANs on top of the standard br-lan.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.