Help fix switch


22.03.2 and MT7620

I build my DTS
My hardware only has ETH0 as lan (not usually WAN)

Also apply change to /etc/board.d/02_network
Switch screen on luci never change.

"Switch switch0 has an unknown topology - the VLAN settings might not be accurate." message
And wrong port appairs


        "model": {
                "id": "geva,batterypoe",
                "name": "GEVA Battery POE"
        "network": {
                "lan": {
                        "device": "eth0",
                        "protocol": "static"

Comparing Asus RT-ac5 dts:

&ethernet {
	nvmem-cells = <&macaddr_factory_28>;
	nvmem-cell-names = "mac-address";
	mediatek,portmap = "wllll";

With my dts:

//Enable eth and set MAC/switch defaults
&ethernet {
        status = "okay";
	//it's useless because your factory is empty and MAC is incorrect
	//but linux define random MAC if invalid
        mtd-mac-address = <&factory 0x4>;
        mediatek,portmap = "wllll";

This has worked well until now, from the V19
I don't understand the differences, if the cause are changes in the versions.

If someone can help me.
And I have a question.

The board.json file is created at the boot ?
If I edit 02_network on the targhet and reboot unit, i can see effect of the change on the luci page and on the board.json file ?

The function ramips_setup_interfaces is not provided by your 02_network file. This function would have set up the switch as required.

As it looks as if you are using a custom build of OpenWrt, why don't you submit your changes upstream so that others could use this device as well?

I never cared about board.json when adding a device, I'm pretty certain it's auto-generated during boot.

not, sorry, missing a part of file.

I have tryed this:
Also without ;;

Also this:
Containing geva,batterypoe|\

There is only 1 LAN-Port, right? Are you sure the switch is used at all? Take the TP-Link RE200v1 for instance, the switch is disabled there. In this case you would remove the portmap from the dts and add your geva,batterypoe case to 02_ethernet in the tplink,re200v1 stanza.

Switch is inside chipset.
Chip has 5 port, but I have only connected one.
I have used wan, thinking it had better performance.
But I remind you that everything worked fine in previous versions of Openwrt

That doesn't mean that it was properly configured. I'm out of ideas then, the RE200v1 was the last device with an mt7620a that I worked with. You might get more/better responses if you post your question to the mailing list instead.

My DTS is right ?
What are difference from asus dts and my dts ?
asus dts do not have "okay"

Solved if i change this file, before build.

Changing file inside device not work.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.