Help complining Firmware support KPN superwifi

Hi everyone,

I’ve successfully installed OpenWrt on a KPN Super WiFi Point (Arcadyan hardware exactly type not know) using the firmware from the KPN Experia (Arcadyan WE420223-99), as outlined here: OpenWrt Arcadyan WE420223-99. The device boots into OpenWrt, and many functions work, but I’m facing some issues and need help generating a custom firmware.

Current Status:

  • The device boots successfully into OpenWrt.
  • One of the WiFi chips (Mediatek MT7615N) works, but only on the 5 GHz band. The 2.4 GHz band is not functioning.

Hardware Details:

  • Flash Chip: Winbond Q250JVFJQ 2045
  • WiFi Chips: 2x Mediatek ARM MT7615N 2105BFSL ACMSAK1P
  • RAM: 1GB DDR3 (Winbond W631GG6KB12J 60218L100ZZ2 110PUA TWN)
  • CPU: Mediatek MT7621AT


Each wifi chip is in its own band.
Do

iw list | tee -a /tmp/wifi_info.txt

Then transfer it to your PC and use like notrepad++ to locate channel maps.

                Frequencies:
                        * 5180.0 MHz [36] (23.0 dBm)
                        * 5200.0 MHz [40] (23.0 dBm)
                        * 5220.0 MHz [44] (23.0 dBm)
                        * 5240.0 MHz [48] (23.0 dBm)
                        * 5260.0 MHz [52] (20.0 dBm) (radar detection)
                        * 5280.0 MHz [56] (20.0 dBm) (radar detection)
                        * 5300.0 MHz [60] (20.0 dBm) (radar detection)
                        * 5320.0 MHz [64] (20.0 dBm) (radar detection)
                        * 5500.0 MHz [100] (26.0 dBm) (radar detection)
                        * 5520.0 MHz [104] (26.0 dBm) (radar detection)
                        * 5540.0 MHz [108] (26.0 dBm) (radar detection)
                        * 5560.0 MHz [112] (26.0 dBm) (radar detection)
                        * 5580.0 MHz [116] (26.0 dBm) (radar detection)
                        * 5600.0 MHz [120] (26.0 dBm) (radar detection)
                        * 5620.0 MHz [124] (26.0 dBm) (radar detection)
                        * 5640.0 MHz [128] (26.0 dBm) (radar detection)
                        * 5660.0 MHz [132] (26.0 dBm) (radar detection)
                        * 5680.0 MHz [136] (26.0 dBm) (radar detection)
                        * 5700.0 MHz [140] (26.0 dBm) (radar detection)
                        * 5720.0 MHz [144] (13.0 dBm) (radar detection)
                        * 5745.0 MHz [149] (13.0 dBm)
                        * 5765.0 MHz [153] (13.0 dBm)
                        * 5785.0 MHz [157] (13.0 dBm)
                        * 5805.0 MHz [161] (13.0 dBm)
                        * 5825.0 MHz [165] (13.0 dBm)
                        * 5845.0 MHz [169] (13.0 dBm)
                        * 5865.0 MHz [173] (13.0 dBm)
                        * 5885.0 MHz [177] (disabled)
                Frequencies:
                        * 2412.0 MHz [1] (20.0 dBm)
                        * 2417.0 MHz [2] (20.0 dBm)
                        * 2422.0 MHz [3] (20.0 dBm)
                        * 2427.0 MHz [4] (20.0 dBm)
                        * 2432.0 MHz [5] (20.0 dBm)
                        * 2437.0 MHz [6] (20.0 dBm)
                        * 2442.0 MHz [7] (20.0 dBm)
                        * 2447.0 MHz [8] (20.0 dBm)
                        * 2452.0 MHz [9] (20.0 dBm)
                        * 2457.0 MHz [10] (20.0 dBm)
                        * 2462.0 MHz [11] (20.0 dBm)
                        * 2467.0 MHz [12] (20.0 dBm)
                        * 2472.0 MHz [13] (20.0 dBm)
                        * 2484.0 MHz [14] (disabled)

(Thats Belgium, Should be same down north)

no i dont think that is it my board have 2 mt7615n chips
almost the same as shown in this topic: Need help adding support for the bt wifi disc - For Developers - OpenWrt Forum except i have 1gb of Ram

and this device [OpenWrt Wiki] D-Link DIR-878 A1 except i have 1gb ram and only 1 gbs ethernet port

Please check in place. Picture with 2 kind of 5GHz radios seems wrong.

i have also 2 wlan chips on the pcb i think 1 is for the mesh and the other for the wifi?

Does it detect good powers ie if it got correct calibration data from system partitions?

Looks like the firmware you have used isn't actually compatible. post the bootlog - I expect we will see firmware load failures due to incorrect DTS.

You can get the bootlog from luci or via dmesg command in an ssh session

1 Like

Kernellog:

[    0.000000] Linux version 5.15.137 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 12.3.0 r23630-842932a63d) 12.3.0, GNU ld (GNU Binutils) 2.40.0) #0 SMP Tue Nov 14 13:38:11 2023
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is Arcadyan WE420223-99
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] percpu: Embedded 11 pages/cpu s14736 r8192 d22128 u45056
[    0.000000] pcpu-alloc: s14736 r8192 d22128 u45056 alloc=11*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] Kernel command line: console=ttyS0,57600 ubi.mtd=5 root=/dev/ubiblock0_0 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Writing ErrCtl register=00018100
[    0.000000] Readback ErrCtl register=00018100
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 119296K/131072K available (7300K kernel code, 624K rwdata, 880K rodata, 1232K init, 226K bss, 11776K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] 	Tracing variant of Tasks RCU enabled.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000004] sched_clock: 64 bits at 880MHz, resolution 1ns, wraps every 4398046511103ns
[    0.016022] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.088328] pid_max: default: 32768 minimum: 301
[    0.098276] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.112693] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.131880] rcu: Hierarchical SRCU implementation.
[    0.142105] smp: Bringing up secondary CPUs ...
[    0.151882] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.151910] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.151925] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.151969] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.211634] Synchronize counters for CPU 1: done.
[    0.273856] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.273880] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.273891] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.273919] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.332828] Synchronize counters for CPU 2: done.
[    0.393222] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.393243] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.393255] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.393286] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.452403] Synchronize counters for CPU 3: done.
[    0.512000] smp: Brought up 1 node, 4 CPUs
[    0.525374] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.544869] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.558772] pinctrl core: initialized pinctrl subsystem
[    0.570690] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.583197] thermal_sys: Registered thermal governor 'step_wise'
[    0.585894] rt2880-pinmux pinctrl: there is not valid maps for state default
[    0.615004] FPU Affinity set after 11720 emulations
[    0.627925] clocksource: Switched to clocksource GIC
[    0.639272] NET: Registered PF_INET protocol family
[    0.649051] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.664297] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes, linear)
[    0.680846] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.696194] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.711399] TCP bind hash table entries: 1024 (order: 1, 8192 bytes, linear)
[    0.725395] TCP: Hash tables configured (established 1024 bind 1024)
[    0.738174] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.751073] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.765252] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.776473] PCI: CLS 0 bytes, default 32
[    0.786913] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.805010] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.816517] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.837372] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.855877] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.867298] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.878733] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.890239] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[    0.903501] mt7621-pci 1e140000.pcie:   No bus range found for /pcie@1e140000, using [bus 00-ff]
[    0.920971] mt7621-pci 1e140000.pcie:      MEM 0x0060000000..0x006fffffff -> 0x0060000000
[    0.937185] mt7621-pci 1e140000.pcie:       IO 0x001e160000..0x001e16ffff -> 0x0000000000
[    1.307994] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    1.321764] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    1.331426] mt7621-pci 1e140000.pcie: PCIE1 enabled
[    1.341125] PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    1.355262] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    1.367780] pci_bus 0000:00: root bus resource [bus 00-ff]
[    1.378661] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.392307] pci_bus 0000:00: root bus resource [io  0x0000-0xffff]
[    1.404619] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    1.416515] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.428951] pci 0000:00:00.0: reg 0x14: [mem 0x60400000-0x6040ffff]
[    1.441453] pci 0000:00:00.0: supports D1
[    1.449332] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.461527] pci 0000:00:01.0: [0e8d:0801] type 01 class 0x060400
[    1.473443] pci 0000:00:01.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.485831] pci 0000:00:01.0: reg 0x14: [mem 0x60410000-0x6041ffff]
[    1.498344] pci 0000:00:01.0: supports D1
[    1.506189] pci 0000:00:01.0: PME# supported from D0 D1 D3hot
[    1.519785] pci 0000:01:00.0: [14c3:7615] type 00 class 0x000280
[    1.531685] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    1.545272] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.576134] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    1.586439] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.598511] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.611990] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x601fffff pref]
[    1.626335] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.639771] pci 0000:02:00.0: [14c3:7615] type 00 class 0x000280
[    1.651649] pci 0000:02:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    1.665236] pci 0000:02:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:01.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.696117] pci 0000:00:01.0: PCI bridge to [bus 02-ff]
[    1.706433] pci 0000:00:01.0:   bridge window [io  0x0000-0x0fff]
[    1.718496] pci 0000:00:01.0:   bridge window [mem 0x60200000-0x602fffff]
[    1.731974] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff pref]
[    1.746319] pci_bus 0000:02: busn_res: [bus 02-ff] end is updated to 02
[    1.759502] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    1.772580] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.786406] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    1.799535] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.813371] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    1.826849] pci 0000:00:00.0: BAR 9: assigned [mem 0x60100000-0x601fffff pref]
[    1.841184] pci 0000:00:01.0: BAR 8: assigned [mem 0x60200000-0x602fffff]
[    1.854664] pci 0000:00:01.0: BAR 9: assigned [mem 0x60300000-0x603fffff pref]
[    1.869004] pci 0000:00:00.0: BAR 1: assigned [mem 0x60400000-0x6040ffff]
[    1.882495] pci 0000:00:01.0: BAR 1: assigned [mem 0x60410000-0x6041ffff]
[    1.895964] pci 0000:00:00.0: BAR 7: assigned [io  0x0000-0x0fff]
[    1.908057] pci 0000:00:01.0: BAR 7: assigned [io  0x1000-0x1fff]
[    1.920162] pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x600fffff 64bit]
[    1.934684] pci 0000:00:00.0: PCI bridge to [bus 01]
[    1.944524] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.956614] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.970090] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x601fffff pref]
[    1.984441] pci 0000:02:00.0: BAR 0: assigned [mem 0x60200000-0x602fffff 64bit]
[    1.998966] pci 0000:00:01.0: PCI bridge to [bus 02]
[    2.008798] pci 0000:00:01.0:   bridge window [io  0x1000-0x1fff]
[    2.020895] pci 0000:00:01.0:   bridge window [mem 0x60200000-0x602fffff]
[    2.034374] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff pref]
[    2.051303] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    2.068900] printk: console [ttyS0] disabled
[    2.077371] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 19, base_baud = 3125000) is a 16550A
[    2.095328] printk: console [ttyS0] enabled
[    2.111851] printk: bootconsole [early0] disabled
[    2.134166] spi-mt7621 1e000b00.spi: sys_freq: 220000000
[    2.146303] spi-nor spi0.0: w25q256 (32768 Kbytes)
[    2.156022] 12 fixed-partitions partitions found on MTD device spi0.0
[    2.168871] Creating 12 MTD partitions on "spi0.0":
[    2.178590] 0x000000000000-0x000002000000 : "ALL"
[    2.189090] 0x000000000000-0x000000030000 : "Bootloader"
[    2.200869] 0x000000030000-0x000000040000 : "Config"
[    2.211847] 0x000000040000-0x000000050000 : "Factory"
[    2.222925] 0x000000050000-0x000001fb0000 : "kernel"
[    2.233826] 0x000000490000-0x000001fb0000 : "rootfs"
[    2.244716] mtd: setting mtd5 (rootfs) as root device
[    2.254923] mtdsplit: no squashfs found in "rootfs"
[    2.264698] 0x000001000000-0x000001fb0000 : "Kernel2"
[    2.275882] 0x000001440000-0x000001fb0000 : "RootFS2"
[    2.287006] 0x000001fb0000-0x000001fc0000 : "glbcfg"
[    2.298216] 0x000001fc0000-0x000001fd0000 : "board_data"
[    2.310073] 0x000001fd0000-0x000001fe0000 : "glbcfg2"
[    2.321251] 0x000001fe0000-0x000001ff0000 : "board_data2"
[    2.469255] mtk_soc_eth 1e100000.ethernet: generated random MAC address ae:99:2d:f2:08:f6
[    2.485754] mtk_soc_eth 1e100000.ethernet: generated random MAC address c2:de:68:47:42:fa
[    2.503451] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.523815] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 20
[    2.543669] mtk_soc_eth 1e100000.ethernet swp0: mediatek frame engine at 0xbe100000, irq 20
[    2.562372] i2c_dev: i2c /dev entries driver
[    2.574046] NET: Registered PF_INET6 protocol family
[    2.586628] Segment Routing with IPv6
[    2.594085] In-situ OAM (IOAM) with IPv6
[    2.602061] NET: Registered PF_PACKET protocol family
[    2.612292] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    2.638799] 8021q: 802.1Q VLAN Support v1.8
[    2.653128] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    2.682501] mt7530-mdio mdio-bus:1f: configuring for fixed/rgmii link mode
[    2.697083] mt7530-mdio mdio-bus:1f: Link is Up - 1Gbps/Full - flow control rx/tx
[    2.699118] mt7530-mdio mdio-bus:1f swp1 (uninitialized): PHY [mt7530-0:01] driver [MediaTek MT7530 PHY] (irq=22)
[    2.735853] DSA: tree 0 setup
[    2.742837] ubi0: attaching mtd5
[    2.784908] ubi0: scanning is finished
[    2.805071] ubi0: attached mtd5 (name "rootfs", size 27 MiB)
[    2.816426] ubi0: PEB size: 65536 bytes (64 KiB), LEB size: 65408 bytes
[    2.829629] ubi0: min./max. I/O unit sizes: 1/256, sub-page size 1
[    2.841941] ubi0: VID header offset: 64 (aligned 64), data offset: 128
[    2.854945] ubi0: good PEBs: 434, bad PEBs: 0, corrupted PEBs: 0
[    2.866910] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
[    2.881300] ubi0: max/mean erase counter: 2/0, WL threshold: 4096, image sequence number: 1699969091
[    2.899495] ubi0: available PEBs: 0, total reserved PEBs: 434, PEBs reserved for bad PEB handling: 0
[    2.917718] ubi0: background thread "ubi_bgt0d" started, PID 328
[    2.919622] block ubiblock0_0: created from ubi0:0(rootfs)
[    2.948478] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    2.966715] Freeing unused kernel image (initmem) memory: 1232K
[    2.978575] This architecture does not have kernel memory protection.
[    2.991427] Run /sbin/init as init process
[    2.999595]   with arguments:
[    2.999604]     /sbin/init
[    2.999610]   with environment:
[    2.999615]     HOME=/
[    2.999620]     TERM=linux
[    3.397987] init: Console is alive
[    3.405237] init: - watchdog -
[    4.018077] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.076367] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.093103] init: - preinit -
[    4.821170] random: jshn: uninitialized urandom read (4 bytes read)
[    4.941522] random: jshn: uninitialized urandom read (4 bytes read)
[    5.057613] random: jshn: uninitialized urandom read (4 bytes read)
[    5.348067] mtk_soc_eth 1e100000.ethernet swp0: PHY [mdio-bus:00] driver [MediaTek MT7530 PHY] (irq=POLL)
[    5.374519] mtk_soc_eth 1e100000.ethernet swp0: configuring for phy/rgmii link mode
[    7.554984] UBIFS (ubi0:1): Mounting in unauthenticated mode
[    7.566628] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 468
[    7.599438] UBIFS (ubi0:1): recovery needed
[    8.037973] random: crng init done
[    8.038317] UBIFS (ubi0:1): recovery completed
[    8.044778] random: 7 urandom warning(s) missed due to ratelimiting
[    8.053791] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[    8.081708] UBIFS (ubi0:1): LEB size: 65408 bytes (63 KiB), min./max. I/O unit sizes: 8 bytes/256 bytes
[    8.100458] UBIFS (ubi0:1): FS size: 23285248 bytes (22 MiB, 356 LEBs), max 366 LEBs, journal size 1177344 bytes (1 MiB, 18 LEBs)
[    8.123697] UBIFS (ubi0:1): reserved for root: 1099819 bytes (1074 KiB)
[    8.136887] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID C30ACCC6-CC9F-44B3-9989-842F396A806D, small LPT model
[    8.177730] mount_root: switching to ubifs overlay
[    8.202353] urandom-seed: Seeding with /etc/urandom.seed
[    8.311142] procd: - early -
[    8.317109] procd: - watchdog -
[    8.927360] procd: - watchdog -
[    8.934758] procd: - ubus -
[    9.007099] procd: - init -
[    9.548284] kmodloader: loading kernel modules from /etc/modules.d/*
[    9.777002] Loading modules backported from Linux version v6.1.24-0-g0102425ac76b
[    9.792047] Backport generated by backports.git v5.15.92-1-44-gd6ea70fafd36
[   10.008573] pci 0000:00:00.0: enabling device (0006 -> 0007)
[   10.019914] mt7615e 0000:01:00.0: enabling device (0000 -> 0002)
[   10.033567] mt7615e 0000:01:00.0: Invalid MAC address, using random address 86:db:af:32:91:8e
[   10.056199] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   10.056268] ieee80211 phy0: copying sband (band 1) due to VHT EXT NSS BW flag
[   10.061087] pci 0000:00:01.0: enabling device (0006 -> 0007)
[   10.072464] mt7615e 0000:02:00.0: enabling device (0000 -> 0002)
[   10.086070] mt7615e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20180518100604a
[   10.086070] 
[   10.099830] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   10.105175] ieee80211 phy1: copying sband (band 1) due to VHT EXT NSS BW flag
[   10.135724] mt7615e 0000:02:00.0: HW/SW Version: 0x8a108a10, Build Time: 20180518100604a
[   10.135724] 
[   10.185431] PPP generic driver version 2.4.2
[   10.197602] NET: Registered PF_PPPOX protocol family
[   10.219661] kmodloader: done loading kernel modules from /etc/modules.d/*
[   10.373370] mt7615e 0000:01:00.0: N9 Firmware Version: _reserved_, Build Time: 20200814163649
[   10.373430] mt7615e 0000:02:00.0: N9 Firmware Version: _reserved_, Build Time: 20200814163649
[   10.586461] mt7615e 0000:02:00.0: CR4 Firmware Version: _reserved_, Build Time: 20190415154149
[   10.586497] mt7615e 0000:01:00.0: CR4 Firmware Version: _reserved_, Build Time: 20190415154149
[   11.094550] urngd: v1.0.2 started.
[   18.425774] mtk_soc_eth 1e100000.ethernet swp0: PHY [mdio-bus:00] driver [MediaTek MT7530 PHY] (irq=POLL)
[   18.456424] mtk_soc_eth 1e100000.ethernet swp0: configuring for phy/rgmii link mode
[   18.474606] br-lan: port 1(swp0) entered blocking state
[   18.485248] br-lan: port 1(swp0) entered disabled state
[   18.496359] device swp0 entered promiscuous mode
[   18.553508] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   18.574525] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   18.597005] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   18.611021] device eth0 entered promiscuous mode
[   18.620823] mt7530-mdio mdio-bus:1f swp1: configuring for phy/gmii link mode
[   18.650103] br-lan: port 2(swp1) entered blocking state
[   18.660714] br-lan: port 2(swp1) entered disabled state
[   18.674491] device swp1 entered promiscuous mode
[   21.568185] mtk_soc_eth 1e100000.ethernet swp0: Link is Up - 1Gbps/Full - flow control rx/tx
[   21.757379] br-lan: port 3(phy0-ap0) entered blocking state
[   21.768546] br-lan: port 3(phy0-ap0) entered disabled state
[   21.780300] device phy0-ap0 entered promiscuous mode
[   21.790638] br-lan: port 3(phy0-ap0) entered blocking state
[   21.801817] br-lan: port 3(phy0-ap0) entered forwarding state
[   21.813948] br-lan: port 3(phy0-ap0) entered disabled state
[   21.826336] br-lan: port 1(swp0) entered blocking state
[   21.836824] br-lan: port 1(swp0) entered forwarding state
[   21.848553] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   21.862604] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan.1: link becomes ready
[   21.884829] device phy0-ap0 left promiscuous mode
[   21.894568] br-lan: port 3(phy0-ap0) entered disabled state
[   21.962277] br-lan: port 3(phy0-ap0) entered blocking state
[   21.973514] br-lan: port 3(phy0-ap0) entered disabled state
[   21.985437] device phy0-ap0 entered promiscuous mode
[   23.664932] br-lan: port 4(phy1-ap0) entered blocking state
[   23.676167] br-lan: port 4(phy1-ap0) entered disabled state
[   23.687852] device phy1-ap0 entered promiscuous mode
[   26.181460] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-ap0: link becomes ready
[   26.195018] br-lan: port 4(phy1-ap0) entered blocking state
[   26.206199] br-lan: port 4(phy1-ap0) entered forwarding state
[   31.940173] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[   31.953885] br-lan: port 3(phy0-ap0) entered blocking state
[   31.965111] br-lan: port 3(phy0-ap0) entered forwarding state

There's the 'smoking gun' - the mtk kernel modules aren't able to load config data while booting. You will need to review the correct partition layout from the factory firmware, edit the openwrt dts to match and recompile.

There also looks to be only 2 mt7615e's devices being brought up, where you would expect to have 3, 1x 2.4ghz and the 2x 5ghz interfaces. Your dts will need to correctly specify all of them for the kernel to attempt to enabled them.

1 Like

Thank you for your quick reply,

Is it posible tonread out the original dts layout trough spci and a raspberry connected directly to the flashchip?

if dtc is installed you can unpacked like

dtc -I fs -O dts /sys/firmware/devicetree/base

if no dtc , try to install it

opkg install dtc

or backup contents of /sys/firmware/devicetree/base, and transfer it to a linux machine and run dtc from a terminal there.

thank you,

when i do this i get a lot of information also of my raspberry pi
but i think we need this:

flash@0 {
                                spi-max-frequency = <0x1312d00>;
                                compatible = "jedec,spi-nor";
                                reg = <0x00>;

                                partitions {
                                        #address-cells = <0x01>;
                                        #size-cells = <0x01>;
                                        compatible = "fixed-partitions";

                                        partition@1fc0000 {
                                                label = "board_data";
                                                reg = <0x1fc0000 0x10000>;
                                        };

                                        partition@1440000 {
                                                label = "RootFS2";
                                                reg = <0x1440000 0xb70000>;
                                        };

                                        partition@490000 {
                                                label = "rootfs";
                                                reg = <0x490000 0x1b20000>;
                                        };

                                        partition@30000 {
                                                label = "Config";
                                                reg = <0x30000 0x10000>;
                                        };

                                        partition@1fd0000 {
                                                label = "glbcfg2";
                                                reg = <0x1fd0000 0x10000>;
                                        };

                                        partition@0 {
                                                label = "ALL";
                                                reg = <0x00 0x2000000>;
                                        };

                                        partition@40000 {
                                                label = "Factory";
                                                reg = <0x40000 0x10000>;
                                        };

                                        partition@1fe0000 {
                                                label = "board_data2";
                                                reg = <0x1fe0000 0x10000>;
                                        };

                                        partition@1000000 {
                                                label = "Kernel2";
                                                reg = <0x1000000 0xfb0000>;
                                        };

                                        partition@50000 {
                                                label = "kernel";
                                                reg = <0x50000 0x1f60000>;
                                        };

                                        partition@1fb0000 {
                                                label = "glbcfg";
                                                reg = <0x1fb0000 0x10000>;
                                        };

                                        partition@1 {
                                                label = "Bootloader";
                                                reg = <0x00 0x30000>;
                                        };
                                };
                        };

                        spidev@1 {
                                #address-cells = <0x01>;
                                #size-cells = <0x00>;
                                spi-max-frequency = <0x7735940>;
                                compatible = "spidev";
                                reg = <0x01>;
                                phandle = <0x7c>;
                        };
                };

1 Like

you cannot use it directly, you'll have to pick out the useful information and translate it into your dts as needed. Fill in the blanks for lack of better words

thanks i dont understand how to do that
can i adjust an existing firmware file like the one of de arcadyan? en where do i start?

i have check the dts of accespoint and the one from de arcadyan and they are the same sizes?

best place to start would be the some docs
https://openwrt.org/docs/guide-developer/hw.hacking.first.steps
https://openwrt.org/docs/guide-developer/add.new.device

they're outdated, but enough to give you the generally idea of the work flow.

next find a supported device most similar to yours and go thru the sources, use or edit the dts to work for your device with the information gained in from your unpacked dts.

i have got wifi working!
i have found a workaround on the web:

opkg update

opkg install kmod-mt76-connac

opkg install kmod-mt7615-common

opkg install kmod-mt7615-firmware

opkg install kmod-mt7615e

uci set wireless.radio0.disabled=0

uci set wireless.radio1.disabled=0

service network restart

cat << EOF > /etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11g'

option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'

option htmode 'HT20'

option disabled '1'


config wifi-iface 'default_radio0'

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'openwrt'

option encryption 'psk2'

option key 'password'


config wifi-device 'radio1'

option type 'mac80211'

option channel '36'

option hwmode '11a'

option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'

option htmode 'VHT80'

option disabled '1'


config wifi-iface 'default_radio1'

option device 'radio1'

option network 'lan'

option mode 'ap'

option ssid 'openwrt-5g'

option encryption 'psk2'

option key 'password'

EOF

wifi reload

i can create and connect to a 2,4 and 5 ghz band.

unfortunatly after an reboot my wireless config is back to stock.

that's strange, perhaps a uci commit before wifi reload...

...
EOF

uci commit 
wifi reload

you could also use a uci defaults script to set these values on boot, a quick and dirty solution, which may be sufficient for testing it for the time being ? it comes down to the time you are willing to invest and your intentions ie adding official support for the device, or personal use etc.

as an example you could add the following file and contents below

/etc/uci-defaults/99_set_wifi

#!/bin/sh


uci set wireless.radio0.disabled=0

uci set wireless.radio1.disabled=0

service network restart

cat << EOF > /etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'

option channel '11'

option hwmode '11g'

option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'

option htmode 'HT20'

option disabled '1'


config wifi-iface 'default_radio0'

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'openwrt'

option encryption 'psk2'

option key 'password'


config wifi-device 'radio1'

option type 'mac80211'

option channel '36'

option hwmode '11a'

option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'

option htmode 'VHT80'

option disabled '1'


config wifi-iface 'default_radio1'

option device 'radio1'

option network 'lan'

option mode 'ap'

option ssid 'openwrt-5g'

option encryption 'psk2'

option key 'password'

EOF

uci commit
wifi reload

## return 1 so script runs on each boot

return 1

from a terminal, make the script executable and reboot

chmod +x /etc/uci-defaults/99_set_wifi
reboot

this is not a solution, any changes to your wireless settings would need to be reflected in the script. But it may allow you to test before deciding to put in the effort to add the device officially.

How did you flash the Experia Wifi image on the Superwifi? With the webinterface or by writing directly to the flash chip?

i have writen it directly to the flashchip

I'll see if I can get my hands on a Superwifi 1 for cheap, would be nice to give these devices a second life with OpenWrt. Also a Superwifi 2, if only for device discovery.