[Help] Cannot set VLAN on RT-53U

Hello there,

It may be a stupid question, but i can't enable VLANs on my RT-53U.
For a small project, i got this one and migrated it to OpenWRT. I'm myself very new to OpenWRT that's why the answer may be ultra obvious.

I have a small lab with a few VLANs, all trunk-ed to the Port 1 of my RT-53U
It support VLANs according to the doc : https://openwrt.org/toh/asus/rt-ax53u

But, if i enable the VLANs with a really simple configuration like this one :
(cannot post images sorry)

  • Port 1 : VLAN130 Tagged
  • Port 2 : Doesn't participate
  • Port 3 : Doesn't participate

The trunk is on LAN1, my admin computer is on LAN3
So my admin computer shouldn't have any issues joining the router after the change as the port doesn't participate to any VLANs

I get the message after the 90s timeout that the router cannot be join and that i may force or dismiss the changes... (so i dismiss them, and here i am)
I've tried many things (Everyone in VLAN1, only 1 port, everyone untagged etc...) each times : it ends with the security message that the router cannot be join and so as rollback the changes

Am i doing something wrong ? should i force the change ?
-> The goal is to have a 4 VLANs configuration on LAN1 and then route them to Internet. Everything is set up on the switch, my main issue here is "it seems" enabling VLANs make me lose the router


Did you try to simply login to the router within the 90s time window or is login not possible?

This same message appears if you changed the routers IP address and you have to login at the new address.

Is this the only VLAN? If yes, you need a second untagged VLAN on the admin port where you enable local access. Then you need to change the LAN interface to be on the newly created VLAN, otherwise you won't have access.

As an alternative (might be even easier for now), you can remove lan3 from the bridge and use that as the underlying device for LAN.

In any case, modifying the LAN interface is the crucial step.

I suggest reading the DSA Mini Tutorial:

Hello there,

@egc : i've tried... and "nope", the router is really unreachable so it's not a false alarm from the GUI

@andyboeh : Good idea to remove the LAN3 from the bridge. It did the work and allowed me to understand the issue

Lack of knowledge on OpenWRT
The only thing missing was, after setting up the VLANs, set the br-lan to not use the bridge anymore but the subinterface just created for what will be become the default VLAN (so br-lan.1 in my case)
After that, it works

I was expecting the br-lan to keep the IP of the gateway for the native VLAN by default... but it needs to be done explicitly
And it requires to have a "backup" link to the router (@andyboeh tips) because the subinterfaces seems to be created only after the changes are applied. So the second configuration cannot be done at the same time

Thanks for the help, it works know

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

IMHO that's one downside of the switch to DSA, it used to be the way you were expecting it when we had swconfig.

If you are a bit more experienced, it can be done in one go - or on the command line, if you're sure what you're doing.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.