Help Archer C50 v1 Bricked

Hi

@DjiPi Thanks for the help, I will install and use very carefully, I will re-report the result, I use it and I will study and learn more about this free firmware world.

Hi,

How I correctly place the UART connector on the Archer C50, I have to jam Resistor R600 and R601 are missing. I asked because I soldered the connector but I did not get it on Putty.

Thank

@DjiPi thank you for u help , i Have luck in restory stok MAC, editing original bios dump file, now all Mac is a same original in TRE router label, now only stok WiFi password Need be correct..

I try soldering uart serial but dont work i think Need jump MB and install back Lede, and i will report my progress.

My apologizes for my poor inglish.

@gu3d3s, thank you for the topic. I've got the same problem. Could you tell which programmer have you bought?

Hello,
I bought a similar one to the link, I edited the Hexdacimal address where the factory MAC address is record, and the wifi network names and factory passwords, according to the label pasted on the back of the router

Thanks for the link! Was it easy to remove the chip or not?

with the right tools is not the most difficult, but there is a cable that allows programming without removing the chip

Wow, that sounds nice. If that is not hard could you point me to that cable? Thank you very much!

I think this is perfect for you....

https://pt.aliexpress.com/item/Free-Shipping-EZP2010-high-speed-USB-SPI-Programmer-support24-25-93-EEPROM-25-flash-bios-chip/1999368336.html

Hi, i have same error on my archer c50. Led orange light and off. Please send tutorial to program with SPI and how you can do this ? Thanks a lot.

Hi, perhaps you could give me any information about SPI. Which chipset should i reprogram ?
Thanks a lot.

tengo un arher c50 eu v3 le trate de instalar LEDE 18 y me equivoque de bin, se congelo, después intente entrar por usb ttl y escribimos algunos comandos como eracer entonces no se pudo, ahora logre sacarlo con una grabadora de eeprom y la compilación 5 de heinz y salió, pero en el proceso anterior creo haber hecho algo mal pues mi router no emite señal wifi, cuando entro al sistema de su interfaz la wifi no identifica la dirección MAC, creo que borre la partición esa, como se puede restaurar?

I have an arher c50 Eu v3 treat him to install LEDE 18 and make a mistake of bin, himself I freeze, after try to go in for USB ttl and we wrote some commands like eracer then one could not, now achieve to take it out with a tape recorder of EEPROM and the compilation 5 of Heinz and it went out, but in the previous process I consider myself to have done something badly because my router does not emit signal wifi, when do I enter your interface's system the wifi does not identify the MAC address, do I believe that he erase that partition, as it can be restored?

Any way of reestablishing the MAC addresses that authenticate GHz and 5ghz to the wifi in 2,4, for in an attempt of putting LEDE and turning of the ARCHER c50 to the original firmware is (EU) v3, signal does not give wifi, and when I see in her web, there is no MAC address in no one of the 2 bands wireeles.Any way of reestablishing the MAC addresses that authenticate GHz and 5ghz to the wifi in 2,4, for in an attempt of putting LEDE and turning of the ARCHER c50 to the original firmware is (EU) v3, signal does not give wifi, and when I see in her web, there is no MAC address in no one of the 2 bands wireeles.

I bricked my Archer C50 v1 when I tried to flash "openwrt-18.06.0-ramips-mt7620-ArcherC50v1-squashfs-factory-eu.bin" via its web interface. Then I tried to restore it via the above mentioned TFTP method. The C50 read the requested file off the TFTP server fine but something went wrong as the result was bricked unit (orange blink - same as shown by gu3d3s above). Later I found out that this was probably because I did strip the U-Boot section from the file.

Although my knowledge is limited on the matter (obviously as everything I did went wrong so far…) I ordered a CH341A Mini Programmer (Black Edition) with a wire clip to access the flash chip on the PCB of the C50. 1st off I backed up the content of the flash chip (even though the unit did not boot with its content anymore).

Then I tried to flash the file which was uploaded by Heinz here - just to see if I can get the unit back to life. And: It worked!

As expected, the device specific router data (mac address at 0x007DF100 and wireless pin at 0x007DF200) was of Heinz’s unit. Therefore, I examined the flash backup of my bricked one. I was able to find the mac address and the pin in there (as written on the label of the unit). So, it seemed that this data was still intact. As there is also unit specific data stored in that area (such as radio data, etc.) I decided to just replace the data of Heinz flash file as of position 0x007C0000 (mtd3 to mtd6 of Heinz files) with the data of my flash backup.

First, I flashed the modified file with the CH341A to my C50. Once reset it to factory defaults, mac address, pin etc. was back to the initial state as recorded on the unit’s label. Whoohoo!!!

Not I will resume where I started: Trying to get openWRT on the unit, so I can configure it as dump AP (no router) with a guest network (as this seems not possible with the original firmware).

Thanks, guys, for the information provided here! On my own I was not able to do that!

Due to the instructions posted by TheRoot here I was finally able to install OpenWRT:

Bild%201015

What a great forum!

Awesome!!!
Nice for your reply...
It help to recovery more bricked routers!!!
I save the Heinz´s dumpe here for this work...
Here in Brazil, I recovery many bricked routers and any sugestions, are always welcome!!

https://www.youtube.com/watch?v=LLgRpnjwutQ

I have the same problem with my TP LINK C50 V1 Router, got the wrong firmware, via Tfpt Recovery, and now it's completely dead, it looks like this link. Please help me, let me know in detail. I have USB to UART TTL. can anyone tell me how to set up RX TX and GND and what's needed. Thank you.

I successfully recovered my bricked Archer C50 using the method described in this thread. Thanks a lot for collecting all the information in one spot. Special thanks to @Heinz and @EFO.

As it is recommended to use mtd3 to mtd6 of the bricked router, but there was no readily available information how to use parts of Heinz's image and mtd3-6 of my own image, I wanted to document how I solved this problem. You'll either need a Linux system to exeucte or use Windows Subsystem for Linux. I used the latter, as I use Windows to program the EEPROM, and it worked like a charm.

Instructions:

  • read the EEPROM content and save it to a file called dump.bin (I used a CH341A and a SOIC8 test clip to read/write to the EEPROM)
  • download Heinz's dump (see Help Archer C50 v1 Bricked)
  • use dd to extract the part to keep from Heinz's dump (mtd0-2) using the following command dd if=heinz.bin of=part1.bin bs=1 count=$((0x007C0000)) (rename file Dump Archer C50v1.bin from Heinz's archive to heinz.img)
  • use dd to extract mtd3-6 from your own dump using the following command dd if=dump.bin of=part2.bin bs=1 count=$((0x00800000-0x007C0000)) skip=$((0x007C0000))
  • use cat to concatenate the 2 parts: cat part1.bin part2.bin > write.bin
  • write write.bin to the EEPROM

Afterwards your Archer C50 should be de-bricked and boot up with the regular firmware. You can now follow the instructions listed here to install OpenWRT: LEDE on TP-Link Archer C50, but the install Instructions is in polish (danghuy1994's recipe worked well for me).

Hi, i hope u found a solution for your problem, i have the same, im trying to connect my archer c50 v1 to my raspberry in serial connection, but i dont know what im doing wrong, minicom doesnt show anything.
If anyone could help me...
Sorry for my english, isnt my primary language

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.