Help Archer C50 v1 Bricked

Hello,

I need help to try save my TP-LINK Archer C50 - V1, I installed the LEDE FW but it did not work properly, did not give me both WIFI, and neither authenticated the PPPoE, tried to return to the original FW but it did not work, my router no longer And recognized by the LAN and when connecting the internet LED lights up red and off.

I saw that it would be possible to repair the same via serial port, using a serial TTL USB converter, or would have to remove the CHIP from FW to be able to record out on an eprom recorder.

My question is: which of the methods is the best for my case, and which equipment and programs should I use?

I use Mac but if I do not have programs for it I can have a PC windows, please all help and welcome

Guedes

Have you tried TFTP method ?

Yes, but don't work .

Hi guys,

I try record new Flash FW w SPI USB but no have luck, please see this video and help me !

Thanks for all, really need put my router back to life/

Unless the TFTP is not working at all, here is my suggestion for you:

I wrote a resume for two procedures reported as working from two different users; may I suggest that you follow the "using sysupgrade", the first step only?

What I propose is to use the TFTP method again (with instructions provided) but using this firmware instead, a stripped one. Usually things work better when the U-Boot partition is removed from the firmware binary for TFTP.

This should get you back to stock firmware if everything works fine.

1 Like

@gu3d3s You have broken or missing bootloader on Your C50.

Here is dump from my C50v1:
https://mega.nz/#!qV42nBbR!fOUhrAPytF6NigRkMV8Z1oZzySHjlI1CUCJ0eCRqZ5I
ps. on mtd4 partition you have mac address in offset 0xf100, on mtd6 is radio calibration data, is better to use your orginal data.

hi,

Thanks for the help and the file, but, by the size of file I think the copy of the correct LEDE ?, I will write directly on the new chip and re-solder on the board.

That I will report a result :slight_smile:

Hi,

I tried via TFTP, but at one point the router stopped giving NETWORK and it was only with this led that goes on and off, what was indicated and to RECORD a FW via a USB SPI to write directly on the chip

I will post results of procedure.

Guedes

Hi guys,
I think I may have the same problem as you.
I used the firmware update page on the router system to update it to the openwrt firmware.
It didn't work, it couldn't conect to the PPPoE. After this, I used the open wrt firmware page to flash the initial firmware(from tplink site) and it is now with only the same red light as your router.
Hope they can help us Guedes!(sou brasileiro também)

Hello Heinz,
these archives .bin, how do I use it? With the Tftp? Which one of them do I use?

Hi @fatman1, in archive is full dump from my c50v1 and dump of separate partitions.
This dump contain factory firmware.

You need SPI flash programmer to write dump to Your flash chip.

@Heinz I would like to set a warning (in the thread were I resumed two method of installation reported as successful) about going back to stock firmware.

I believe that it's required to have a stripped firmware. Are you able to confirm that to me? I'd like to help prevent further bricking. Is it the usual skip=257 bs=512 bytes?

@fatman1 ainda estou a tentar recuperar o router, ja recebi o gravador SPI, mas tive um pequeno problema na placa do archer, espero na semana resolver e passo a voce o que , e como foi feito, e caso voce tenha novidades peco que ma avise.

I am still trying to recover the router, I already received the SPI recorder, but I had a small problem on the card of the archer, I hope in the week to solve and I will give you what, and how it was done, and in case you have news, please let me know.

Grateful

Guedes

Just skip the first 512 bytes. Archer C50 will flash over bootloader too.

Thank you, I'll update my tl;dr soon to include that info.

Hi @Heinz

Friend thank you for the help, my ARCHER came back to life, I bought the SPI programmer and I used your DUMP FILE. Everything working fine, only the router MAC changed is no longer what is in the router's label, can you tell me if there is any way I can restore the MAC?

Now I will try to install the new Vs. Of LEDE FW, but I will study more on the subject, not to do my brick archer anymore :smiley:

And Thank you

1 Like

I hope you did backup chip before reflashing.

Hi Guedes, happy to see that you could fix it.
Pode me ajudar, talvez fazer um tutorial sobre como você resolveu?
caso seja mais facil, podemos conversar por outras plataformas!

@fatman1 i will help you
Procura por mim no FB Guedes Jr. Tive que fazer um reflash no chip do router mas mesmo comprando todo material valeu pelo aprendizado., o Archer esta a rodar o LEDE agora e tudo funcionando..
Entra em contato pelo FB ou gu3d3s arroba iCloud dot com

No i dont, backup stok fw. :frowning: