Habanero-dvk : flash image -error

I have problems with firmware update 07/19 to 02/21/1
Habanero DVK -C2
FW: OpenWrt-8devices v3.1 r9932-13962b7 / LuCI openwrt-19.07 branch (f138fc93)
Kernel: 4.14.113

At luci -> Backup-> Flash new firmware image:
"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform. Select 'Force upgrade' to flash the image even if the image format check fails. Use only if you are sure that the firmware is correct and meant for your device!"


  • openwrt-21.02.1-ipq40xx-generic-8dev_habanero-dvk-squashfs-sysupgrade.bin
  • openwrt-ipq40xx-generic-8dev_habanero-dvk-squashfs-sysupgrade.bin

can anyone help?

Seems like a false positive error message. Does it say the same if you try to upload the latest firmware from 8devices?

yes , I think this is the current FW, downloaded today.

OKay, but does it give you the same error when you try to upload the 8devices image?

Where can I download them ?
a download does not work there ...

Click on the link I posted earlier. It works fine for me.

Thanks very much,
With openwrt-8devices-v3.2-ipq40xx-generic-8dev_habanero-dvk-squashfs-sysupgrade.bin
it works. But it is still openwrt-19.07. a possibility to update to openwrt-21.02 does not seem to be available from 8devices yet.

With 3.2 installed, does it still complain about the error when you try to flash 21.02.1?

good question. I haven't had the idea to test it with 3.2 yet. I do tomorrow.

but still tested today. it works ! I could have come up with this idea myself. Thanks again !

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.