Got stuck on ''system running in recovery (initramfs) mode" | Totolink X5000R

I wanted to install openwrt firmware on my newly bought router. openwrt firmware link:

First of all, I downloaded the kernel file and entered my router's stock firmware and flashed it simply using the update firmware option. The flashing process was successful and I saw the new login interface to enter the openwrt firmware. After login I got a message -"System running in recovery (initramfs) mode. This mode should only be used to install to a firmware upgrade." I didn't know what to do and I was feeling nervous. So I hold the reset button for 15 seconds to reset the router. But nothing happened. So I tried to re-flash with the previously downloaded Kernel file. I saw that the file was successfully uploaded and the flash process was completed. I re-login to openwrt and got the same message.

Then I downloaded the sysupgrade file from the previous link and tried re-flashing it. Again I saw that the file was successfully uploaded and the flash process was completed. But the result was same.Nothing changed.

Then I tried reverting to the stock firmware of Totolink. I searched the router model from Totolink website and downloaded the file "V9.1.0u.6369_B20230113".

After that, I reflashed using that file by following the method in the link below:

Thus I completed the whole process but it didn't work for me.I opened a browser and entered ; the login page of the Totolink router did not open.After that I typed and entered and it opened the openwrt login page.I logged in and I was very disappointed to see the same thing. I think I'm stuck here. I don't know how to solve this problem now. Looking for help from those who are experts here or who had this problem and managed to solve it. I am new here. Please forgive me if I made any mistakes. Thank you for reading the entire article with patience.

The installation instructions on the wiki page say

Download the OpenWrt sysupgrade image as shown above
Flash using OEM web UI

Have you tried this?

or did you perhaps use the wrong image ?

1 Like

Sorry, I tried it but unfortunately flashed with kernel image the first time. I didn't realize at that time that I have to flash with sysupgrade image.Later I flashed with sysupgrade image. But that didn't work anymore.

say Hi! to serial recovery ...


What do you see if you unplug it from the socket, plug it back in, then turn the router back on. What interface comes up?

Maybe you're right. I used the wrong image. Would you like to help me with serial recovery? Since my knowledge about this is less, I don't want to make any more mistakes.

After unplugging the socket and plugging it in again, the router is turned on then I enter in the browser, the openwrt interface will appear.

you need a 3.3v USB TTL, connect it to the pins behind the power connector, on the PCB.
don't connect the 3.3v pin.

then you should be able to do the TFTP recovery described in the wiki.

The wiki back to stock instructions don't require USB TTL? looks like there's a webserver in the bootloader to recover firmware.

OP said he tried the return to stock part, so I assume it was tested, but failed...


Ah my bad. Prolly worth them trying again though. Usually its a bit fiddly getting into bootloader recovery. Can't imagine the bootloader has been overwritten!

Ok. I am ordering a 3.3v usb ttl from online . Hope to get it in 2 days. Will let you know if I have any difficulty understanding anything. Thanks bro for your guidance :blush:

Try the back to stock instructions again. Make sure you follow them exactly.

Ok brother.I will try it again and let you know the results. Thanks a lot for your valuable guidance. :blush:

1 Like

Good luck. If it doesn't work, provide information (logs/screenshots) as to which part it fails at and we can try to help you further.

Fingers crossed ...

bro I have tried again with those nstructions.It didn't work for me. I put my computer ethernet IP to
I exactly followed the rest of the instructions.