GL.iNET Flint 2 (GL-MT6000) discussions

Weird. I tried to install that version but it also error. Are you sure it's r26536-c67d5189a4?

Could you please share the sysupgrade bin? I would like to install yours so I can install mwan3 :sweat_smile:

Not sure - it just showed that build at the top of the page. Maybe it's updated to r26556 already.

same issue, i had to revert back to an older version.... had to reconfigure from scratch... no bueno

Alright so with many has confirmed, latest snapshot is considered as broken. If you use your Flint 2 as a main router, it is advised to hold back upgrade.

Thanks to @vw-owrt I have safely restore my Flint 2 to r26536-c67d5189a4. Now, what commit that might be the issue? If this is a common issue with other routers there should be many report in OpenWrt repo, yet it isn't. I suspect this commit might be the issue:


That commit no issue. It is this one but it is reverted, so next release is ok.


i only updated the previous day to try nlbwmon (crashing problems) again, guess i dodged a bad build.

1 Like

Are the issues fixed with r26557-de59fc4540? Thanks!

Just unpacked my new Flint 2 router today running firmware 4.5.8
I have one issue with a bose wifi speaker.
Everytime i stream from my mac (ethernet connected) to my bose speaker (wifi 2.4 connected) using airplay, i get 10 seconds of music and then nothing without the speaker dropping the wifi connection.
Is it a known issue with the stock firmware ?
What can i do to improve this as it is juste unusable for this use case ?

Edit : a final reboot of the router was the trick ! :slight_smile:

1 Like

I don't think so. de59fc4540 is right before the commit reverting the issue.

1 Like

r26573-bac2f1bed6 containing the fix/revert is now available in firmware selector.
I successfully downloaded and installed it.

Also used @_FailSafe's gist to download the MediaTek firmware from commit 6bc4c6e45cbba8b4cd3af6a79cfc49ad28af5be4 (firmware build time 20240507...)

Will let you know if there are some instabilities.


Just to reiterate - this forum is for official openwrt firmware support... stock firmware questions should be directed to the gl.inet support forum.


Yep ran off a new build at r26573. I noticed they updated the mediatek firmware to 2024-01-17, looks like just small bug fixes, but nice to see it updated too.

edit: actually I don't recommend installing today's snapshot either, I'm having a couple weird issues: can't SSH in (permission denied publickey), never seen this error in all my years of Linux/OpenWrt, although LuCI login still works. Also Adblock-Fast service won't start it keeps crashing. Maybe there is a regression. Otherwise things are fine but I'd wait a few days.


That means the only authentication method is public key, no passwords or anything else accepted.

No dropbear settings were changed?

1 Like

edit: Ugh I went back into LuCI SSH page and password auth and allow root were unchecked. No idea why as I didn't change my config, on well dumb mistake on my part it works now.


I'm confused. Normal r26581 snapshot is still using 2022 firmware.

This PR changed one of them.

I'm having other issues with this snapshot. Last week things were like perfect now with this my wifi is randomly becoming unresponsive. I don't see any changes that would affect this, the mediatek performance increase with napi they added shouldn't affect this. I still recommend holding for a few days if anyone is curious.

1 Like

That's not the WiFi module firmware but for the SoC


Yes I know, that's why I can't understand why my wifi is so unresponsive with this build.


How do you check the Mtk firmware version?

dmesg | grep -i firmware

This is to check the WiFi firmware version.