GL-iNet AX1800 new router - OpenWrt support?

I'll second that. Your efforts are really very much appreciated!
Many thanks...

1 Like

Check DM's peeps!!

Needs testing before sharing!

1 Like

Great! Will try later and report back...

1 Like

Just to let you know your firmware recovered my AXT1800.

I used the intramfs image via the bootloader and then the sysupgrade one to finalize it.

My build off of your build system didn't work but I can now recover with the UBI I can keep testing.

1 Like

New here. GL-iNet AXT1800

Would be interested in the firmware as I originally thought it was openwrt supported (not locked.. silly me)

I was tempted to send it back but I love the hardware and found this thread. I am willing to help.

New to all of this but in the same boat, about to send it back but would love to help this thread.

Can you please share the build with me?

Here you go.

Index of /snapshots/r21530 (

1 Like

Sorry, I have searched the above link and can't find a .tar or a .img file? Am i missing something?

You need the ubi file which you flash via uboot or the bin file which you flash via webgui.

I've tried solidus1983's firmware openwrt-snapshot-r21530-84162fdd7d-ipq60xx-generic-glinet_gl-ax1800-squashfs-nand-factory.ubi

  1. WiFi - speedtest - 300MBps - fineMy internet connection is 300MBps PPPoE
  2. WireGuard - 10Mb/s ~ 80MBps - I hoped for more
  3. USB Problem. Firmware doesn't detect my USB3 Drive.

root@AX:~# lsusb -t
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 480M

May be it didn't power on the port. When I touched the drive, i didn't feel any vibration as when connect it to my PC.
I've tried with USB Flash drive, but again no luck. In dmesg it didn't apear anything

Any suggestions?

Thank you for the reports back, as stated my builds are alpha quality at best due to all the issues, WolfSSL being one of them, USB being the other it's new SOC so there is going to be issues which is why it's not even in snapshots officially from openwrt.

I have made a new build today which should help with USB, the crypto performance is still an issue however which is being worked on in trying to find out why it's an issue.

Thank you for your effort to make a running clean openwrt for this powerful device.
I've tried your last build openwrt-snapshot-r21588-af44174187-ipq60xx-generic-glinet_gl-ax1800-squashfs-nand-factory.ubi
But again with no luck. I've noticed that my USB drive had LED for operation :). The led didn't lit on
If you think, that I can be more helpful, i can do some tests/check on working glinet 4.2 snapshot, with which i've trying to do my goals. I can check everything that you want with working USB drive.

Right, it might be due to the usb drivers being missing and file system modules, which can be added manually.

look up for qca or qcom and there should be dw3 for usb, make sure thats install and then install the usb storage stuff as well then retest.

I can't find the *.ubi file for the ax1800 in your folders.
Where is it? I want to test it on my ax1800.

AX1800 UBI

Tried the last two snapshot-files ax1800-squashfs-nand-factory.ubi but after reboot GL-inet's 4.10 stable firmware is still there. I must be missing something.

For now stay in 4.1. new builds will be made soon enough for testing.

Thank you very much, I'll be patient. Hope to find instructions for successful uboot upload by then.

If your using GL-iNets stock firmware you can just use the pin hole reset trick to get into uboot.

Change your Client PC to a static IP such as submask then head to and flash the factory image from there.