GL-B1300 with vlans, one of switch ports won't work

Version 22.03.5 r20134-5f15225c1e.
My br-lan bridges two switch vlans. WAN is connected to the modem.

I have set up vlans and firewalls for IoT, Guest and Normal networks.

Switch looks like this

VLAN 1: # eth0(CPU)
	vid: 1
	ports: 0t 3t 4t
VLAN 2: # wan / eth1 / port 5
	vid: 2
	ports: 0t 5
VLAN 103: # switch, left port
	vid: 103
	ports: 0t 3
VLAN 104: # switch, middle port
	vid: 104
	ports: 0t 4

With this config, a RPI with AdGuard works as a DNS. But I can't use another switch port for my desktop. Seems like no traffic leaves the port. And If I either separate switch vlans from br-lan. Or add any other interface that has something to do with the switch ports, I loose wan. It instantly looses my wire-connected DNS on RPI and practically as good as dead.

Network setup:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxx'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '103'
	option vid '103'
	option ports '0t 3'
	option description 'lan1p3'

config switch_vlan
	option device 'switch0'
	option vlan '104'
	option vid '104'
	option ports '0t 4'
	option description 'lan2p4'

config device
	option name 'br-lan'
	option type 'bridge'
	option igmp_snooping '1'
	option acceptlocal '1'
	option ipv6 '0'
	list ports 'eth0.103'
	list ports 'eth0.104'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option dns_metric '0'
	option ifname 'eth0.103'
	option ipaddr '192.168.2.1'
	option gateway '192.168.1.1'
	list dns '192.168.2.184'
	option device 'br-lan'

config device
	option type 'bridge'
	option name 'VLANS'
	list ports 'eth0.103'
	list ports 'VLANS.60'
	list ports 'VLANS.20'
	list ports 'VLANS.30'
	option igmp_snooping '1'
	option acceptlocal '1'
	option ipv6 '0'

config bridge-vlan
	option device 'VLANS'
	option vlan '20'
	list ports 'eth0.103:t'
	list ports 'VLANS.20:t'

config bridge-vlan
	option device 'VLANS'
	option vlan '30'
	list ports 'eth0.103:t'
	list ports 'VLANS.30:t'

config bridge-vlan
	option device 'VLANS'
	option vlan '60'
	list ports 'eth0.103:t'
	list ports 'VLANS.60:t'

config interface 'IoT'
	option proto 'static'
	option device 'VLANS.20'
	option ipaddr '192.168.20.4'
	option netmask '255.255.255.0'
	option gateway '192.168.20.1'
	option type 'bridge'

config interface 'WIFI'
	option proto 'static'
	option device 'VLANS.30'
	option ipaddr '192.168.30.4'
	option netmask '255.255.255.0'
	option gateway '192.168.30.1'

config interface 'wan'
	option proto 'static'
	option device 'eth1'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ipaddr '192.168.1.2'
	list dns '192.168.2.184'

config device
	option name 'eth1'
	option ipv6 '0'

Device wiki has a note about it, but it doesn't help:

I've tried the suggestions from various posts, to no avail:

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

2 Likes

The IPQ40xx was converted to DSA for version 23, and finally VLANs work properly. If you need tagged packets on the external ports you really need to upgrade to 23.05.2

1 Like

Thanks for pointing this out, I realised I'm on 22 instead of 23! Flashing now. And also thanks for pointing to firmware selector. It would be really nice to have it linked in LuCi's footer, right near the current version or in the flash menu.
FWIW I took my image from GL-B1300 wiki page.

Not just on 22… you see on gl-inet’s non-standard version of OpenWrt which is massively different.

Be sure to allow the flash process to reset to defaults - do not try to keep settings or restore a backup. It will not be compatible.

Worth adding to the feature requests section, although I’m not sure if it would be adopted.

The oem firmware links are usually also included on the device pages for those who wish to revert back to vendor firmware. I’m guessing you grabbed that at some point, possibly by accident.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.