GL-B1300: tagged VLAN on WAN not working

Hi,

I'm trying to configure a GL-B1300 (running 21.02.3) as wireless access point. The GL-B1300 WAN port is connected to my main router. This works fine, until I try to use VLAN's on the WAN port. The goal is to have a trunk with 3 tagged VLAN's: lan (vlan 1), guest (vlan 2) and iot (vlan 3), and then bridge those to their corresponding wifi network.

I started with this (working) configuration, without a vlan for the lan network:

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config interface 'guest'
	option proto 'none'
	option device 'br-guest'

config interface 'iot'
	option proto 'none'
	option device 'br-iot'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'eth1.2'

config device
	option type 'bridge'
	option name 'br-iot'
	list ports 'eth1.3'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '3 4 0'

But as soon as I try to use eth1.1, the connection fails:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'
	list ports 'eth1.1'

I have a similar configuration with another access point (Turris Omnia), and there everything works as expected.

There are couple of topics discussing issues with the GL-B1300 and ipq40xx:

But those issues are related to the switch, and as far as I can tell, the WAN port is not part of the switch.

Jef

1 Like

You need this.

Any idea whether this will make it into the 22.03 release?

Never.

23.xy.0, 24.xy.0 probably.