GL-AR750S settings are always lost after reboot

I am using the openwrt-21.02.3-ath79-nand-glinet_gl-ar750s-nor-nand-initramfs-kernel.bin file.

I bricked the device at first, so I did a reset and was able to succesfully install the file above using the u-boot debrick method (basically, hold reset button until the light flashes 5 times, see that 2.5ghz light turned on, stop holding button, go to I did some changes dns intercept, wireless, interfaces, firewall, etc, then when I pressed reboot all was lost

I found mentions of this issue in 2 forum posts, but I am not sure if I understood properly. My belief is that this was fixed on later updates of this firmware, especially because the latest post was testing a release candidate. If a solution was mentioned here, I couldn't catch it because I am a noob.

Is there any way I can fix this issue?
Would it be a good idea to try and flash the nand image instead?

initramfs doesn't save data to the flash, it's designed for running in the device's RAM.
whatever settings you change/apply, will get lost in a reboot.

oh :frowning:

Should I choose a sysupgrade then? Looks like the only option. Not sure if you can just change things from initramfs to squashfs

read the wiki I added to my post.

okay I see, I have to reset the router again. Can't do it through luci because of that unsupported format bug

can always export your settings 1st, to avoid redoing all the config you've made.

I wanted to reset anyways, I shouldn't had setup dns intercept settings without connecting and installing my pihole first (it was not even installed @_@.... silly mistakes). It became difficult to backtrack what I did and remove and disable things

When I upload openwrt-21.02.3-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade, nothing seems to happen. It shows the load animation and what you would expect, but the router never resets and going back to the page allows me to upload the file again. It's as if it's getting rejected or something

The lights do react when I upload the image, but it's not letting me go back to luci, it always shows that page

upload where ?

webUI or the debrick interface ?

there might be a flash layout issue, since you wrote initramfs to the flash, try going back to stock fw, then retry the openwrt flash, using the correct image.

I was using the debrick interface.

I'll try that today

just to confirm. to flash openwrt using uboot, I need to use the file "openwrt-21.02.3-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade.bin" right?

Because on GL.iNet, the file format they suggest for uboot is different (it's .img instead of .bin)

Update: Uploading stock firmware worked. I went back to uboot, and uploaded openwrt firmware. OpenWRT firmware has no effects

I got it to work.

I used uboot to flash the stock image.

After that I went to advanced settings to get to luci. In luci I went to backup / flash firmware and went to flash new firmware image, and uploaded the file openwrt-21.02.3-ath79-nand-glinet_gl-ar750s-nor-nand-squashfs-sysupgrade

Was this supposed to work? I thought I was supposed to get an error message if I tried this. I reread your reply now

then retry the openwrt flash, using the correct image.

Is this what you wanted me to do from the beggining? I thought I was supposed to use uboot. uboot always failed and did nothing.

Anyways, let me see if I can configure this whole thing in just 20 minutes because I am done waiting and I am eager to use it. I don't have much time. I have a recording of this btw, but I expected this to fail

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.