21.02.0 rc2 --> GL-AR750S

I successfully ubooted the 21.02.0 rc2 kernel from OpenWrt.

21.02.1 rc2 NOR kernel --> GL-AR750S =

  • won't hold an admin password or new subnet on reboot.
  • no 5Ghz
  • opkg update = no
  • software repository loads on luci
  • can't install ath10k-firmware-qca9887
  • can't install kmod-ath10k
  • has internet access

21.02.1 rc2 NOR NAND kernel --> GL-AR750S =

  • won't hold an admin password or new subnet on reboot.
  • no 5Ghz
  • opkg update = no
  • software repository loads on luci
  • can't install ath10k-firmware-qca9887
  • can't install kmod-ath10k
  • has internet access

I had to repeatedly clear firefox web cache. Fun. Is there a better way?

This is WIP. What should I test with it?

I wanted 5Ghz so I could drop in replace my TV AP/STA->LAN. I will try instead on 2.4Ghz.

**updated: not confident with results firefox was giving.
**clearing cache gave the above results.
**making a 2.4Ghz WLAN doesn't survive reboot.

these two don't really make sense together...

you really need serial to properly debug at this level...

I ordered a few serial to USB. Should be here in a few weeks.

1 Like

well technically the primary purpose was to examine your layout (/overlay space) ... dmesg boot jffs formatting output etc.

which I suppose you could probably get without the serial after all... ( but they are a worthwhile investment... bought 5 last year and half the time can't find one )

1 Like

Tried running it as an AP for the TV client = worked. stable during test.

Tried running it as client for the TV = connected but didn't work. laptop couldn't surf.

The tv is served by the LAN port.

Test 1: TV <-- ar750s / 19.07.7 client <--> ar750s / 21.02.0-rc2 AP

Test 2: TV <-- ar750s / 21.02.0-rc2 client <--> ea8300 / 19.07.7 AP

Test 1

type oAr750s test 1: AP, firewall

 -----------------------------------------------------
 OpenWrt 21.02.0-rc2, r16122-c2139eef27
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# cat /etc/config/firewall
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fxxx:/6
	option dest_ip		fxxx::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
	option name		Support-UDP-Traceroute
	option src		wan
	option dest_port	33434:33689
	option proto		udp
	option family		ipv4
	option target		REJECT
	option enabled		false

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	xxxxxxxxxxx
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	xxxxxxxxxxx
#	option dest_port	120
#	option proto	tcpr paste code here
tAr750s test 1: AP, network

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fxxxxxxxxx'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'
ype or paste code here
Ar750s test 1: AP, wireless


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxxxxxx'
	option hidden '1'
	option isolate '1'
	option encryption 'sae'
	option key 'xxxxxxxxxxxx'
	option ieee80211w '2'
	option wpa_disable_eapol_key_retries '1'


type or paste code here

Test 2

Ar750s test 2: STA MODE firewall

 -----------------------------------------------------
 OpenWrt 21.02.0-rc2, r16122-c2139eef27
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'
	list network 'wwan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fxxxxx::/6'
	option dest_ip 'fxxxxx::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'


type Ar750s test 2: STA MODE network


root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxx/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

config interface 'wwan'
	option proto 'dhcp'


or paste code here
Ar750s test 2: STA MODE wireless

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/18100000.wmac'
	option htmode 'HT20'
	option txpower '20'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'sta'
	option network 'wwan'
	option bssid 'xxxxxxxxxxxx'
	option ssid 'xxxxxxxxxx'
	option encryption 'sae'
	option key 'xxxxxxxxxxxx'
	option ieee80211w '2'

Configured using LuCI. I saved the logs too.

HTH

in summary?;

21.02.0-rc2 AR750S

  • cannot save settings
  • wifi does not work in client mode

there have been some fixes since rc2 re: wifi...

more concerned at this stage with not saving settings... so we need to see;

mount
df -h

style commands... ( and whether NAND or NOR image was used are two image types etc. etc.)

seem to recall similar threads regarding this device for master going back a while... (confusion about what image types are available, how to go from one to another etc.) so better for me to leave it to someone familiar with this device...

for the wireless stuff... best to wait for the next release before testing further...

1 Like

I am running openwrt-21.02.0-rc2-ath79-nand-glinet_gl-ar750s-nor-squashfs-sysupgrade.bin image on GL-AR750S configured as Access Point without problem. Not sure what you mean with kernel.
Pehaps it's a matter of configuration. If I can provide any CLI output, let me know.

1 Like
  • turn down verbosity
  • configured admin pw using LuCI
  • configured 2.4Ghz AP using LuCI
  • 21.02.0-rc2 NOR NAND kernel
  • WAN not connected
  • 2.4Ghz LED not on
  • 5Gz LED on

Console accepts admin pw:xxxxxxxxxx6666666666

dmesg

root@192.168.1.1's password: 


BusyBox v1.33.1 (2021-05-28 14:04:04 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.0-rc2, r16122-c2139eef27
 -----------------------------------------------------
root@OpenWrt:~# dmesg
[    0.000000] Linux version 5.4.119 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16122-c2139eef27)) #0 Fri May 28 14:04:04 2021
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] MIPS: machine is GL.iNet GL-AR750S (NOR/NAND)
[    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] On node 0 totalpages: 32768
[    0.000000]   Normal zone: 288 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32768 pages, LIFO batch:7
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 112836K/131072K available (5482K kernel code, 179K rwdata, 704K rodata, 10328K init, 210K bss, 18236K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] random: get_random_bytes called from 0x8069aa28 with crng_init=0
[    0.000000] CPU clock: 775.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4932285024 ns
[    0.000007] sched_clock: 32 bits at 387MHz, resolution 2ns, wraps every 5541893118ns
[    0.008228] Calibrating delay loop... 385.02 BogoMIPS (lpj=770048)
[    0.046713] pid_max: default: 32768 minimum: 301
[    0.051715] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.059426] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.071499] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.081812] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.089091] pinctrl core: initialized pinctrl subsystem
[    0.095826] NET: Registered protocol family 16
[    0.102155] GPIO line 7 (usb-vbus) hogged as output/high
[    0.130100] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[    0.143116] clocksource: Switched to clocksource MIPS
[    0.149521] NET: Registered protocol family 2
[    0.154308] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.162618] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.171502] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.179594] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.187035] TCP: Hash tables configured (established 1024 bind 1024)
[    0.193869] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.200805] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.208452] NET: Registered protocol family 1
[    0.213112] PCI: CLS 0 bytes, default 32
[    0.394945] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.407878] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.414070] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.437548] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.448700] pinctrl-single 1804002c.pinmux: 544 pins, size 68
[    0.455819] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.464616] printk: console [ttyS0] disabled
[    0.469206] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
[    0.478320] printk: console [ttyS0] enabled
[    0.487381] printk: bootconsole [early0] disabled
[    0.507078] spi-nand spi0.1: GigaDevice SPI NAND was found.
[    0.512897] spi-nand spi0.1: 128 MiB, block size: 128 KiB, page size: 2048, OOB size: 128
[    0.522472] 1 fixed-partitions partitions found on MTD device spi0.1
[    0.529085] Creating 1 MTD partitions on "spi0.1":
[    0.534060] 0x000000000000-0x000008000000 : "ubi"
[    0.696170] spi-nor spi0.0: w25q128 (16384 Kbytes)
[    0.701177] 5 fixed-partitions partitions found on MTD device spi0.0
[    0.707742] Creating 5 MTD partitions on "spi0.0":
[    0.712704] 0x000000000000-0x000000040000 : "u-boot"
[    0.718683] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.725030] 0x000000050000-0x000000060000 : "art"
[    0.730767] 0x000000060000-0x000000460000 : "kernel"
[    0.736743] 0x000000460000-0x000001000000 : "nor_reserved"
[    0.744096] libphy: Fixed MDIO Bus: probed
[    1.151108] random: fast init done
[    1.383480] libphy: ag71xx_mdio: probed
[    1.407052] switch0: Atheros AR8337 rev. 2 switch registered on mdio.0
[    1.994613] ag71xx 19000000.eth: connected to PHY at mdio.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
[    2.005897] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: mii
[    2.014193] NET: Registered protocol family 10
[    2.023354] Segment Routing with IPv6
[    2.027292] NET: Registered protocol family 17
[    2.031963] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    2.045357] 8021q: 802.1Q VLAN Support v1.8
[    2.052025] PCI host bridge /ahb/pcie-controller@18250000 ranges:
[    2.058386]  MEM 0x0000000012000000..0x0000000013ffffff
[    2.063792]   IO 0x0000000000000000..0x0000000000000000
[    2.069347] PCI host bridge to bus 0000:00
[    2.073616] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
[    2.080723] pci_bus 0000:00: root bus resource [io  0x0000]
[    2.086483] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    2.093499] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    2.101714] pci 0000:00:00.0: [168c:0050] type 00 class 0x028000
[    2.107974] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    2.115043] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    2.122044] pci 0000:00:00.0: supports D1
[    2.126196] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    2.133080] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    2.139964] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    2.147544] pci 0000:00:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[    2.157460] UBI: auto-attach mtd0
[    2.160958] ubi0: attaching mtd0
[    4.183006] ubi0: scanning is finished
[    4.211867] ubi0: attached mtd0 (name "ubi", size 128 MiB)
[    4.217582] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    4.224693] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    4.231711] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    4.238904] ubi0: good PEBs: 1023, bad PEBs: 1, corrupted PEBs: 0
[    4.245202] ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
[    4.252667] ubi0: max/mean erase counter: 18/8, WL threshold: 4096, image sequence number: 455825797
[    4.262102] ubi0: available PEBs: 1000, total reserved PEBs: 23, PEBs reserved for bad PEB handling: 19
[    4.272147] ubi0: background thread "ubi_bgt0d" started, PID 365
[    4.335050] Freeing unused kernel memory: 10328K
[    4.339845] This architecture does not have kernel memory protection.
[    4.346492] Run /init as init process
[    4.819083] init: Console is alive
[    4.822914] init: - watchdog -
[    4.843326] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.853056] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.870958] init: - preinit -
[    5.113039] random: jshn: uninitialized urandom read (4 bytes read)
[    5.179377] random: jshn: uninitialized urandom read (4 bytes read)
[    5.297375] random: jshn: uninitialized urandom read (4 bytes read)
[    8.546525] procd: - early -
[    8.549654] procd: - watchdog -
[    9.119220] procd: - watchdog -
[    9.122805] procd: - ubus -
[    9.133369] urandom_read: 3 callbacks suppressed
[    9.133376] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.176480] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.183551] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.192967] procd: - init -
[    9.718551] kmodloader: loading kernel modules from /etc/modules.d/*
[    9.764745] Loading modules backported from Linux version v5.10.34-0-g0aa66717f684
[    9.772629] Backport generated by backports.git v5.10.34-1-0-g7b5533e1
[    9.831084] xt_time: kernel timezone is -0000
[    9.953175] PPP generic driver version 2.4.2
[    9.964089] NET: Registered protocol family 24
[    9.971541] urngd: v1.0.2 started.
[   10.060160] ath: EEPROM regdomain sanitized
[   10.060170] ath: EEPROM regdomain: 0x64
[   10.060173] ath: EEPROM indicates we should expect a direct regpair map
[   10.060192] ath: Country alpha2 being used: 00
[   10.060194] ath: Regpair used: 0x64
[   10.071401] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   10.073256] ieee80211 phy0: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
[   10.135451] kmodloader: done loading kernel modules from /etc/modules.d/*
[   10.246727] random: crng init done
[   10.250306] random: 1 urandom warning(s) missed due to ratelimiting
[   56.775932] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 1 is up
[   56.797804] br-lan: port 1(eth0.1) entered blocking state
[   56.803432] br-lan: port 1(eth0.1) entered disabled state
[   56.809316] device eth0.1 entered promiscuous mode
[   56.814305] device eth0 entered promiscuous mode
[   56.820206] eth0: link up (1000Mbps/Full duplex)
[   56.839191] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   56.895246] br-lan: port 1(eth0.1) entered blocking state
[   56.900855] br-lan: port 1(eth0.1) entered forwarding state
[   57.775357] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[  140.781893] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 1 is down
[  176.621848] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
[  319.213093] br-lan: port 2(wlan0) entered blocking state
[  319.218738] br-lan: port 2(wlan0) entered disabled state
[  319.224568] device wlan0 entered promiscuous mode
[  319.301668] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  319.308547] br-lan: port 2(wlan0) entered blocking state
[  319.314085] br-lan: port 2(wlan0) entered forwarding state

mount

root@OpenWrt:~# mount
tmpfs on / type tmpfs (rw,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,noatime,mode=700)

df -h

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    60.1M     11.5M     48.7M  19% /
tmpfs                    60.1M    240.0K     59.9M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

1 Like

fwiw my configs for AP are small

root@slate:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config include
        option path '/etc/firewall.user'

root@slate:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd69:8e1b:7e24::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.168.126'
        option gateway '192.168.168.1'
        list dns '192.168.168.129'
        list dns_search 'xxx.yy'
        option delegate '0'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 3 2 1'

root@slate:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'hangar'
        option encryption 'psk2'
        option key 'xxxxxxxxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'hangar'
        option encryption 'psk2'
        option key 'xxxxxxxxx'
1 Like
  • left power on and instructed LuCI to reboot and all settings back to default / no admin pw set
  • it's a clean SLATE :rofl:
BusyBox v1.33.1 (2021-05-28 14:04:04 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.0-rc2, r16122-c2139eef27
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# dmesg
[    0.000000] Linux version 5.4.119 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r16122-c2139eef27)) #0 Fri May 28 14:04:04 2021
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] MIPS: machine is GL.iNet GL-AR750S (NOR/NAND)
[    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] On node 0 totalpages: 32768
[    0.000000]   Normal zone: 288 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32768 pages, LIFO batch:7
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 112836K/131072K available (5482K kernel code, 179K rwdata, 704K rodata, 10328K init, 210K bss, 18236K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] random: get_random_bytes called from 0x8069aa28 with crng_init=0
[    0.000000] CPU clock: 775.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4932285024 ns
[    0.000007] sched_clock: 32 bits at 387MHz, resolution 2ns, wraps every 5541893118ns
[    0.008229] Calibrating delay loop... 385.02 BogoMIPS (lpj=770048)
[    0.046713] pid_max: default: 32768 minimum: 301
[    0.051713] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.059425] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.071506] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.081821] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.089099] pinctrl core: initialized pinctrl subsystem
[    0.095834] NET: Registered protocol family 16
[    0.102162] GPIO line 7 (usb-vbus) hogged as output/high
[    0.130101] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[    0.143121] clocksource: Switched to clocksource MIPS
[    0.149520] NET: Registered protocol family 2
[    0.154307] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.162610] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.171494] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.179586] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.187026] TCP: Hash tables configured (established 1024 bind 1024)
[    0.193858] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.200796] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.208443] NET: Registered protocol family 1
[    0.213105] PCI: CLS 0 bytes, default 32
[    0.394602] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.407540] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.413726] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.437226] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.448390] pinctrl-single 1804002c.pinmux: 544 pins, size 68
[    0.455508] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.464300] printk: console [ttyS0] disabled
[    0.468889] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
[    0.478004] printk: console [ttyS0] enabled
[    0.487063] printk: bootconsole [early0] disabled
[    0.506825] spi-nand spi0.1: GigaDevice SPI NAND was found.
[    0.512652] spi-nand spi0.1: 128 MiB, block size: 128 KiB, page size: 2048, OOB size: 128
[    0.522227] 1 fixed-partitions partitions found on MTD device spi0.1
[    0.528841] Creating 1 MTD partitions on "spi0.1":
[    0.533814] 0x000000000000-0x000008000000 : "ubi"
[    0.696455] spi-nor spi0.0: w25q128 (16384 Kbytes)
[    0.701462] 5 fixed-partitions partitions found on MTD device spi0.0
[    0.708027] Creating 5 MTD partitions on "spi0.0":
[    0.712988] 0x000000000000-0x000000040000 : "u-boot"
[    0.718962] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.725299] 0x000000050000-0x000000060000 : "art"
[    0.731030] 0x000000060000-0x000000460000 : "kernel"
[    0.737003] 0x000000460000-0x000001000000 : "nor_reserved"
[    0.744372] libphy: Fixed MDIO Bus: probed
[    1.151114] random: fast init done
[    1.383487] libphy: ag71xx_mdio: probed
[    1.407289] switch0: Atheros AR8337 rev. 2 switch registered on mdio.0
[    1.994618] ag71xx 19000000.eth: connected to PHY at mdio.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
[    2.005899] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: mii
[    2.014194] NET: Registered protocol family 10
[    2.023360] Segment Routing with IPv6
[    2.027299] NET: Registered protocol family 17
[    2.031969] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    2.045363] 8021q: 802.1Q VLAN Support v1.8
[    2.052030] PCI host bridge /ahb/pcie-controller@18250000 ranges:
[    2.058391]  MEM 0x0000000012000000..0x0000000013ffffff
[    2.063798]   IO 0x0000000000000000..0x0000000000000000
[    2.069354] PCI host bridge to bus 0000:00
[    2.073622] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
[    2.080730] pci_bus 0000:00: root bus resource [io  0x0000]
[    2.086491] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    2.093504] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    2.101719] pci 0000:00:00.0: [168c:0050] type 00 class 0x028000
[    2.107980] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    2.115049] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    2.122051] pci 0000:00:00.0: supports D1
[    2.126202] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    2.133083] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    2.139970] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    2.147551] pci 0000:00:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[    2.157456] UBI: auto-attach mtd0
[    2.160943] ubi0: attaching mtd0
[    4.182014] ubi0: scanning is finished
[    4.210866] ubi0: attached mtd0 (name "ubi", size 128 MiB)
[    4.216591] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    4.223698] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    4.230711] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    4.237905] ubi0: good PEBs: 1023, bad PEBs: 1, corrupted PEBs: 0
[    4.244204] ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
[    4.251670] ubi0: max/mean erase counter: 18/8, WL threshold: 4096, image sequence number: 455825797
[    4.261104] ubi0: available PEBs: 1000, total reserved PEBs: 23, PEBs reserved for bad PEB handling: 19
[    4.271177] ubi0: background thread "ubi_bgt0d" started, PID 365
[    4.334086] Freeing unused kernel memory: 10328K
[    4.338882] This architecture does not have kernel memory protection.
[    4.345533] Run /init as init process
[    4.812888] init: Console is alive
[    4.816715] init: - watchdog -
[    4.837042] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.846730] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.864629] init: - preinit -
[    5.106134] random: jshn: uninitialized urandom read (4 bytes read)
[    5.173347] random: jshn: uninitialized urandom read (4 bytes read)
[    5.298441] random: jshn: uninitialized urandom read (4 bytes read)
[    8.539349] procd: - early -
[    8.542416] procd: - watchdog -
[    9.112180] procd: - watchdog -
[    9.115812] procd: - ubus -
[    9.126346] urandom_read: 3 callbacks suppressed
[    9.126353] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.169460] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.176529] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.186029] procd: - init -
[    9.726047] kmodloader: loading kernel modules from /etc/modules.d/*
[    9.768844] Loading modules backported from Linux version v5.10.34-0-g0aa66717f684
[    9.776724] Backport generated by backports.git v5.10.34-1-0-g7b5533e1
[    9.830720] xt_time: kernel timezone is -0000
[    9.953197] PPP generic driver version 2.4.2
[    9.964886] urngd: v1.0.2 started.
[    9.969138] NET: Registered protocol family 24
[   10.060147] ath: EEPROM regdomain sanitized
[   10.060157] ath: EEPROM regdomain: 0x64
[   10.060161] ath: EEPROM indicates we should expect a direct regpair map
[   10.060180] ath: Country alpha2 being used: 00
[   10.060182] ath: Regpair used: 0x64
[   10.071297] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   10.073155] ieee80211 phy0: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
[   10.135458] kmodloader: done loading kernel modules from /etc/modules.d/*
[   10.246908] random: crng init done
[   10.250490] random: 1 urandom warning(s) missed due to ratelimiting
[   42.308157] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up
[   42.329368] br-lan: port 1(eth0.1) entered blocking state
[   42.335004] br-lan: port 1(eth0.1) entered disabled state
[   42.340891] device eth0.1 entered promiscuous mode
[   42.345885] device eth0 entered promiscuous mode
[   42.355183] eth0: link up (1000Mbps/Full duplex)
[   42.371187] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   42.414675] br-lan: port 1(eth0.1) entered blocking state
[   42.420306] br-lan: port 1(eth0.1) entered forwarding state
[   43.311203] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[  189.807917] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is down
[  199.023616] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 2 is up








mount


root@OpenWrt:~# mount
tmpfs on / type tmpfs (rw,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,noatime,mode=700)





df -h


root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    60.1M     11.4M     48.7M  19% /
tmpfs                    60.1M    224.0K     59.9M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

I do not recall everything in detail and order but basically, form default I did

  • set password
  • disable firewall and firewall rules
  • delete wan interfaces
  • disable VLAN but keep one ID
  • disable DHCP sever
  • bridge ethernet and wireless
  • configure wireless
  • untick various unused features (like v6 delegation I think)
  • assign static v4 address

In short: disable/delete a lot layer 3. Only keep layer 2 bridging.

Is your SLATE keeping its settings after reboot?

yes I see no issues or inconsistencies or loss or change of config

I ubooted the rc2 kernel directly. Whereas you upgraded to rc2 from rc1?

Again, I am not booting kernel I am flashing (nor) 21.02.0-rc2 u-boot image using u-boot debrick method [hold reset and power on until after led flashes 5 times]. Then flash u-boot image using u-boot 192.168.1.1 web interface, I had previously (because I had bricked device) booted GL u-boot image 19.07.7 same way and set network to access point. But not sure if that matters since u-boot debrick method seems to erase all. fwiw, I upgraded another device (GL-X750) from 19.07.7 to 21.02.0-rc2 nomal way. So I guess nomal upgrade rc1 to rc2 and so further will also work.