Github Install Package

Good day all ...

I'm trying to install package from out of OpenWrt list of packages (Github) because this package specification is good ....I'm using last update from OpenWrt (Ker: 6.6.35) with all required packages (git , git-http and bash) This Package is not ipk (I didn't find ipk on it folder on github) .

Package Link :

I tried this command on PUTTY

root@OpenWrt:~# wget
--2024-06-28 17:28:27--
Connecting to||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: 'luci-app-3ginfo-lite.3'

luci-app-3ginfo-lite.3            [ <=>                                              ] 150.36K   881KB/s    in 0.2s

2024-06-28 17:28:27 (881 KB/s) - 'luci-app-3ginfo-lite.3' saved [153964]

I tried after this ---> opkg install luci-app-3ginfo-lite -----> got msg not found

What I should do next to get this package appear on Luci Interface

ImmortalWrt is not the same as OpenWrt. If you are using official OpenWrt and trying to install a package from the ImmortalWrt repo, it probably will not work.

That said, regardless if your situation fits the description above or you are actually running ImmortalWrt, you need to ask them for help since it is not from the official OpenWrt project.

I'm using OpenWrt Image ..

There are many of packages are not from OpenWrt and not listed on their list of package . I passed to install them and they worked fine ..... where these packages were ipk

Package name was : luci-app-interfaces-statistics]
Network interfaces statistics for LuCI

When you try to install packages that are from other repos, it may or may not work... it depends on the details of the package and its dependencies.

But, when problems arise installing a package that is from an external source, you need to ask the maintainers of the repo/package for help.

1 Like

Dude , There is no problem with package .... The issue I don't know how to install that package on OpenWrt from Github.... either to help me with steps or thank you let other people help me ....

Note: No problem if the package doesn't work but at least let me try to go with steps so I know later how I can install any package ....

Dear @psherman Thank you for your fast response ..

How did you get the luci-app-interfaces-statistics installed?

In general, the process is:

  1. download package (often to /tmp/)
  2. install it with the command opkg install </path/to/package>

I found the command of installation was ready for luci-app-interfaces-statistics

Sir , the steps are not clear ... I appreciate more explanation

Why are you using that and not using luci-app-statistics from the software tab?

Dear ,
this package has more information and details (which already installed) ....

My target now to install LTE package from github

Okay, how is this install different than the other installs you got before?

Anyway, @psherman told you how to download the package locally and install it locally.

Instead of posting screenshots, please post the results of the commands in text format:

Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.
Please edit your post accordingly. Thank you! :slight_smile:

Meanwhile, you need to download the package on OpenWrt, or copy it to OpenWrt via scp. It has no way to get the package from your computer's path.

For first point Noted , As per Fred R. Barnard picture is worth a thousand words

For 2nd point as I remember already I mentioned the package downloaded

root@OpenWrt:~# wget
--2024-06-28 19:00:58--
Connecting to||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: 'luci-app-3ginfo-lite.5'

luci-app-3ginfo-lite.5          [  <=>                                    ] 244.79K  1.01MB/s    in 0.2s

2024-06-28 19:00:59 (1.01 MB/s) - 'luci-app-3ginfo-lite.5' saved [250669]

What is next

Looks like you dumped it in your root dir.

opkg install luci-app-3ginfo-lite.5

from root.

, Already there was command for installation was ready ,, check previous reply to @psherman ----->

You need to find the path to where you dumped it.

Dear @LilRedDog

I tried opkg install luci-app-3ginfo-lite.5

root@OpenWrt:~# opkg install luci-app-3ginfo-lite.5
Unknown package 'luci-app-3ginfo-lite.5'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci-app-3ginfo-lite.5.
root@OpenWrt:~# opkg install luci-app-3ginfo-lite
Unknown package 'luci-app-3ginfo-lite'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci-app-3ginfo-lite.

Where ? I'm not professional
I appreciate your time and I will try to follow the steps --- if you can tell me

I'd tell you if I knew where it is; I don't play games.

1 Like

See if you have that path.

Is that your 5th time downloading the folder?

1 Like

Dear @LilRedDog

I tried this and i'm not sure .... ( My computer is Windows 11)

root@OpenWrt:~# /immortalwrt/wwan-packages/tree/master/ap
-ash: /immortalwrt/wwan-packages/tree/master/ap: not found
root@OpenWrt:~# plications/
-ash: plications/: not found
root@OpenWrt:~# opkg install /immortalwrt/wwan-packages/tree/master/ap
Unknown package '/immortalwrt/wwan-packages/tree/master/ap'.
Collected errors:
 * opkg_install_cmd: Cannot install package /immortalwrt/wwan-packages/tree/mast                         er/ap.
**root@OpenWrt:~# plications/**

I downloaded it more than 3 times