Fritz!box 7412 Fonial.De ADSL2+/ATM/AAL5 DSL Configuration

DSL/ATM/ADSL2+ puzzle

are there "most commonly known problems" for Showtime with TC-Layer sync state and no RX (no PPPOE)?

  • Any way to enable debug mode for ATM connection? or any command to exchange any "low level ping / test" data to verify the correctness of ATM/dsl0.7 config? *Even with "debug" log level there's not much in the log. dsl0.7 gets initialized though.
  • I guess PPPoE doesn't even matter on this stage (Timeout waiting for PADO packets).
  • there is some TX from the router, but according to provider there are no "login attempts".
  • if I plug the dsl cabel from a working device (fritzos) to a non-working (openwrt) - then I get some RX right away (after a quick synchronization). So the dslam is still trying to send something and openwrt modem picks that up and shows like traffic (even still no pppoe)

clarifications

  • any dsl "advanced parameters" to learn/look into?
    mtu 1500 / tx queue length 1000

  • Should option xfer_mode 'atm' be explicitly set (network.dsl.xfer_mode='atm')?

  • atm device / bridge unit - empty

the stack

1. ADSL2+ link (Annex B, Profile ??, ITU Line mode G.993.5)
2. ATM (vci 32 vpi 1 LLC)
3. Ethernet with VLAN 7
4. PPPOE

logread ppp:

pppd[21661]: Timeout waiting for PADO packets
Sat Mar 16 17:06:22 2024 daemon.err pppd[21661]: Unable to complete PPPoE Discovery
Sat Mar 16 17:06:22 2024 daemon.info pppd[21661]: Exit.

current setup

what "works":

  • pppoe/internet worked on this openwrt device with telekom + vdsl
  • an alternative fritzbox with the stock fritzos connects OK (internet, pppoe): annex b, tone b43 (others too).
  • verified credentials in pppoe login wireshark via stock fritzos -> same as provided by the isp.

/etc/config/network

config dsl 'dsl'
        option firmware '/lib/firmware/vr9-B-dsl.bin'
        option tone 'bv'
        #option tone 'V43'
        option annex 'b2p'
        #option annex 'j'
        option ds_snr_offset '0'

config atm-bridge
        option encaps 'llc'
        option payload 'bridged'
        option vci '32'
        option vpi '1'
        option nameprefix 'dsl'

config device
        option name 'dsl0'
        option macaddr 'C8:0E:14:34:BA:B8'

config interface 'wan'
        option proto 'pppoe'
        option device 'dsl0.7'
        option username 'Y@fonial.de'
        option password 'X'
        option ipv6 'auto'
        option delegate '0'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'

config device
        option name 'dsl0.7'
        option type '8021q'
        option ifname 'dsl0'
        option vid '7'
        option mtu '1500'
        option macaddr 'C8:0E:14:33:BA:B8'

notes

  • in the configuration manual for fritzbox: "Plusnet" or "qsc.de" should be selected. Are there any other settings could be influenced by this?
  • the isp stresses that hw should support annex j, but in the configuration one should select "adsl2+/vdsl". I played with all of them (A43C/J43/A43/V43)
  • tried with 2 firmwares (lantiq redistributable and from the fb firmware).

Used in the research

/etc/init.d/dsl_control dslstat

{
        "api_version": "4.17.18.6",
        "firmware_version": "5.9.0.13.0.2",
        "chipset": "Lantiq-VRX200",
        "driver_version": "1.5.17.6",
        "state": "Showtime with TC-Layer sync",
        "state_num": 7,
        "up": true,
        "uptime": 637,
        "atu_c": {
                "vendor_id": [
                        181,
                        0,
                        66,
                        68,
                        67,
                        77,
                        147,
                        239
                ],
                "vendor": "Broadcom 147.239",
                "system_vendor_id": [
                        0,
                        0,
                        48,
                        48,
                        48,
                        48,
                        0,
                        0
                ],
                "version": [
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0,
                        0
                ],
                "serial": [
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48,
                        48
                ]
        },
        "power_state": "L0 - Synchronized",
        "power_state_num": 0,
        "xtse": [
                0,
                0,
                0,
                0,
                0,
                4,
                0,
                0
        ],
        "annex": "B",
        "standard": "G.992.5",
        "mode": "G.992.5 (ADSL2+)",
        "upstream": {
                "trellis": true,
                "bitswap": true,
                "retx": false,
                "virtual_noise": false,
                "ra_mode_num": 4294967295,
                "interleave_delay": 500,
                "inp": 0.000000,
                "data_rate": 1287000,
                "latn": 16.800000,
                "satn": 16.600000,
                "snr": 6.800000,
                "actps": -38.000000,
                "actatp": 12.600000,
                "attndr": 1291000
        },
        "downstream": {
                "trellis": true,
                "bitswap": false,
                "retx": false,
                "virtual_noise": false,
                "ra_mode_num": 4294967295,
                "interleave_delay": 250,
                "inp": 0.000000,
                "data_rate": 12815000,
                "latn": 20.600000,
                "satn": 18.800000,
                "snr": 6.700000,
                "actps": -41.400000,
                "actatp": 18.600000,
                "attndr": 13180000
        },
        "olr": {
                "downstream": {
                        "bitswap": {
                                "requested": 0,
                                "executed": 0,
                                "rejected": 0,
                                "timeout": 0
                        },
                        "sra": {
                                "requested": 0,
                                "executed": 0,
                                "rejected": 0,
                                "timeout": 0
                        },
                        "sos": {
                                "requested": 0,
                                "executed": 0,
                                "rejected": 0,
                                "timeout": 0
                        }
                },
                "upstream": {
                        "bitswap": {
                                "requested": 2,
                                "executed": 1,
                                "rejected": 0,
                                "timeout": 0
                        },
                        "sra": {
                                "requested": 0,
                                "executed": 0,
                                "rejected": 0,
                                "timeout": 0
                        },
                        "sos": {
                                "requested": 0,
                                "executed": 0,
                                "rejected": 0,
                                "timeout": 0
                        }
                }
        },
        "errors": {
                "near": {
                        "es": 25,
                        "ses": 0,
                        "loss": 0,
                        "uas": 117,
                        "lofs": 0,
                        "fecs": 0,
                        "cv_c": 42,
                        "fec_c": 0,
                        "hec": 231,
                        "ibe": 3510185699,
                        "crc_p": 0,
                        "crcp_p": 0,
                        "cv_p": 0,
                        "cvp_p": 0
                },
                "far": {
                        "es": 55506,
                        "ses": 27434,
                        "loss": 39,
                        "uas": 117,
                        "lofs": 0,
                        "fecs": 133496,
                        "cv_c": 119537,
                        "fec_c": 2626599,
                        "hec": 2451505,
                        "ibe": 129738364,
                        "crc_p": 0,
                        "crcp_p": 0,
                        "cv_p": 0,
                        "cvp_p": 0,
                        "rx_corrupted": 0,
                        "rx_uncorrected_protected": 0,
                        "rx_retransmitted": 0,
                        "rx_corrected": 0,
                        "tx_retransmitted": 0
                }
        }
}

any pointers / tools / settings / commands to try out are welcome. Thank you!

Interestingly,

in the stock Fritzbox firmware,
if manual VCI/VPI are set and VLAN not specified/not set (check box off)
the connection works.

As soon as the "expected/required" VLAN 7 explicitly activated/set,
the connection fails with almost similar PPP errors.

Could that be suggesting that the VLAN needs to be set on the PPPoE interface and not the DSL interface?

Magically the solution was not using any VLAN at all.

Neither

config device
        option name 'dsl0.7'
        option ifname 'dsl0'

nor

config interface 'dsl0_7'
    option ifname 'dsl0.7'

@pythonic still thank you for that remark, it's very helpful for understanding the stacking better.

Mmmh, do you know who operates the DSL port by chance? VLAN 7 is used by telekom, but other operator with their own access network might not....
On the other hand Telekom required VLAN 7 for a long time, but helpfully inserted it if it was missing, so if your own VLAN specification was somehow incorrect this mechanism might work in the background....

But since this is ADSL and henve ATM/AAL5 we do not need to guess completely devoid of infoemation...
Just follow the instructions here:

and post the resulting plots to the thread. In case you run into issues with octave, just send me a link to the data file.... (as always when sharing information with strangers, have a look inside that file first to convince yourself that it does not exfiltrate anything you do not want to reveal)

@moeller0 Fonial can use all networks, but mainly the Telekom network (as in this case). I'll try the detector.

Just to round this up more and provide help for anyone who encounters this in the future:

I actually found the technical documentation / interface description (german) "deep" in the links (the support failed even to send it per support requests):

interface description

Configure the end device to use the ATM layer 2 protocol (VPI 1, VCI 32) along with PPPoE over ATM (PPPoEoA). Do not use Multilink PPP or PPP over ATM (PPPoA).

For fonial products based on a Deutsche Telekom AG upstream product, there's an exception: If the connection is provided with Annex J, the PPPoE session should be established in VLAN 7—hence, the parameters VPI 1, VCI 32, VLAN 7 apply.

fonial strongly recommends configuring the end device so that the dial-in is negotiated both untagged/native, without a VLAN tag, and tagged with VLAN 7, until a PPPoEoA connection has been successfully established. This process should be repeated every time the PPPoEoA connection is interrupted.

  • So does it actually make sense to set up 2 wan interfaces (a. no vlan + b. wan7) and bridge them? Because "fonial strongly recommends" and one day they flip 992.5 to 3.

"both untagged/native"

but helpfully inserted [VLAN7] it if it was missing

You mean in the PPPoE? Because with the native/old VDSL/Telekom I used the device dsl0.7 (but after pythonic's comment not 100% sure if it was an interface, it was a stock openwrt).

offtopic

It's all pretty convoluded, everywhere you see "device must support Annex J, we offer Annex J etc. (G.992.3)", however it all may vary and in my case Annex B used with obviously different configurations for 992.3/5.

not sure if it's because the company is still "relatively new" on the market (10 years, started with VOIP, with typos in agbs / minimal / essential info / NO SEARCH) or they have some "agreements" pushing own "supported" hardware and "kind of" complying with the law of Router Freedom, but the support couldn't even provide the correct VLAN value from their own help.

bonus fun

chat with the avm support:

  • [user] what VLAN is used when in your fritzbox provider X is selected?
  • [avm] we have the infos. :rofl::rofl::rofl:

Thanks. So, my take, your current link is via a DSLAM not operated by deutsche Telekom hence no VLAN7. This can IMO arise if either:
a) Telekom does not operate TALs in your area (then someone else would need to offer VDSL from outdoor DSLAMs)
or
b) Telekom operates Outdoor DSLAMs, but somebody else (maybe even fonial) still operates ADSL DSLAMs inside the CO/Betriebsstelle, and fonial rents/operates your line from there.

My guess is b) and the verbiage in the Schnittstellenbeschreibung aims to prepare for the likely shutdown of such CO-based DSLAMs in Telekom VDSL areas, but that is speculation.

Anyway, I would not bother with VLAN7 right now, but keep it in mind as a potentiakl remedy, should your link stop working....

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.