Fresh OpenWrt install, wifi works, no internet connection

Hello, I have freshly installed OpenWRT for the second time. The first install I tried to fix the problem and quickly got over my head, I got to the point I could no longer log into the router. I could see the wifi networks and connect no problem, but I had no internet. The wifi emblem said, no internet connection but the connection speed was excellent.

At this time, I reinstalled OpenWRT onto my x4s/R7800 and only set a password, nothing further. However I anticipate the same problem, which I think has to do either with DHCP/DNS settings or not changing my IP address somewhere (cable modem/origin or the R7800).

My ideal configuration is attached. I am fine with reading and I have spent hours on this already only to be back at square one, if there is a guide that would be specific to my situation I'd really appreciate it.

I should also mention that I used the TFTP setup instructions for the OpenWRT firmware install on the x4s, which had the following inputs:

IP address:
Subnet mask:
Default Gateway:

This should be pretty straight forward. Did you follow the dumb AP guide?

1 Like

Are you sure your CableModem IP is

Login to Luci on R7800 and go to Network>Diagnostics and PING to verify

Thanks for the suggestion.

I followed to a "T". Not sure if I missed it or not, but initially it wasn't working after following the guide. I stumbled upon a message somewhere on the forum that said while in Dumb AP mode you must connect to the LAN port from the main router/modem.

I switched the internet line to one of the LAN ports and bingo!

That's enough for a night, I'll work on the next steps (adding second dumb AP) tomorrow.


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like